You are not logged in.

#1 2010-03-12 06:34:18

nitroguy
Member
Registered: 2009-10-16
Posts: 16

[SOLVED] How can I disable Touchpad

For some reason, a recent update made my touchpad life a super-hell.  Previously, the thing was disabled but now all the sudden it started working.  I don't have synaptics installed.  I configure my other mouse using evdev, using a udev rule I crafted to make a symlink which I refer to in xorg.conf.

I really just want to disable the touchpad because the erasermouse is so much better.  I would like to disable in xorg.conf if possible.  If not then with a udev addition to my rule.  As last resort, through hal or some other method.

I already have udev rule to create a symlinks for my laptop mice:

$ cat /etc/udev/rules.d/11-mice.rules

# Synaptic Touchpad (first seen as event7)
KERNEL=="event[0-9]*", ATTRS{modalias}=="input:b0011v0002p0007e01B1e0,1,3,k110,111,112,145,14A,ra0,1,18,1C,mlsfw", SYMLINK+="input/touchpad"

# Eraser Mouse (first seen as event13)
KERNEL=="event[0-9]*", ATTRS{modalias}=="input:b0011v0002p000Ae0000-e0,1,2,k110,111,112,r0,1,amlsfw", SYMLINK+="input/ibmeraser"

But now I want to disable the touchpad in xorg.conf

$ cat /etc/X11/xorg.conf

#
#  Configure the eraser-mouse
#
Section "InputDevice"
  Identifier    "IBM Eraser Mouse"
  Option        "Device" "/dev/input/ibmeraser"
  Option        "Phys" "synaptics-pt/serio0/input0"
  Driver        "evdev"
  #Option        "Name" "IBM Eraser Mouse"
  Option        "evBits"  "+1-2"
  Option        "keyBits" "~272-287"
  Option        "relBits" "~0-2 ~6 ~8"
  Option        "Pass"    "3"
  Option        "SendCoreEvents" "true"
  Option        "SendDragEvents" "true"
  Option        "EmulateWheel" "true"
  Option        "EmulateWheelButton" "2"
  Option        "EmulateWheelInertia" "20"
  Option        "EmulateWheelTimeout" "200"
EndSection

#
#  Disable the touchpad (it's very very annoying)
#
Section "InputDevice"
  Identifier    "Annoying Touchpad"
  Option        "Device" "/dev/input/touchpad"
  Option        "Phys" "isa0060/serio1/input0"
  Driver        "evdev"
  #Option        "Name" "Annoying Touchpad"
  Option        "evBits"  "+1-2"
  Option        "keyBits" "~272-287"
  Option        "relBits" "~0-2 ~6 ~8"
  Option        "Pass"    "3"
  Option        "SendCoreEvents"    "false"
EndSection

I was hoping specifically that Option        "SendCoreEvents"    "false" would do it but no such luck roll

I know the eraser mouse config works because I can use the middle-mouse button for scrolling.  I just don't know if there is some option to completely disable a configured InputDevice (that annoying touchpad) or maybe I can make the udev node 'chmod 000' ??

Please someone help me I can barely move my mouse right now mad

EDIT: Removed profanity

Last edited by nitroguy (2010-03-12 17:01:52)

Offline

#2 2010-03-12 14:43:50

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [SOLVED] How can I disable Touchpad

I have Synaptics driver and GSynaptics installed - and the first option in GSynaptics says "Disable touchpad" :-) It's better then disabling it in Xorg.conf because you never now when you can need to turn it on :-)

Offline

#3 2010-03-12 16:49:52

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [SOLVED] How can I disable Touchpad

Install synaptics and then try "synclient TouchpadOff=1". It could not be easier. You could then also create a udev rule to enable/disable touchpad in case you're using your mouse.

Offline

#4 2010-03-12 16:59:53

nitroguy
Member
Registered: 2009-10-16
Posts: 16

Re: [SOLVED] How can I disable Touchpad

That workaround works for me.  I'm still shocked at how hard it is to simply disable an event device (is it impossible?).

Thanks everyone!

Last edited by nitroguy (2010-03-12 17:02:36)

Offline

#5 2013-03-21 22:22:29

rkraevskiy
Member
Registered: 2013-03-21
Posts: 1

Re: [SOLVED] How can I disable Touchpad

patch for touchpad state control http://pastebin.com/3EcKpCUM

Offline

#6 2013-03-25 17:56:13

RealGecko
Member
Registered: 2012-01-04
Posts: 29

Re: [SOLVED] How can I disable Touchpad

I had Synaptiks installed and it handled automatic disable of touchpad when mouse attached, but after recent update it stopped to work.
"synclient TouchpadOff=1" helped to turn touchpad off, but how can I get back automatic handling? Udev rule described in Wiki does not help:(

Edit: tried udev rule again, now with running "udevadm trigger" command, seems like working.

Last edited by RealGecko (2013-03-25 19:09:44)

Offline

Board footer

Powered by FluxBB