You are not logged in.

#1 2005-02-13 15:35:50

aneas
Member
Registered: 2005-02-13
Posts: 17

[Arch 0.7] no sound with snd-intel8x0

It's not like there is no sound to hear, but aplay & xmms simply dont play anything. Xmms (with Alsa) gets stuck at 00:00 and aplay doesnt stop playing (well, i dont actually hear that 'play') a 5 sec wav (so i think it doesnt start playing like xmms). It seems that this is not a problem of muted sound or unplugged speakers (everything works perfectly with windows xp).

using:
linux 2.6.10-arch, devfs (udev didnt work either)

running on a notebook:

Acer Extensa 3002 WLMi (the 'better' version of Acer Travelmate 4002 WLMi)
Intel Pentium M 725 Centrino 1.6GHz
ATI Radeon 9700/64mb Mobility
100GB HDD, 512 MB DDR
built-in speakers (working with windows xp)

I already re-installed arch, tried kernel24 and 2.6.9, jumped in circles and prayed to every single god-like metaphor i've ever heard of ever...

Some output:

amixer: (everything 100 unmuted)

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [on]
  Front Right: Playback 31 [100%] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [on]
  Front Right: Playback 31 [100%] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31

  Front Left: Playback 31 [100%] [on]
  Front Right: Playback 31 [100%] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [on] Capture [off]
  Front Right: Playback 31 [100%] [on] Capture [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [on] Capture [off]
  Front Right: Playback 31 [100%] [on] Capture [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [on]
  Front Left: Capture [on]
  Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Video',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Phone',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Playback AC97-SPSA',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 3
  Mono: 3 [100%]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 15 [100%] [on]
Simple mixer control 'Aux',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [on]
  Front Right: Capture 0 [0%] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

lspci:

00:00.0 Host bridge: Intel Corp.: Unknown device 3580 (rev 02)
00:00.1 System peripheral: Intel Corp.: Unknown device 3584 (rev 02)
00:00.3 System peripheral: Intel Corp.: Unknown device 3585 (rev 02)
00:01.0 PCI bridge: Intel Corp.: Unknown device 3581 (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp.: Unknown device 24cc (rev 03)
00:1f.1 IDE interface: Intel Corp.: Unknown device 24ca (rev 03)
00:1f.3 SMBus: Intel Corp. 82801DB SMBus (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB AC'97 Modem (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4e50
02:02.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
02:04.0 Network controller: Intel Corp.: Unknown device 4220 (rev 05)
02:06.0 CardBus bridge: Texas Instruments: Unknown device 8031
02:06.2 FireWire (IEEE 1394): Texas Instruments: Unknown device 8032
02:06.3 Unknown mass storage controller: Texas Instruments: Unknown device 8033

cat /etc/modprobe.conf

#
# /etc/modprobe.conf (for v2.6 kernels)
#

# OSS Compatibility
install snd-pcm modprobe -i snd-pcm ; modprobe snd-pcm-oss ; true
install snd-seq modprobe -i snd-seq ; modprobe snd-seq-oss ; true

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
options snd  device_mode=0666
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

groups root:

root bin daemon sys adm disk wheel audio

of course, pacman -Syu:

:: Synchronizing package databases... 
:: current is up to date
:: extra is up to date

lsmod | grep snd

snd_intel8x0m          19524  0 
snd_intel8x0           34336  0 
snd_ac97_codec         78176  2 snd_intel8x0m,snd_intel8x0
snd_pcm_oss            56612  0 
snd_mixer_oss          21120  1 snd_pcm_oss
snd_pcm               101252  4 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              27140  1 snd_pcm
snd                    59108  7 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10848  1 snd
snd_page_alloc         10244  3 snd_intel8x0m,snd_intel8x0,snd_pcm

Please MTV, pimp my ride...

Offline

#2 2005-02-13 18:47:21

xian
Member
Registered: 2005-01-29
Posts: 19

Re: [Arch 0.7] no sound with snd-intel8x0

As I also run this soundcard and find that it works on Arch 0.7 using the recommended setup in the wiki, I would suggest that if you are in KDE that you enter the Control Center and untick the system sound option. For some reason xmms and other sound applications will often hang if this is not done, but there are some packages like realplay which seem to work fine under any situation.

Offline

#3 2005-02-17 11:31:37

jerem
Member
From: France
Registered: 2005-01-15
Posts: 310

Re: [Arch 0.7] no sound with snd-intel8x0

I am really tired of people not being able to figure out how to cleverly compile a kernel...

Your sound card is in your computer, eh ? You do not remove it everyday from your computer, eh ? Then WHY do you compile that as a module ????? :twisted:

If you want to avoid lots of problems, stop compiling as module what you use everyday and cannot be removed from your computer.:idea:

For ex I would compile pcmcia as module but not the soundcard driver for it needs a lot of dependencies(10 modules !!!!).

Here is the way to fix your problem : build your module inside the kernel !!!

Alsa==>PCI==> Intel

and here is the way to configure alsa :

pacman -S alsa-utils
amixer set Master unmute
amixer set PCM unmute
alsamixer
alsactl store
echo "alsactl restore" >> /etc/rc.local

Offline

#4 2005-02-24 08:07:33

SG-3
Member
Registered: 2005-02-01
Posts: 28

Re: [Arch 0.7] no sound with snd-intel8x0

Do you get any sound at all in KDE ?

Xmms may not be set up out of the box

If you need any more please PM me ...

HTH


"just below me"

Offline

#5 2005-02-24 08:34:12

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: [Arch 0.7] no sound with snd-intel8x0

jerem wrote:

I am really tired of people not being able to figure out how to cleverly compile a kernel...

Your sound card is in your computer, eh ? You do not remove it everyday from your computer, eh ? Then WHY do you compile that as a module ????? :twisted:

If you want to avoid lots of problems, stop compiling as module what you use everyday and cannot be removed from your computer.:idea:

For ex I would compile pcmcia as module but not the soundcard driver for it needs a lot of dependencies(10 modules !!!!).

Here is the way to fix your problem : build your module inside the kernel !!!

Alsa==>PCI==> Intel

and here is the way to configure alsa :

pacman -S alsa-utils
amixer set Master unmute
amixer set PCM unmute
alsamixer
alsactl store
echo "alsactl restore" >> /etc/rc.local

Firstly dude. The standard arch kernel has it as a module because not everyone has this card.

Second dude. People put it as a module because occassionally programs crash, and sometimes if they were using the soundcard, it's locked up requiring a reboot. Removing and reloading the module fixes this.

Besides, whats the problem with it having lots of dependencies when used as a module? If you compile the driver into the kernel, the deps are compiled in. If you load the driver with modprobe, it autoloads the deps. The deps arent a problem


iphitus

Offline

#6 2005-03-10 17:39:22

ody
Member
From: Manchester, UK
Registered: 2002-08-12
Posts: 212
Website

Re: [Arch 0.7] no sound with snd-intel8x0

jerem wrote:

For ex I would compile pcmcia as module but not the soundcard driver for it needs a lot of dependencies(10 modules !!!!).

Why? with your reckoning of compiling everything that's removable as a module and anything not so removable leave compiled in the kernel why would you want to compile pcmcia support as a module?

Offline

#7 2005-03-10 21:30:43

RedShift
Member
From: Belgium
Registered: 2004-07-16
Posts: 230

Re: [Arch 0.7] no sound with snd-intel8x0

I use intel8x0 here and it works fine. Use

alsamixer

to check if your volumes are right and not muted.


:?

Offline

#8 2005-03-11 08:20:36

jerem
Member
From: France
Registered: 2005-01-15
Posts: 310

Re: [Arch 0.7] no sound with snd-intel8x0

cat /dev/urandom > /dev/dsp

if you here some talkie-walkie noise your sound is working.

Offline

#9 2005-03-11 14:39:10

ravster
Member
From: Queen's U, Kingston, Canada
Registered: 2004-05-02
Posts: 285
Website

Re: [Arch 0.7] no sound with snd-intel8x0

I used to have this same problem, and alsamixer would not start sometime(yes, I tried modprobe'ing the module, but it did not work)
Now what I do is compile my own kernel and make the Alsa drivers as part of the kernel.

Offline

#10 2005-03-11 19:54:07

jerem
Member
From: France
Registered: 2005-01-15
Posts: 310

Re: [Arch 0.7] no sound with snd-intel8x0

I built the -cko2 2.6.11 kernel and all my stuff worked perfectly :

-nvidia compiled successfully
-snd-intel8x0 compiled in and never had any problem(10 modules dependent from each other is a pain and somewhat ridiculous, that's too much of an instable plastic cube tower)

Offline

#11 2005-03-12 20:27:14

Stanislav
Member
Registered: 2004-10-16
Posts: 82

Re: [Arch 0.7] no sound with snd-intel8x0

i have the same problem with the same card on my notebook. did something change in the kernel since 2.6.9 that i am not aware of? it's good that i have the old kernel, so i can always boot with it.

the weird things is that i get no error messages during booting with 2.6.11 . and music players seem to play music, but i can't hear anything. it's such a mystery. so i will wait to see if anything will change or if someone have a solution.

take care, Stanislav


[URL=http://imageshack.us][img]http://img360.imageshack.us/img360/481/imbulgarian6ph.gif[/img][/URL]

Offline

#12 2005-03-12 20:42:26

mpie
Member
From: 404 Not found
Registered: 2005-03-06
Posts: 649

Re: [Arch 0.7] no sound with snd-intel8x0

at the risk of stating the obvious have you enabled dmixer as stated in the link in the newsletter, I needed this and to chmod 0666 /dev/dsp...

now this card works flawlessly, albeit in a desktop

Offline

#13 2005-03-12 20:50:12

Stanislav
Member
Registered: 2004-10-16
Posts: 82

Re: [Arch 0.7] no sound with snd-intel8x0

what confuses me is, why everything works perfect with the old 2.6.9 kernel?


[URL=http://imageshack.us][img]http://img360.imageshack.us/img360/481/imbulgarian6ph.gif[/img][/URL]

Offline

#14 2005-03-12 23:33:23

Stanislav
Member
Registered: 2004-10-16
Posts: 82

Re: [Arch 0.7] no sound with snd-intel8x0

OK guys,

i have found a solution to the problem. there is some problem with the latest alsa 1.0.8 & snd-intel8x0. the latest also is also in the latest kernel 2.6.11 

to get the sound, you need to mute your headphone jack sense in alsamixer & then you can play anything you want.

i hope this helps & it gets fixed permanently!

big_smile  take care, Stanislav


[URL=http://imageshack.us][img]http://img360.imageshack.us/img360/481/imbulgarian6ph.gif[/img][/URL]

Offline

#15 2005-03-13 00:16:14

mpie
Member
From: 404 Not found
Registered: 2005-03-06
Posts: 649

Re: [Arch 0.7] no sound with snd-intel8x0

dont seam to have a headphone jack in.......sri

Offline

#16 2005-03-13 06:47:56

Stanislav
Member
Registered: 2004-10-16
Posts: 82

Re: [Arch 0.7] no sound with snd-intel8x0

it's right after Master,Master Mono,Headphone & the next is Headphone Jack Sense when you run alsamixer!


[URL=http://imageshack.us][img]http://img360.imageshack.us/img360/481/imbulgarian6ph.gif[/img][/URL]

Offline

Board footer

Powered by FluxBB