You are not logged in.

#1 2005-03-10 08:33:14

CrayMk7
Member
From: Norway
Registered: 2004-03-29
Posts: 51

Screen turns off when logging out.

I got this annoying problem, ever since I got my GF card (Abit GF4-4200) some years ago, whenever I quit my DE or WM my monitor goes into some powersave state, this has happened on every distro I have ever tried with this card.

If I type startx, it will turn itself on again and show me the desktop. Also, I have my TV running on the TV out on this card, and it will display everything ok with no error messages.

This only occur when using the nvidia module, everything is ok when using the nv driver, I also tried to replase this card with an older nvidia card using the nvidia module with no problem.
I am currently using xorg and xfce4.2.

This is not a real problem but very annoying, so if anyone know what is going on please tell me.

Thanks.

Offline

#2 2005-03-10 08:51:36

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Screen turns off when logging out.

turn the monitor off and on, my friend had a similar problem

Offline

#3 2005-03-10 09:14:18

CrayMk7
Member
From: Norway
Registered: 2004-03-29
Posts: 51

Re: Screen turns off when logging out.

Hey iphitus.

I only got a "no signal conected" warning blinking on my screen when turning the power on and off again.

Offline

#4 2005-03-10 13:16:11

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Screen turns off when logging out.

maybe check the configuration in your bios. NV likes you to change alot of settings when using their cards. You also might want to make sure ACPI or APM is turned off. If its on, and your os supports some sort of power saving mode, they usually tend to conflict. I would also recommend turning of plug and play. Arch doesn't need it neither does windows 2000 or XP.

Offline

#5 2005-03-12 13:05:18

CrayMk7
Member
From: Norway
Registered: 2004-03-29
Posts: 51

Re: Screen turns off when logging out.

Plug and Play is turned off in bios, has been for almost a year now after making arch my only OS on both my PC's.

If I swap my old GF2mx card from my old PC into this PC and my GF4-4200 into my old PC, this one wold act as it should and my old PC will have the same problems when logging out.

How can I check if ACPI or APM is running, and where can i make shure they dont start at boot?

Thanks.

Offline

#6 2005-03-12 13:34:04

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Screen turns off when logging out.

Try the newest nvidia drivers, maybe that helps? (There was something about apm support in the changelog, IIRC)

Boot with noacpi and apm=off to turn them off. Check dmesg to see what is enabled. Though your bios apm and acpi settings are more important. If both apm and acpi are enabled in your kernel then acpi is used. According to the nvidia driver readme they don't support acpi yet, only apm. Often there are a lot of power saving options in the bios, try changing those of the videocard and enabling/disabling apm/acpi. See for detailed info the nvidia driver readme.

Offline

#7 2005-03-12 13:43:20

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Screen turns off when logging out.

If you want the kernel to disable acpi append acpi=off to your kernel line in menu.lst, its on by default. However, I was talking about ACPI in the bios. It depends on your brand but it'll be in there somewhere. If its an older board it will probably be APM, either case try disabling them before anything.  You should have gotten instructions on how to adjust many of your bios settings with your card, at least I did with a NV card I bought a couple years ago. I would highly recommend looking into that as well before turning off acpi in the kernel.

Offline

#8 2005-03-12 14:33:42

CrayMk7
Member
From: Norway
Registered: 2004-03-29
Posts: 51

Re: Screen turns off when logging out.

I did try to add acpi=off, but when logging out, rebooting or shutting down, I still get a blank screen, I've been looking trough all the options in my bios and tried to change those who looked relevant in the powersave section, but after reading th motherboard manual (MSI K7N2 Delta), I see I'm supposed to have an option called IPCA function under power managment setup, this item is to activate/deactivate the ACPI function in bios...

The only problem is, it isn't there   :? , I have upgraded my bios a couple of times after getting this MB, but since I didn't have any real problems with it I haven't done it for a while.

Perhaps it's time to get the newest bios and see if it shows up again or the original bios (I cant really remember if it was there when I first got this board).

Another thing when using acpi=off dmesg give me this.

Kernel command line: root=/dev/discs/disc0/part2 ro acpi=off
Found and enabled local APIC!

Is APIC related to this, I'm abit confused since I have to disable IPCA in bios to disable ACPI  :?:

Thanks.

Offline

Board footer

Powered by FluxBB