You are not logged in.

#1 2010-04-06 13:41:12

valandil
Member
Registered: 2008-03-11
Posts: 62

[SOLVED] French Canadian keyboard strange behaviour

Hello!

I just upgraded to Gnome 2.30 in [testing] and my keyboard has a strange behaviour. With Gnome 2.28, my keyboard layout was set to Canadian French (legacy), and still is, though some of the keys do not behave the same. For instance, the accents "`", "¸" and ^ do not behave as usual, but rather give me some letter with that accent on it, rather than letting me choose the letter on which put the accent.

Moreover, the SHIFT+3 combination gives me a # instead of a /, but not in all software. Google Chrome has the good behaviour, but gnome-terminal gives me a #.

Do you understand any of this?

I'll post the packages I have upgraded.

[2010-04-05 01:09] upgraded openssl (0.9.8n-1 -> 1.0.0-2)
[2010-04-05 01:09] upgraded python (2.6.5-2 -> 2.6.5-3)
[2010-04-05 01:09] upgraded pygobject (2.20.0-1 -> 2.21.1-1)
[2010-04-05 01:09] upgraded pygtk (2.16.0-2 -> 2.17.0-1)
[2010-04-05 01:09] upgraded gnome-menus (2.28.0.1-1 -> 2.30.0-1)
[2010-04-05 01:09] upgraded libsoup (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:09] upgraded libldap (2.4.21-1 -> 2.4.21-2)
[2010-04-05 01:09] upgraded libidl2 (0.8.13-1 -> 0.8.14-1)
[2010-04-05 01:09] upgraded orbit2 (2.14.17-1 -> 2.14.18-1)
[2010-04-05 01:09] upgraded gconf (2.28.0-1 -> 2.28.1-1)
[2010-04-05 01:09] upgraded gnome-keyring (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:09] upgraded heimdal (1.3.1-3 -> 1.3.2-1)
[2010-04-05 01:09] upgraded libsoup-gnome (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:10] upgraded gnome-icon-theme (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:10] upgraded libgweather (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:10] upgraded evolution-data-server (2.28.3.1-1 -> 2.30.0-2)
[2010-04-05 01:10] upgraded gnome-desktop (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:10] upgraded libwnck (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:10] upgraded libunique (1.1.6-1 -> 1.1.6-2)
[2010-04-05 01:10] upgraded gnome-disk-utility (2.28.1-1 -> 2.30.1-1)
[2010-04-05 01:11] upgraded libarchive (2.8.3-1 -> 2.8.3-3)
[2010-04-05 01:11] upgraded smbclient (3.5.1-1 -> 3.5.1-2)
[2010-04-05 01:11] upgraded gvfs (1.4.3-1 -> 1.6.0-1)
[2010-04-05 01:11] upgraded gnome-vfs (2.24.2-2 -> 2.24.3-2)
[2010-04-05 01:11] upgraded libbonobo (2.24.2-1 -> 2.24.3-1)
[2010-04-05 01:11] upgraded libgnome (2.28.0-2 -> 2.30.0-1)
[2010-04-05 01:11] upgraded libart-lgpl (2.3.20-1 -> 2.3.21-1)
[2010-04-05 01:11] upgraded libgnomecanvas (2.26.0-1 -> 2.30.1-1)
[2010-04-05 01:11] upgraded libbonoboui (2.24.2-1 -> 2.24.3-1)
[2010-04-05 01:11] upgraded librsvg (2.26.0-2 -> 2.26.2-1)
[2010-04-05 01:11] upgraded gnome-panel (2.28.0-2 -> 2.30.0-1)
[2010-04-05 01:11] upgraded libgnomeui (2.24.2-1 -> 2.24.3-1)
[2010-04-05 01:11] upgraded gnome-python (2.28.0-1 -> 2.28.1-1)
[2010-04-05 01:11] upgraded alacarte (0.12.4-2 -> 0.13.1-1)
[2010-04-05 01:11] upgraded apache (2.2.15-1 -> 2.2.15-2)
[2010-04-05 01:11] upgraded at-spi (1.28.1-1 -> 1.30.0-1)
[2010-04-05 01:11] upgraded totem-plparser (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:12] upgraded brasero (2.28.3-2 -> 2.30.0-1)
[2010-04-05 01:12] upgraded icu (4.2.1-1 -> 4.4-1)
[2010-04-05 01:12] upgraded brltty (4.1-2 -> 4.1-3)
[2010-04-05 01:12] upgraded libgtop (2.28.0-1 -> 2.28.1-1)
[2010-04-05 01:12] upgraded bug-buddy (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:12] upgraded cheese (2.28.1-1 -> 2.30.0-1)
[2010-04-05 01:12] upgraded clutter (1.0.10-1 -> 1.2.4-1)
[2010-04-05 01:12] upgraded clutter-gtk (0.10.2-1 -> 0.10.2-2)
[2010-04-05 01:12] upgraded libxklavier (4.0-1 -> 5.0-1)
[2010-04-05 01:12] upgraded libgnomekbd (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:12] upgraded gnome-settings-daemon (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:12] upgraded zenity (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:13] upgraded metacity (2.28.1-1 -> 2.30.0-2)
[2010-04-05 01:13] upgraded gnome-control-center (2.28.1-1 -> 2.30.0-1)
[2010-04-05 01:13] upgraded compiz-decorator-gtk (0.8.4-2 -> 0.8.4-3)
[2010-04-05 01:13] upgraded libcups (1.4.2-5 -> 1.4.3-2)
[2010-04-05 01:13] upgraded openslp (1.2.1-2 -> 1.2.1-3)
[2010-04-05 01:13] upgraded cups (1.4.2-5 -> 1.4.3-2)
[2010-04-05 01:13] upgraded curl (7.20.0-1 -> 7.20.0-2)
[2010-04-05 01:13] upgraded cvs (1.11.23-4 -> 1.11.23-5)
[2010-04-05 01:13] upgraded postgresql-libs (8.4.3-1 -> 8.4.3-2)
[2010-04-05 01:13] upgraded cyrus-sasl-plugins (2.1.23-1 -> 2.1.23-2)
[2010-04-05 01:13] upgraded cyrus-sasl (2.1.23-3 -> 2.1.23-4)
[2010-04-05 01:13] upgraded dbus-python (0.83.0-2.1 -> 0.83.1-1)
[2010-04-05 01:13] upgraded gnome-python-desktop (2.28.0-3 -> 2.30.0-1)
[2010-04-05 01:13] upgraded deskbar-applet (2.28.0-3 -> 2.30.0-1)
[2010-04-05 01:13] upgraded dnsutils (9.6.1-2 -> 9.6.1-3)
[2010-04-05 01:14] upgraded eog (2.28.2-2 -> 2.30.0-1)
[2010-04-05 01:14] upgraded libwebkit (1.1.15.4-3 -> 1.1.90-2)
[2010-04-05 01:14] upgraded gobject-introspection (0.6.6-1 -> 0.6.9-1)
[2010-04-05 01:14] upgraded epiphany (2.28.2-2 -> 2.30.0-1)
[2010-04-05 01:14] upgraded evince (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:14] upgraded gtkhtml (3.28.3-1 -> 3.30.0-1)
[2010-04-05 01:14] upgraded evolution-exchange (2.28.3-1 -> 2.30.0-2)
[2010-04-05 01:14] upgraded evolution-webcal (2.28.0-1 -> 2.28.1-1)
[2010-04-05 01:14] upgraded file-roller (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:15] upgraded gcalctool (5.28.2-1 -> 5.30.0-1)
[2010-04-05 01:15] upgraded gconf-editor (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:15] upgraded gnome-session (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:15] upgraded gdm (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:15] upgraded gtksourceview2 (2.8.2-1 -> 2.10.0-1)
[2010-04-05 01:15] upgraded pygtksourceview2 (2.8.0-1 -> 2.10.0-1)
[2010-04-05 01:15] upgraded gedit (2.28.3-1 -> 2.30.0-1)
[2010-04-05 01:15] upgraded git (1.7.0.3-1 -> 1.7.0.4-1)
[2010-04-05 01:15] upgraded libsigc++2.0 (2.2.4.2-1 -> 2.2.5-1)
[2010-04-05 01:15] upgraded glibmm (2.22.1-1 -> 2.24.0-1)
[2010-04-05 01:15] upgraded gucharmap (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:16] upgraded gnome-applets (2.28.0-2 -> 2.30.0-1)
[2010-04-05 01:16] upgraded gnome-backgrounds (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:16] upgraded gnome-bluetooth (2.28.6-1 -> 2.30.0-1)
[2010-04-05 01:16] upgraded vte (0.22.5-1 -> 0.24.0-2)
[2010-04-05 01:16] upgraded gnome-desktop-sharp (2.26.0-3 -> 2.26.0-5)
[2010-04-05 01:16] upgraded gnome-doc-utils (0.18.1-1 -> 0.20.0-1)
[2010-04-05 01:17] upgraded gnome-games (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:17] upgraded gnome-games-extra-data (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:17] upgraded gnome-mag (0.15.9-1 -> 0.16.1-1)
[2010-04-05 01:17] upgraded gnome-media (2.28.5-1 -> 2.30.0-2)
[2010-04-05 01:17] upgraded gnome-netstatus (2.28.0-1 -> 2.28.1-1)
[2010-04-05 01:17] upgraded gnome-nettool (2.28.0-1 -> 2.30.0-1)
[2010-04-05 01:17] upgraded gnome-power-manager (2.28.3-1 -> 2.30.0-1)
[2010-04-05 01:17] upgraded gnome-screensaver (2.28.3-1 -> 2.30.0-1)
[2010-04-05 01:17] upgraded gtkmm (2.18.2-1 -> 2.20.0-1)
[2010-04-05 01:17] upgraded gnome-system-monitor (2.28.0-1 -> 2.28.1-1)
[2010-04-05 01:18] upgraded system-tools-backends (2.8.3-1 -> 2.10.0-1)
[2010-04-05 01:18] upgraded liboobs (2.22.2-1 -> 2.30.0-1)
[2010-04-05 01:18] upgraded nautilus (2.28.4-1 -> 2.30.0-1)
[2010-04-05 01:18] upgraded gnome-system-tools (2.28.2-1 -> 2.30.0-2)
[2010-04-05 01:18] upgraded gnome-terminal (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:18] upgraded gtk-engines (2.18.5-1 -> 2.20.0-1)
[2010-04-05 01:18] upgraded gnome-themes (2.28.1-1 -> 2.30.0-1)
[2010-04-05 01:18] upgraded gnome-user-share (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:18] upgraded gnome-utils (2.28.3-1 -> 2.30.0-1)
[2010-04-05 01:19] upgraded xulrunner (1.9.2.2-2 -> 1.9.2.3-1)
[2010-04-05 01:19] upgraded yelp (2.28.1-2 -> 2.30.0-1)
[2010-04-05 01:19] upgraded gnome2-user-docs (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:19] upgraded gok (2.28.1-1 -> 2.30.0-1)
[2010-04-05 01:19] upgraded grep (2.6.2-1 -> 2.6.3-1)
[2010-04-05 01:19] upgraded gstreamer0.10-bad (0.10.18-2 -> 0.10.18-3)
[2010-04-05 01:19] upgraded neon (0.28.6-2 -> 0.28.6-4)
[2010-04-05 01:19] upgraded gstreamer0.10-bad-plugins (0.10.18-2 -> 0.10.18-3)
[2010-04-05 01:19] upgraded hamster-applet (2.28.2-1 -> 2.30.0.1-1)
[2010-04-05 01:19] upgraded net-snmp (5.5-2 -> 5.5-3)
[2010-04-05 01:19] upgraded hplip (3.9.12-5 -> 3.10.2-1)
[2010-04-05 01:20] upgraded imap (2007e-1 -> 2007e-2)
[2010-04-05 01:20] upgraded jre (6u18-2 -> 6u19-2)
[2010-04-05 01:21] upgraded kdebase-workspace (4.4.2-1 -> 4.4.2-2)
[2010-04-05 01:21] upgraded kernel26-firmware (2.6.33.1-1 -> 2.6.33.2-1)
[2010-04-05 01:24] upgraded kernel26 (2.6.33.1-1 -> 2.6.33.2-1)
[2010-04-05 01:24] upgraded kernel26-headers (2.6.33.1-1 -> 2.6.33.2-1)
[2010-04-05 01:24] upgraded lib32-glib2 (2.22.5-1 -> 2.24.0-1)
[2010-04-05 01:24] upgraded lib32-atk (1.28.0-1 -> 1.30.0-1)
[2010-04-05 01:24] upgraded lib32-e2fsprogs (1.41.10-1 -> 1.41.11-1)
[2010-04-05 01:24] upgraded lib32-openssl (0.9.8n-1 -> 1.0.0-2)
[2010-04-05 01:24] upgraded lib32-heimdal (1.3.1-3 -> 1.3.2-1)
[2010-04-05 01:24] upgraded lib32-libcups (1.4.2-5 -> 1.4.3-2)
[2010-04-05 01:24] upgraded lib32-pango (1.26.2-1 -> 1.28.0-1)
[2010-04-05 01:24] upgraded lib32-gtk2 (2.18.9-2 -> 2.20.0-2)
[2010-04-05 01:24] upgraded lib32-libgl (7.7-1 -> 7.7.1-0.1)
[2010-04-05 01:24] upgraded lib32-libxml2 (2.7.6-2 -> 2.7.7-1)
[2010-04-05 01:24] upgraded lib32-mesa (7.7-1 -> 7.7.1-0.1)
[2010-04-05 01:24] upgraded lib32-qt (4.6.2-2 -> 4.6.2-3)
[2010-04-05 01:24] upgraded libepc (0.3.10-1 -> 0.3.11-1)
[2010-04-05 01:24] upgraded libfetch (2.30-1 -> 2.30-3)
[2010-04-05 01:24] upgraded libgail-gnome (1.20.1-1 -> 1.20.2-1)
[2010-04-05 01:24] upgraded libgdata (0.4.0-1 -> 0.6.4-1)
[2010-04-05 01:24] upgraded libgnomecups (0.2.3-6 -> 0.2.3-7)
[2010-04-05 01:24] upgraded libgnomeprint (2.18.6-2 -> 2.18.7-2)
[2010-04-05 01:24] upgraded libgnomeprintui (2.18.4-1 -> 2.18.5-1)
[2010-04-05 01:24] upgraded librpcsecgss (0.19-2 -> 0.19-3)
[2010-04-05 01:24] upgraded libssh (0.4.1-1 -> 0.4.1-3)
[2010-04-05 01:25] upgraded libxml++ (2.26.0-1 -> 2.30.0-1)
[2010-04-05 01:25] upgraded links (2.2-3 -> 2.2-4)
[2010-04-05 01:25] upgraded lynx (2.8.7-1 -> 2.8.7-2)
[2010-04-05 01:25] upgraded sbcl (1.0.35-1 -> 1.0.37-1)
[2010-04-05 01:25] upgraded maxima (5.20.1-2 -> 5.20.1-3)
[2010-04-05 01:25] upgraded mercurial (1.5-1 -> 1.5.1-1)
[2010-04-05 01:26] upgraded miro (2.5.4-4 -> 3.0-1)
[2010-04-05 01:26] upgraded mousetweaks (2.28.2-1 -> 2.30.0-1)
[2010-04-05 01:26] upgraded nasm (2.07-1 -> 2.08.01-1)
[2010-04-05 01:26] upgraded nautilus-actions (1.12.2-1 -> 2.30.0-1)
[2010-04-05 01:26] upgraded nautilus-open-terminal (0.18-1 -> 0.18-2)
[2010-04-05 01:26] upgraded nautilus-sendto (2.28.2-1 -> 2.28.4-1)
[2010-04-05 01:26] upgraded samba (3.5.1-1 -> 3.5.1-2)
[2010-04-05 01:26] upgraded nautilus-share (0.7.2-4 -> 0.7.2-5)
[2010-04-05 01:26] upgraded network-manager-applet (0.8-2 -> 0.8-3)
[2010-04-05 01:26] upgraded nfs-utils (1.2.2-1 -> 1.2.2-2)
[2010-04-05 01:26] upgraded nmap (5.21-1 -> 5.21-2)
[2010-04-05 01:26] upgraded ptlib (2.6.5-1 -> 2.6.5-2)
[2010-04-05 01:27] upgraded opal (3.6.6-1 -> 3.6.6-2)
[2010-04-05 01:27] upgraded openntpd (3.9p1-10 -> 3.9p1-11)
[2010-04-05 01:28] upgraded openoffice-base (3.2.0-1 -> 3.2.0-3)
[2010-04-05 01:28] upgraded openssh (5.4p1-3 -> 5.4p1-4)
[2010-04-05 01:28] upgraded openvpn (2.1.1-1 -> 2.1.1-2)
[2010-04-05 01:28] upgraded orca (2.28.3-1 -> 2.30.0-1)
[2010-04-05 01:28] upgraded perl-crypt-ssleay (0.57-3 -> 0.57-4)
[2010-04-05 01:28] upgraded perl-uri (1.52-1 -> 1.54-1)
[2010-04-05 01:28] upgraded php (5.3.2-4 -> 5.3.2-6)
[2010-04-05 01:28] upgraded php-apache (5.3.2-4 -> 5.3.2-6)
[2010-04-05 01:28] upgraded pixman (0.16.6-1 -> 0.18.0-1)
[2010-04-05 01:28] upgraded postfix (2.7.0-1 -> 2.7.0-2)
[2010-04-05 01:28] upgraded qt (4.6.2-2 -> 4.6.2-3)
[2010-04-05 01:28] upgraded qtscriptgenerator (0.1.0-3 -> 0.1.0-4)
[2010-04-05 01:29] upgraded rhythmbox (0.12.7-1 -> 0.12.8-1)
[2010-04-05 01:29] upgraded ruby (1.9.1_p378-1 -> 1.9.1_p378-2)
[2010-04-05 01:29] upgraded seahorse (2.28.1-1 -> 2.30.0-1)
[2010-04-05 01:29] upgraded seahorse-plugins (2.28.1-1 -> 2.30.0-1)
[2010-04-05 01:29] upgraded sound-juicer (2.28.1-2 -> 2.28.2-1)
[2010-04-05 01:29] upgraded subversion (1.6.9-2 -> 1.6.9-4)
[2010-04-05 01:29] upgraded syslog-ng (3.0.4-3 -> 3.0.4-4)
[2010-04-05 01:29] upgraded telepathy-glib (0.10.1-1 -> 0.10.2-1)
[2010-04-05 01:29] upgraded tomboy (1.1.0-1 -> 1.2.0-2)
[2010-04-05 01:29] upgraded totem (2.28.5-2 -> 2.30.0-1)
[2010-04-05 01:29] upgraded transmission-gtk (1.92-1 -> 1.92-2)
[2010-04-05 01:30] upgraded vala (0.7.10-1 -> 0.8.0-1)
[2010-04-05 01:30] upgraded vinagre (2.28.1-2 -> 2.30.0-1)
[2010-04-05 01:30] upgraded vino (2.28.1-3 -> 2.28.2-1)
[2010-04-05 01:30] upgraded virtuoso (6.1.0-1 -> 6.1.0-2)
[2010-04-05 01:30] upgraded wget (1.12-1 -> 1.12-2)
[2010-04-05 01:30] upgraded wpa_supplicant (0.6.10-1 -> 0.6.10-2)
[2010-04-05 01:30] upgraded xorg-server (1.7.6-2 -> 1.7.6-3)
[2010-04-05 01:30] upgraded xorg-xinit (1.2.0-1 -> 1.2.1-1)
[2010-04-05 01:30] upgraded xterm (255-1 -> 256-1)
[2010-04-05 09:21] upgraded fofix-svn (1991-1 -> 2038-1)
[2010-04-05 12:31] upgraded gloobus-preview-bzr (212-1 -> 214-1)

Last edited by valandil (2010-04-06 16:52:28)

Offline

#2 2010-04-06 16:52:16

valandil
Member
Registered: 2008-03-11
Posts: 62

Re: [SOLVED] French Canadian keyboard strange behaviour

Problem solved!

I remembered I once configured my keyboard with HAL and /etc/hal/fdi/policy/10-keymap.fdi was set to xkb.layout=ca and xkd.variant=fr. I changed the GDM layout to Canada and removed the xkb.variant=fr from the .fdi file and everything was fixed!

Offline

Board footer

Powered by FluxBB