You are not logged in.

#1626 2010-04-07 19:50:02

Gruntz
Member
From: Haskovo, Bulgaria
Registered: 2007-08-31
Posts: 256

Re: The AMD/ATI Bar & Grill

Vi0L0, thank you. Everything is working now, and I have direct rendereing.

I have never had problems with ati`s catalyst installer till now. I will use the AUR from now on.

Thank you.

Offline

#1627 2010-04-07 21:55:57

jck
Member
From: USA
Registered: 2009-05-08
Posts: 97

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

Well, I use the other one and it works for me. Could you try it?

Thank you, It works really nicely now. Urxvt and ut2004 are a lot smoother now...

Offline

#1628 2010-04-08 22:24:51

Cory
Member
Registered: 2009-07-13
Posts: 57

Re: The AMD/ATI Bar & Grill

Kernel 2.6.33 is in core repository now i need to recompile catalyst 10.4 beta with patch, right?

Last edited by Cory (2010-04-08 22:50:34)

Offline

#1629 2010-04-09 00:52:14

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Cory wrote:

Kernel 2.6.33 is in core repository now i need to recompile catalyst 10.4 beta with patch, right?

Yes, indeed. Just use AUR's catalyst-test and it will patch catalyst for you.
Tomorrow (i gotta sleep right now wink) i will update [catalyst] repo
Edit: and probably prepare catalyst-test packages (maybe also repo with xorg-server 1.8, so it may cooperate with [xorg18] repo, which should land in [extra] in few days/maybe_weeks... - will see)

Last edited by Vi0L0 (2010-04-09 01:02:52)

Offline

#1630 2010-04-09 03:00:30

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

ATTENTION! This is IMPORTANT!

There are some issues with updating arch, there is new version of openssl - many packages needs to be recompiled and updated, xorg-server also. My Xes are broken now - some errors with uki - im using own xorg-server 1.8 builded on older openssl libs, so im gonna recompile it again with newer ones, and tell does it really work!
So my advise to you is DO NOT pacman -Syu! Im gonna test it tomorrow and tell does it work correctly. But for now dont update your systems - if something will go wrong theres no turning back! (at least i dont know how to rollback openssl, cuz when i did that my pacman brokes - i fixed that, but i guess you need livecd to rollback) smile

Last edited by Vi0L0 (2010-04-09 03:02:19)

Offline

#1631 2010-04-09 04:59:11

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: The AMD/ATI Bar & Grill

You are a wonder ViOLO. cool big_smile


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#1632 2010-04-09 11:01:40

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

handy wrote:

You are a wonder ViOLO. cool big_smile

xD naaah, just dreamin about wonders wink

Anyhow everything seems ok now, uff... and as i can see xorg-server is back in [extra] (it wasnt there when i was writing attention), so if you were using it you can safely update, if not - recompile own xorg-server. Before recompiling dont forget to get full update from some serious mirror, like ftp.archlinux.org

Last edited by Vi0L0 (2010-04-09 11:07:04)

Offline

#1633 2010-04-09 11:44:05

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

So, do we have a patched 1.8 server for catalyst compatibility (i.e. version number hack)?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1634 2010-04-09 12:46:38

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

So, do we have a patched 1.8 server for catalyst compatibility (i.e. version number hack)?

Yes, i wrote about that here: http://bbs.archlinux.org/viewtopic.php? … 11#p738711
For now you need to compile it by yourself, but maybe today i will prepare some repo with it

Last edited by Vi0L0 (2010-04-09 12:51:11)

Offline

#1635 2010-04-09 14:22:42

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

To get catalyst<=10.3 work with old xserver 1.6 after recent update you need to have /usr/lib/libssl.so.0.9.8 and /usr/lib/libcrypto.so.0.9.8
you may get it with AUR's openssl-compatibility http://aur.archlinux.org/packages.php?ID=36308
(read comments to get PKGBUILD for x86_64 version)

Offline

#1636 2010-04-09 17:48:13

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Vi0L0, after following your instructions for testing xserver 1.8 with catalyst 1.4, X refuses to start, sort of.

The module is successfully loaded, xorg.conf.d exists and has evdev/synaptics. Yet after startx it freezes on a black screen. Only hard reset works. Here's the kernel log:

[    22.696] (II) fglrx(0): Kernel Module Build Time Information:
[    22.696] (II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.33-ARCH
[    22.696] (II) fglrx(0):     Build-Kernel MODVERSIONS:        no
[    22.696] (II) fglrx(0):     Build-Kernel __SMP__:            no
[    22.696] (II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
[    22.696] (II) fglrx(0): [uki] register handle = 0x00004000
[    22.708] (EE) fglrx(0): Failed to allocate primary surface (frame buffer)!
[    22.708] (II) fglrx(0): Shutdown CMMQS
[    22.708] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[    22.708] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0xb7311000
[    22.708] (WW) fglrx(0): ***********************************************
[    22.708] (WW) fglrx(0): * DRI initialization failed!                  *
[    22.708] (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
[    22.708] (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
[    22.708] (WW) fglrx(0): * no 3D acceleration available                *
[    22.708] (WW) fglrx(0): ********************************************* *
[    22.708] (II) fglrx(0): FBADPhys: 0xf00000000 FBMappedSize: 0x10000000
[    22.715] (EE) fglrx(0): Failed to map FB memory
[    22.715] (II) fglrx(0): === [atiddxScreenInit] === end
[    22.715] 
Fatal server error:
[    22.715] AddScreen/ScreenInit failed for driver 0
[    22.715] 
[    22.715] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    22.715] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    22.715] 
[    24.294] (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.

Any ideas?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1637 2010-04-09 17:58:20

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@dcc24:
This:

[    22.696] (II) fglrx(0): [uki] register handle = 0x00004000
[    22.708] (EE) fglrx(0): Failed to allocate primary surface (frame buffer)!
[    22.708] (II) fglrx(0): Shutdown CMMQS
[    22.708] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[    22.708] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0xb7311000

I get those errors yesterday after updating arch without recompiling xorg-server... Its related with opessl libs. Try to compile xorg-server after full system update, and without old openssl libs on your system...

Offline

#1638 2010-04-09 18:02:00

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Well, I did.

- I've added the xorg18 repo.
- pacman -Suu and pacman -Syy.
- Conflicted with catalyst, so removed it with -Rd.
- Upgrade went fine.
- Built your xorg-1.8 with fglrx patch. Installed & restart.
- Built catalyst-test. Reboot.
- "startx" with the above kernel.log

All seems well. Any ideas?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1639 2010-04-09 18:05:41

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Edit: ! Add nomodeset to your kernel line in /boot/grub/menu.lst , so it may looks like this:
kernel /boot/vmlinuz26 root=/dev/disk/by-uuid/1aa731c0-f626-4d01-a551-8eed3c2a35f3 ro nomodeset vga=794 splash quiet

[catalyst] repo with catalyst 10.3 should now work fine with recent updates and 2.6.33-ARCH kernel
(althought i have no time now for updating ~500MB of packages @ my i686 system and test does catalyst work fine there)


EDIT: [xorg18] repo has been moved to [testing] hmm
So the use of [catalyst-test-xorg18] repos isnt as clear as it was before that fact ([testing] has a lot of new soft, sometimes some fresh soft may loose its previous funcionality) ... Also if your are using [testing] you should use [community-testing] repo also.
So i recommand [catalyst-test-xorg18] repo only for testers

[catalyst-test-xorg18] repo is online!!! smile :
with catalyst-test, patched xorg-server 1.8.0 (+ lib32-catalyst-test-utils for x86_64)
Edit: please update addresses of this repo... the new ones are below.

For i686:

[catalyst-test-xorg18]
    Server = http://dl.dropbox.com/u/4321633/repo/ca … org18/i686

For x86_64:

[catalyst-test-xorg18]
    Server = http://dl.dropbox.com/u/4321633/repo/ca … g18/x86_64

To use it you need to:
* add needed repos to /etc/pacman.conf - [catalyst-xorg18] must be above [testing], [testing] and [community-testing] above all others, ie for x86_64:

/etc/pacman.conf wrote:

(...)

[catalyst-test-xorg18]
Server = http://dl.dropbox.com/u/4321633/repo/ca … 18/x86_64/

[testing]
Include = /etc/pacman.d/mirrorlist

[community-testing]
Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

(...)

* now just
pacman -Syy
pacman -Suu
pacman -S catalyst-test
(optionally pacman -S lib32-catalyst-test-utils)
(and ofcourse pacman -S xorg-server)
* reboot

++ You may choose which maximize-fixed xorg-server you like :
xorg-server (here patched with backclear patch)
xorg-server-1.8-catalyst-maximize-fix (patched with fedora patch by dcc24)

** keyboard/mouse not working?
Please remember that old hal's input config doesnt work with new xorg-server...
Well it should work out of the box with provided with xorg-server 1.8 package files: /etc/X11/xorg.conf.d/10-evdev.conf and  /etc/X11/xorg.conf.d/10-evdev.conf10-quirks.conf
but it could happen that's not working / fitting to you sooo...

Read more here:
  + Introducing [xorg18] repo: http://www.mail-archive.com/arch-dev-pu … 12804.html
  + New config order: https://fedoraproject.org/wiki/Input_de … figuration - its better to use /etc/X11/xorg.conf.d directory instead of fedora's /etc/xorg.conf.d

Do not add any new xserver Section into your /etc/X11/xorg.conf - this file is still used by catalyst - i mean ie dont add any Section "InputClass" into xorg.conf cuz when you do this both aticonfig and amdcccle wont start cuz of parsing xorg.conf error (just use /etc/xorg.conf.d directory for it)

(again i have no time now for updating ~500MB of packages @ my i686 system and test does catalyst-test-xorg18 work fine there hmm )
Edit: tested, working fine on my recently updated i686 system


***  used xorg-server's PKGBUILD with fglrx-xorg-version.patch + backclear.patch and other needed files : http://dl.dropbox.com/u/4321633/xorg-server.tar.gz

Last edited by Vi0L0 (2010-04-29 00:26:39)

Offline

#1640 2010-04-09 18:11:14

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

Well, I did.

- I've added the xorg18 repo.
- pacman -Suu and pacman -Syy.
- Conflicted with catalyst, so removed it with -Rd.
- Upgrade went fine.
- Built your xorg-1.8 with fglrx patch. Installed & restart.
- Built catalyst-test. Reboot.
- "startx" with the above kernel.log

All seems well. Any ideas?

Uhh... not good... could you try my repo? maybe theres a problem with i686 (if i remembered well you are using i686)

Offline

#1641 2010-04-09 18:18:10

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Or maybe you dcc24 got some extra time for building and posting such package? smile

I'll take a look at this as soon as I get my X working smile


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1642 2010-04-09 18:32:12

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@dcc24:
If nothing helps you can try to get /usr/lib/libssl.so.0.9.8 and /usr/lib/libcrypto.so.0.9.8
It's in AUR's openssl-compatibility http://aur.archlinux.org/packages.php?ID=36308
(althought it shouldnt work with my repo - xorg-server there was builded with fresh openssl libs)

I was getting exact same error when libssl and libcrypto doesnt fit to xorg-server... so i guess its must be related

Last edited by Vi0L0 (2010-04-09 18:50:17)

Offline

#1643 2010-04-09 19:04:23

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Edit: Which mirror are you using? Maybe this is an out-of-sync mirror issue?

Doesn't work. Here's the Xorg.0.log:
http://arch.pastebin.com/06RR8Qkt

I'm currently running it with the vesa driver @1024x768 sad

Here's some more info:

pacman.conf

[catalyst-test-xorg18]
Server=http://dl.dropbox.com/u/4321633/repo/catalyst-test/i686

[xorg18]
Include = /etc/pacman.d/mirrorlist

[core]
Include=/etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

pacman -Qi xorg-server:

Name           : xorg-server
Version        : 1.8.0-1
URL            : http://xorg.freedesktop.org
Licenses       : custom  
Groups         : xorg  
Provides       : x-server  
Depends On     : libgl  libxfont>=1.4.1  libgcrypt>=1.4.5  udev>=151  libpciaccess>=0.10.9  libxv>=1.0.5  pixman>=0.18.0  xcursor-themes>=1.0.2  xkeyboard-config>=1.8  xorg-server-utils  xorg-fonts-misc  xbitmaps  diffutils  
                 xf86-input-evdev>=2.2.5  inputproto>=2.0  
Optional Deps  : None
Required By    : catalyst-test  
Conflicts With : catalyst-utils<=9.2  xf86-input-calcomp  xf86-input-citron  xf86-input-digitaledge  xf86-input-dmc  xf86-input-dynapro  xf86-input-elo2300  xf86-input-jamstudio  xf86-input-magellan  xf86-input-magictouch  
                 xf86-input-microtouch  xf86-input-palmax  xf86-input-spaceorb  xf86-input-summa  xf86-input-tek4957  xf86-input-ur98  xf86-video-vga  xf86-video-intel-legacy  nvidia-96xx-utils<96.43.14  
                 nvidia-173xx-utils<173.14.21  
Replaces       : None
Installed Size : 9992.00 K
Packager       : Unknown Packager
Architecture   : i686
Build Date     : Fri 09 Apr 2010 09:08:39 PM EEST
Install Date   : Fri 09 Apr 2010 09:40:53 PM EEST
Install Reason : Explicitly installed
Install Script : Yes
Description    : X.Org X servers

pacman -Qi catalyst-test:

Name           : catalyst-test
Version        : 10.4-555
URL            : http://www.ati.amd.com
Licenses       : custom  
Groups         : None
Provides       : catalyst  libgl  libatical  
Depends On     : xorg-server<1.9.0  kernel26>=2.6.29  kernel26<2.6.34  kernel26-headers  netkit-bsd-finger  libstdc++5  libxrandr  libsm  fontconfig  libxcursor  libxi  gcc-libs  
Optional Deps  : None
Required By    : dosbox  gnujump  mesa  mplayer-vaapi  qt  supertuxkart  xorg-server  xorg-utils  xvba-video  
Conflicts With : catalyst  catalyst-utils  nvidia  libgl  catalyst-leaked  xf86-video-ati  xf86-video-radeonhd  ati-dri  
Replaces       : None
Installed Size : 65992.00 K
Packager       : Unknown Packager
Architecture   : i686
Build Date     : Fri 09 Apr 2010 07:31:49 PM EEST
Install Date   : Fri 09 Apr 2010 09:33:28 PM EEST
Install Reason : Explicitly installed
Install Script : Yes
Description    : AMD/ATI drivers for Radeon brand cards (based on ubuntu's fglrx with xserver 1.7 support). Stock kernel

openssl is at version 1.0.0-2.

Any ideas? hmm

Last edited by dcc24 (2010-04-09 19:11:54)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1644 2010-04-09 19:15:07

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@dcc24: Strange... your Xorg.log doesnt contain even a word about fglrx...
And no - no idea whats happening, rollback to older xorg-server for now, tomorrow i will check does it work on my i686

Offline

#1645 2010-04-09 19:18:51

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Well, thanks smile

Btw, can you post your xorg.conf and the contents of xorg.conf.d? Maybe something is different there!?!?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1646 2010-04-09 19:23:53

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

Well, thanks smile

Btw, can you post your xorg.conf and the contents of xorg.conf.d? Maybe something is different there!?!?

/etc/X11/xorg.conf:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "off"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    HorizSync    30.0 - 81.0
    VertRefresh  75.0 - 75.0
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "0-DFP2"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
    Option        "PreferredMode" "1280x1024"
    Option        "TargetRefresh" "75"
    Option        "Position" "0 0"
    Option        "Rotate" "normal"
    Option        "Disable" "false"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option        "UseFastTLS" "1"
    Option        "Monitor-DFP2" "0-DFP2"
    Option        "TexturedVideoSync" "on"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "DRI"
    Mode         0666
EndSection

My /etc/X11/xorg.conf.d/ contains only original xorg-server package files:

ls /etc/X11/xorg.conf.d/
10-evdev.conf  10-quirks.conf

Btw: you are not using xorg-server (1.8.0-2) package from my repo, i know that probably there will be no changes, but please try it.

Last edited by Vi0L0 (2010-04-09 19:24:39)

Offline

#1647 2010-04-09 20:07:40

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

I also tried with the version in your repo as well, no luck.

Edit: Well, this just got more interesting.

I've reverted back to 1.7.6 and problem persists! X cannot start! Though I strongly believe this is an fglrx issue, since 1.7.6 starts fine with xf86-video-ati.

I'll just wait for Vi0L0's i686 test hmm

Last edited by dcc24 (2010-04-09 20:18:31)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1648 2010-04-09 21:46:21

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@dcc24:
[catalyst-test-xorg18] repo is working fine on my i686 system out of the box...

Offline

#1649 2010-04-09 21:52:16

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Wait a minute! Could it be? Do you have KMS enabled?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1650 2010-04-09 21:56:05

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

Wait a minute! Could it be? Do you have KMS enabled?

Crazy? smile
Ofcourse not - why should it work? wink

Offline

Board footer

Powered by FluxBB