You are not logged in.

#1 2005-03-18 21:35:48

matto
Member
From: Münster/germany
Registered: 2004-06-03
Posts: 88
Website

usb-storage/mp3-player drives me crazy!

hi there!
I am "windows-free" for nearly one year and on the best way to install it again!
I have an mp3-player-usbstick with filesystem vfat (i think)
i tried several entries in /etc/fstab to use this stick but it never works like i want it to!
at the moment there is : /dev/sda  /mnt/usbstick vfat   rw,user,users,noauto,noexec  0  0
as a user sometimes (!!!!!!not allways!!!!!) you can mount this damn thing!
and sometimes you can write files to it or remove them, sometimes!
sometimes i get the message that my usbstick is read-only... but few minutes ago i could remove files from it!
and sometimes a fresh written to dir with music isn´t readable anymore "input/output - error"
ok no problems fpr windows2k  , how on earth do i manage an usbstorage with linux correctly?
btw on a friends pc (mandrake 10.1 community) it works fine!
greetings matto

(sorry for my bad english)


// DAMNiAM //

Offline

#2 2005-03-18 22:18:26

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: usb-storage/mp3-player drives me crazy!

First, shouldn't you be trying to mount a partition (sda1...) instead of a device (sda). Second, are you using the stock Arch kernel? If not, make sure that your USB stuff is configured correctly (some devices have issues with the 'detect read-only devices' kernel config setting)  Third, you should probably try adding sync to your fstab entry. Which player/stick do you have?

Offline

#3 2005-03-18 23:16:27

matto
Member
From: Münster/germany
Registered: 2004-06-03
Posts: 88
Website

Re: usb-storage/mp3-player drives me crazy!

Hi!first, thank you for quick answer!
i don´t have /dev/sdaX ... only /dev/sda ... :-/
i have 2 kernels, 2.6.9 self compiled, with nearly standard settings, but without some things my machine does not have , eg fire wire. and i have arch 2.6.11 kernel.
with the first one, i can manipulate my usbstick as root, but no chance for users..
the other one (arch) has these rpoblems... where to check my kernel settings?
what is "sync" ? the player is a "gembird" 256MB , written on it: mp3/wma/rec/fm
greetings matto


// DAMNiAM //

Offline

#4 2005-03-22 08:10:02

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: usb-storage/mp3-player drives me crazy!

sorry for the lack of response in the past few days. i notice that the arch default kernel has CONFIG_USB_STORAGE_RW_DETECT=y defined. this may be your problem. you should try to recompile the kernel without this setting and check back. last i heard this driver setting was not compatible with some usb devices.

Offline

#5 2005-03-22 15:26:51

matto
Member
From: Münster/germany
Registered: 2004-06-03
Posts: 88
Website

Re: usb-storage/mp3-player drives me crazy!

hi there !
i´m trying this right now! and i found something in my usb-device-mp3-player settings:
you can choose betwenn 3 types, "multilaufwerk" (multi-drive , i think), normal , and encrypted.
it is set to multi by default, i´ll try the others if this doesn´t work for me, thank you!
greetings matto
-----------------------------
thank you! this works for me!


// DAMNiAM //

Offline

#6 2005-03-25 16:24:49

viniosity
Member
From: New York, NY
Registered: 2005-01-22
Posts: 378
Website

Re: usb-storage/mp3-player drives me crazy!

matto wrote:

Hi!first, thank you for quick answer!
i don´t have /dev/sdaX ... only /dev/sda ... :-/
i have 2 kernels, 2.6.9 self compiled, with nearly standard settings, but without some things my machine does not have , eg fire wire. and i have arch 2.6.11 kernel.
with the first one, i can manipulate my usbstick as root, but no chance for users..
the other one (arch) has these rpoblems... where to check my kernel settings?
what is "sync" ? the player is a "gembird" 256MB , written on it: mp3/wma/rec/fm
greetings matto

How did you get around this problem? I also don't have /dev/sdaX just /dev/sda. As root I am typing

 mount -t vfat /dev/sda /mnt/reader 

but it just hangs for a while and then dumps me back at the prompt.  I'm trying to hook up a LEXAR usb reader.  I'm loading the usb-storage module at startup in rc.conf but that doesn't seem to help.

Offline

#7 2005-03-25 17:15:34

matto
Member
From: Münster/germany
Registered: 2004-06-03
Posts: 88
Website

Re: usb-storage/mp3-player drives me crazy!

hi, is your usb-storage formated correctly?
does it work on other pcs? or with windows?
if no errors occure.. maybe it is mounted? check with "mount"
i use the options rw,umask=000
greetings matto


// DAMNiAM //

Offline

Board footer

Powered by FluxBB