You are not logged in.

#26 2005-03-19 14:19:04

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: New Linux User - New Mission - Better Get Comfortable

xerxes's reffering to /etc/rc.conf.

Offline

#27 2005-03-19 14:41:50

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: New Linux User - New Mission - Better Get Comfortable

don't forget to load you usb modules, that should be "uhci_hcd" and "ehci_hcd" for most chips,


arch + gentoo + initng + python = enlisy

Offline

#28 2005-03-19 14:44:36

Katch
Member
Registered: 2005-03-16
Posts: 17

Re: New Linux User - New Mission - Better Get Comfortable

lucke wrote:

xerxes's reffering to /etc/rc.conf.

OK thats the Hotplug all disabled. Any advice on basic modules it was resposible for to add to the module array?

Also is there a log generated during the boot process that I can go and read?


- Official Board N00b - Your patience and advice is  greatfully recieved!

Offline

#29 2005-03-19 15:19:55

Katch
Member
Registered: 2005-03-16
Posts: 17

Re: New Linux User - New Mission - Better Get Comfortable

Just a note -

The hotplug errors have (obviously) all disappeared, however I am still having issues getting the alsa drivers to function and the alsaconf utility still will not complete...

EDIT - http://portal.suse.com/sdb/en/1999/10/l … -600e.html
http://main.linuxfocus.org/~guido/gento … onfig.html
Some useful information about the system I'm working on. (except I've modded to a P3 Cel 600 and 544Mb RAM)


- Official Board N00b - Your patience and advice is  greatfully recieved!

Offline

#30 2005-03-19 17:21:21

Katch
Member
Registered: 2005-03-16
Posts: 17

Re: New Linux User - New Mission - Better Get Comfortable

Ok back to the soundcard issue.

I'm fairly certain I need to tell Linux and the ALSA drivers exactly where and how the card is set up. I have this information and have ensured the card is set up correctly using a dos app for the purpose.

The cofiguration in question is as follows -

#cat /etc/modules.d/alsa 
# Alsa 0.9.X kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
#alias snd-card-0 snd-cs4232
alias snd-card-0 snd-cs4236 
# You have to specify every damm paramter to get it working:
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220 fm_port=0x388 irq=5 dma1=1 dma2=0
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

Now in the various places I have seen this fix it says this code is in either /etc/modules.conf or /etc/modprobe.d/alsa or /etc/modules.d/alsa or even /etc/modprobe.conf.

I have tried placing it in the modprobe.conf file in my /etc but it doesn't seem to work the trick. The /modprobe.d/alsa and /modprobe.d/alsa files do not exist on my setup.

The alsaconf utility still fails to complete properly...


- Official Board N00b - Your patience and advice is  greatfully recieved!

Offline

#31 2005-03-19 17:47:04

Katch
Member
Registered: 2005-03-16
Posts: 17

Re: New Linux User - New Mission - Better Get Comfortable

got it!!!!!!!!!!!!!!!!!!!!!!

It was in the modprobe.conf file, just a few formating errors.

I feel good now big_smile

Next...

Wireless Networking
&
KDE from a CD somehow


- Official Board N00b - Your patience and advice is  greatfully recieved!

Offline

#32 2005-03-19 19:48:17

Katch
Member
Registered: 2005-03-16
Posts: 17

Re: New Linux User - New Mission - Better Get Comfortable

Ok,

To make getting various packages for KDE and my Wireless setup easier I'm going to try and get my wired network working first.

So the PCMCIA Realtek ethernet card is in but I have no idea how to a)get it flashing and alive b)connect it out of my gateway to use pacman to get packages from the ftps...

lost...


- Official Board N00b - Your patience and advice is  greatfully recieved!

Offline

#33 2005-03-21 15:38:09

DeusExLinux
Member
Registered: 2005-03-18
Posts: 98

Re: New Linux User - New Mission - Better Get Comfortable

which driver does it use?  google the model number.


And on the 8th day, God gave the people Google so that all the problems of the universe could be researched from one central place.  And it was good.

Offline

#34 2005-03-21 15:47:05

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: New Linux User - New Mission - Better Get Comfortable

Katch wrote:

So the PCMCIA Realtek ethernet card is in but I have no idea how to a)get it flashing and alive b)connect it out of my gateway to use pacman to get packages from the ftps...

lost...

ok, let's try this.... add pcmcia to the daemons array in rc.conf.  from there, reboot (or just start the daemon manually) and run a "cardctl ident" to see if pcmcia recognized your card.... modprobe the network driver and then you can simply run:

# ifconfig eth0 up
# dhcpcd eth0

to start up your network... if that works, then set the proper values in rc.conf

Offline

Board footer

Powered by FluxBB