You are not logged in.

#1 2010-04-30 23:40:22

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

change fan speed with catalyst-test (ATI HD 4850)

Hi guys!

I just installed the catalyst-test driver on my video card because it's making so much noise. The installation was kind of straightforward. (at least more straightforward than expected.)
I just can't get how to change the fan speed. I used google and searched in this forum but I couldn't find it and get tired of searching. Can anyone help me?

Thanks in advance. smile

Offline

#2 2010-05-01 02:56:49

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

Hi!

To view the fan speed:
$ aticonfig --pplib-cmd "get fanspeed 0" --> 0 if you have single card

To change the fan speed:
$ aticonfig --pplib-cmd "set fanspeed 0 X" -->X is a porcentage 0-100%

To view the temperature:
$ aticonfig --adapter=0 --od-gettemperature
or
$ aticonfig --odgt

Offline

#3 2010-05-01 08:52:23

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

Thanks, but I get this: sad

I searched a bit in the internet and that seems to be a common problem. F****** ATI! hmm
Has anybody a solution to control the fan speed? Is downgrading xorg-server and trying catalyst (instead of catalyst-test) worth a try?

 display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series
OpenGL version string: 3.2.9756 Compatibility Profile Context
aticonfig --pplib-cmd "get version"
PPLIB version is 1.4 and is active!
aticonfig --adapter=0 --od-gettemperature

Adapter 0 - ATI Radeon HD 4800 Series
            Sensor 0: Temperature - 45.50 C
aticonfig --pplib-cmd "get fanspeed 0"
PPLIB command execution has failed!
ati_pplib_cmd: execute "get" failed!
aticonfig --pplib-cmd "set fanspeed 0 50"
PPLIB command execution has failed!
ati_pplib_cmd: execute "set" failed!

Offline

#4 2010-05-01 14:43:56

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

Now I'm with xf86-video-ati driver, so I can't test if it works. But few weeks ago I had catalyst-test installed and the commands worked, if I remember well.
Have you added fglrx module in rc.conf? Have you done aticonfig --initial to generate a xorg.conf? Have you disabled KMS adding "nomodeset" after kernel in grub?
I have the same card,  4850.

Last edited by Crozepp (2010-05-01 14:48:05)

Offline

#5 2010-05-01 15:04:13

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

I did everything as I should...

Here is my xorg.conf

That is the only thing that could be wrong.

Why did you switch to the open ati driver?
Isn't your card noisy?

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc"
    FontPath     "/usr/share/fonts/100dpi:unscaled"
    FontPath     "/usr/share/fonts/75dpi:unscaled"
    FontPath     "/usr/share/fonts/TTF"
    FontPath     "/usr/share/fonts/Type1"
    FontPath     "/usr/share/fonts/local"
EndSection

Section "Module"
    Load  "dri2"
    Load  "extmod"
    Load  "record"
    Load  "dri"
    Load  "dbe"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

#Section "Monitor"

    #DisplaySize      380   300    # mm
#    Identifier   "Monitor0"
#    VendorName   "NEC"
#    ModelName    "90GX2"
#    HorizSync    31.0 - 81.0
#    VertRefresh  56.0 - 75.0
#    Option        "DPMS"
#EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                # [<bool>]
        #Option     "SWcursor"               # [<bool>]
        #Option     "Dac6Bit"                # [<bool>]
        #Option     "Dac8Bit"                # [<bool>]
        #Option     "BusType"                # [<str>]
        #Option     "CPPIOMode"              # [<bool>]
        #Option     "CPusecTimeout"          # <i>
        #Option     "AGPMode"                # <i>
        #Option     "AGPFastWrite"           # [<bool>]
        #Option     "AGPSize"                # <i>
        #Option     "GARTSize"               # <i>
        #Option     "RingSize"               # <i>
        #Option     "BufferSize"             # <i>
        #Option     "EnableDepthMoves"       # [<bool>]
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "NoBackBuffer"           # [<bool>]
        #Option     "DMAForXv"               # [<bool>]
        #Option     "FBTexPercent"           # <i>
        #Option     "DepthBits"              # <i>
        #Option     "PCIAPERSize"            # <i>
        #Option     "AccelDFS"               # [<bool>]
        #Option     "IgnoreEDID"             # [<bool>]
        #Option     "DisplayPriority"        # [<str>]
        #Option     "PanelSize"              # [<str>]
        #Option     "ForceMinDotClock"       # <freq>
        #Option     "ColorTiling"            # [<bool>]
        #Option     "VideoKey"               # <i>
        #Option     "RageTheatreCrystal"     # <i>
        #Option     "RageTheatreTunerPort"     # <i>
        #Option     "RageTheatreCompositePort"     # <i>
        #Option     "RageTheatreSVideoPort"     # <i>
        #Option     "TunerType"              # <i>
        #Option     "RageTheatreMicrocPath"     # <str>
        #Option     "RageTheatreMicrocType"     # <str>
        #Option     "ScalerWidth"            # <i>
        #Option     "RenderAccel"            # [<bool>]
        #Option     "SubPixelOrder"          # [<str>]
        #Option     "ShowCache"              # [<bool>]
        #Option     "DynamicClocks"          # [<bool>]
        #Option     "VGAAccess"              # [<bool>]
        #Option     "ReverseDDC"             # [<bool>]
        #Option     "LVDSProbePLL"           # [<bool>]
        #Option     "AccelMethod"            # <str>
        #Option     "DRI"                    # [<bool>]
        #Option     "ConnectorTable"         # <str>
        #Option     "DefaultConnectorTable"     # [<bool>]
        #Option     "DefaultTMDSPLL"         # [<bool>]
        #Option     "TVDACLoadDetect"        # [<bool>]
        #Option     "ForceTVOut"             # [<bool>]
        #Option     "TVStandard"             # <str>
        #Option     "IgnoreLidStatus"        # [<bool>]
        #Option     "DefaultTVDACAdj"        # [<bool>]
        #Option     "Int10"                  # [<bool>]
        #Option     "EXAVSync"               # [<bool>]
        #Option     "ATOMTVOut"              # [<bool>]
        #Option     "R4xxATOM"               # [<bool>]
    Identifier  "Card0"
    Driver      "fglrx"
    VendorName  "ATI Technologies Inc"
    BoardName   "RV770 [Radeon HD 4850]"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection

Offline

#6 2010-05-01 16:10:43

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

I have a xorg.conf backup from my days with fglrx:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

I left fglrx because the slow resizing, maximizing and unmaximizing with compiz and the tearfull video playback without opengl. I know that there is a patched Xorg to solve the maximizing lag but I think that it's a dirty solution. My fan was noisy, but I cleaned well the card and now is quiet. Before that the main reason to use fglrx for me was the powersaving and fan control. I'm happy now with free drivers, I don't have xorg.conf file, compiz runs smooth as it should be and video playback in fullscreen is tearfree.

Offline

#7 2010-05-01 17:59:54

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

OK, thanks. I'm not using compiz and not even a DE, just a tiling WM. So I have different priorities. I remember that the fan was noisy even when the video card was new. But I will clean and try.

I used the makepkg which was recommended in the wiki of ATI catalyst. Was this the right choice?

Offline

#8 2010-05-01 18:24:15

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

I used the makepkg which was recommended in the wiki of ATI catalyst. Was this the right choice?

Yes. But to install catalyst I used an AUR helper ("clyde" in my case http://wiki.archlinux.org/index.php/AUR_Helpers ). The method is like makepkg but in an easier way. The commands are like pacman. To install manually catalyst from AUR:

# pacman -Rd libgl ati-dri xf86-video-ati
# pacman -S base-devel

Go to http://aur.archlinux.org/packages.php?ID=29111 and download the Tarball

Build the pkg:

$ tar -xvzf catalyst.tar.gz
$ cd catalyst
$ makepg -s

Install the package:

# pacman -U "The name of the generated package".pkg.tar.gz

Then open /boot/grub/menu.lst and add "nomodeset" to disable KMS in the kernel line, add "fglrx" in /etc/rc.conf, exit from X and run aticonfig --initial to generate an Xorg.conf. Reboot.

Offline

#9 2010-05-01 19:50:36

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

I usually use yaourt. I didn't even know that there are other 'AUR helpers' (also didn't know this term)
But because the guy who wrote the wiki said that the makepkg from the other guy is better I used a different makepkg for the first time.

So you used the makepkg from the AUR I guess? If you used an AUR helper ...

Do you run your video card on x86_64 or i686? (Maybe this could be the difference and I messed up the lib32)

(Btw: I'm using arch for some months now but it is the first distro I use so there is less lack of knowledge of the specifications of arch as of the 'basic' stuff.)

EDIT: I just realized that in the default conf the AUR helper ask if you want to change the pkgbuild. I forgot this because I never do this so I disabled this question in yaourt.

EDIT2: The custom makepkg wasn't about catalyst-test but about lib32-catalyst-utils. I used the standard makepkg for catalyst-test.

EDIT3: I edited the xorg.conf to have it most possible similar to yours. It still doesn't work. I even recompiled the package with clyde. No effect. I think I will try to sell this card and buy a nvidia. sad

Last edited by Maximalminimalist (2010-05-01 20:21:01)

Offline

#10 2010-05-01 21:07:25

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

I installed "catalyst-test" with clyde on my i686 system. I don't know why you can't set your fan speed hmm If you've followed the steps it should run fine. Maybe with catalyst 10.4 the things have been changed? I don't know. Have you looked to the manpage of aticonfig?

Last edited by Crozepp (2010-05-01 21:09:52)

Offline

#11 2010-05-01 21:15:10

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

The aticonfig --help doesn't tell anything about the fan speed control. That's why I didn't know how to change it. (Or maybe I just still can't see it.)

Maybe I will try to compile the lib32-catalyst-utils with the makepkg from the AUR. Anyway ... ATI sucks. -.-

If I buy a nvidia, can I expect to be able to change the fan speed? They have better linux support as I heard.

Offline

#12 2010-05-01 21:30:07

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

Try man aticonfig.
As far as I know Catalyst package is compatible with 64 and 32 bits. And it provides the fan management. I never had problems with this.

Offline

#13 2010-05-01 21:37:08

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

"no manual entry for aticonfig" O_o

Offline

#14 2010-05-01 21:45:20

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

I'm installing catalyst-test


Well... I can't set the fanspeed and the aticonfig --help don't show anything so you are right.  Sorry but I can't help you.

Last edited by Crozepp (2010-05-01 22:16:17)

Offline

#15 2010-05-01 21:56:20

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

Thanks for your help. I will sleep now. Too tired...

Don't wanna stop.^^ I'm trying catalyst just right now.

Last edited by Maximalminimalist (2010-05-01 22:07:30)

Offline

#16 2010-05-01 22:18:09

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

Sigh...all this time spent for nothing. hmm

Thanks anyway. smile

Do you think this is specific in arch or catalyst is just not able any more to do that with this card?

Last edited by Maximalminimalist (2010-05-01 22:20:48)

Offline

#17 2010-05-01 22:22:44

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

Maximalminimalist wrote:

Thanks for your help. I will sleep now. Too tired...

Don't wanna stop.^^ I'm trying catalyst just right now.

It's strange. With catalyst-test

[crozepp@myhost ~]$ aticonfig --pplib-cmd "get fanspeed 0"
Fan speed query: 
Query Index: 0, Speed in percent
Result: Fan Speed: 29%
[crozepp@myhost ~]$ aticonfig --pplib-cmd "set fanspeed 0 50"
PPLIB command execution is Successful!

Last edited by Crozepp (2010-05-01 22:23:35)

Offline

#18 2010-05-01 22:34:42

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

Do you have a manual entry for aticonfig? I will try again. Maybe I will be more lucky.

I think there is an issue with the lib32-catalyst-utils...

Offline

#19 2010-05-01 22:47:14

Crozepp
Member
From: Basque Country
Registered: 2010-04-03
Posts: 41

Re: change fan speed with catalyst-test (ATI HD 4850)

Maximalminimalist wrote:

Do you have a manual entry for aticonfig? I will try again. Maybe I will be more lucky.

I think there is an issue with the lib32-catalyst-utils...

No, and aticonfig --help is useless.
I'm using xorg 1.7.6 and kernel 2.6.33.
My /etc/rc.conf:

MODULES=(fglrx !radeon ...)

My /boot/grub/menu.lst:

kernel /boot/vmlinuz26 root=/dev/disk/by-uuid/7b589719-d7dd-45f2-ab42-ae4027bdd4bc ro nomodeset

Don't forget to quit X and run aticonfig --initial as root

Last edited by Crozepp (2010-05-01 22:48:36)

Offline

#20 2010-05-01 23:42:01

Maximalminimalist
Member
Registered: 2009-09-20
Posts: 112

Re: change fan speed with catalyst-test (ATI HD 4850)

Everything is the same in my config...I'll do a post in the AMD/ATI Bar & Grill thread.

Offline

Board footer

Powered by FluxBB