You are not logged in.

#1 2005-03-20 12:58:29

incinerator
Member
From: Edinburgh, Scotland
Registered: 2005-02-15
Posts: 80

wiki search not working

When trying to use the search function at http://wiki2.archlinux.org/ I get following error message:

lib/DbaDatabase.php:54: Fatal[256]: dba_open(/home/judd/public_html/db/wiki_pagedb.gdbm,w): Driver initialization failed for handler: gdbm: Can't be writer

    * file: /home/judd/public_html/db/wiki_pagedb.gdbm
    * mode: w
    * handler: gdbm


lib/DbaDatabase.php:54: Fatal[256]: dba_open(/home/judd/public_html/db/wiki_pagedb.gdbm,w): Driver initialization failed for handler: gdbm: Can't be writer

    * file: /home/judd/public_html/db/wiki_pagedb.gdbm
    * mode: w
    * handler: gdbm

I tried to search a couple of times but to no avail, I always fails.

Cheers,
Dominik

Offline

#2 2005-03-20 19:08:08

smith
Member
From: Crescent City, CA
Registered: 2005-02-19
Posts: 77

Re: wiki search not working

Just tried a few searches and it works for me.  I have received a similar error message in the past, but after repeating my search the error message was gone.  Give it another shot.


I have nothing to say, and I am saying it.

Offline

#3 2005-03-20 19:13:00

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: wiki search not working

I just tried a search. It failed the first 3 times. Last time it worked.

gdbm is not really an optimal solution for a website, where you can have many concurrent users attempting to write at the same time. If one process gets a lock on writing, for instance, and somehow dies or hoses up, then everyone else must wait until that lock expires...Or until the lock is somehow released.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#4 2005-03-20 20:15:38

incinerator
Member
From: Edinburgh, Scotland
Registered: 2005-02-15
Posts: 80

Re: wiki search not working

are you suggesting the wiki software is shite, then?

Offline

#5 2005-03-20 20:21:12

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: wiki search not working

its propaganda, cactus is developing his own wiki software...

mind you he's right. wink

Dusty

Offline

#6 2005-03-21 02:49:29

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: wiki search not working

Due to spamming the Wiki is configured in slow mode not allowing fast entries. This causes the error.
We are planning to change the Wiki system waiting for cactus's wiki (or another supporting user login, categories and php 5).

Offline

#7 2005-03-21 13:27:25

incinerator
Member
From: Edinburgh, Scotland
Registered: 2005-02-15
Posts: 80

Re: wiki search not working

Thx, that's exactly what I wanted to hear :-)

rasat wrote:

Due to spamming the Wiki is configured in slow mode not allowing fast entries. This causes the error.
We are planning to change the Wiki system waiting for cactus's wiki (or another supporting user login, categories and php 5).

Offline

Board footer

Powered by FluxBB