You are not logged in.

#1 2005-03-21 17:29:52

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Trouble Setting Up My Internet Connection and DHCP

I installed arch last night without a hitch.  Everything went well and once I was logged in to the system I tried to upgrade my system with pacman but wasn't able to connect to any servers.  I checked ifconfig and found that only lo was running and not eth0.  I tried to start eth0 but it said that the device could not be found.

When I was setting up my rc.conf file for interfaces I put

eth0 = "DHCP" 

as the install guide suggested.  This did not seem to work though.

I am using an ADSL connection but it is a home computer that is not attached to any network.  I would like the internet to be connected on startup and not have to do the adsl start everytime I want to get on the net.  What did I do wrong?  Any suggestions?

Next question is that on start up the prompt stalls once and says:

pciehp failed
hw_random failed

Any ideas on this?

Thanks in advance.

Offline

#2 2005-03-21 17:45:32

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Trouble Setting Up My Internet Connection and DHCP

the device could not be found because you don't have the module installed... when you probe the module, it creates an eth0 device for you.... do you know what module your card uses?

the failure stuff is from hotplug... i guess ignore it, or blacklist those devices...

Offline

#3 2005-03-21 17:58:32

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: Trouble Setting Up My Internet Connection and DHCP

No idea if it matters, but also try "dhcp" in lower caps.

Offline

#4 2005-03-21 18:02:34

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Trouble Setting Up My Internet Connection and DHCP

i3839 wrote:

No idea if it matters, but also try "dhcp" in lower caps.

I was gonna say that too, after getting the module up

Offline

#5 2005-03-21 18:50:05

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Re: Trouble Setting Up My Internet Connection and DHCP

Sorry about my posting, the "dhcp" was in lower case.  I don't know what module my card uses.  How do I find that out?

Offline

#6 2005-03-21 19:42:57

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Trouble Setting Up My Internet Connection and DHCP

El Guapo wrote:

Sorry about my posting, the "dhcp" was in lower case.  I don't know what module my card uses.  How do I find that out?

what card is it? can you post the output of "lspci"?

Offline

#7 2005-03-21 19:51:40

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Re: Trouble Setting Up My Internet Connection and DHCP

I will have to get that info for you later.  I am not at my arch computer at the moment (as you can tell, I am on the internet).  wink

Thanks for your help though!

Offline

#8 2005-03-21 20:32:49

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: Trouble Setting Up My Internet Connection and DHCP

You might have to load a card module by hand to the module section of rc.conf, actually this is the case on my laptop.


Microshaft delenda est

Offline

#9 2005-03-21 21:41:07

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Re: Trouble Setting Up My Internet Connection and DHCP

My card is a Realtek RTL8139 Family PCI Fast Ethernet NIC.  Is that enough information?

Offline

#10 2005-03-21 21:44:03

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,017

Re: Trouble Setting Up My Internet Connection and DHCP

Yhm, am I blind or did you write you don't connect to net via LAN, but locally, via ADSL?

If that's the case, you shouldn't worry about eth0. You should just add 'adsl' to DAEMONS section of /etc/rc.conf to make it start on boot - granted that '/etc/rc.d/adsl start' puts your internet connection up.

Offline

#11 2005-03-21 21:56:18

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Trouble Setting Up My Internet Connection and DHCP

El Guapo wrote:

My card is a Realtek RTL8139 Family PCI Fast Ethernet NIC.  Is that enough information?

add 8139too to the modules array in rc.conf

Offline

#12 2005-03-21 22:37:28

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Re: Trouble Setting Up My Internet Connection and DHCP

Is that all I have to do?  What is the next step, or is there one?

Offline

#13 2005-03-21 23:16:23

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Trouble Setting Up My Internet Connection and DHCP

look at this wikipage

wiki->howto->network...->static ip and dhcp

that should get you on the net, hopefully  big_smile


arch + gentoo + initng + python = enlisy

Offline

#14 2005-03-21 23:42:19

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Re: Trouble Setting Up My Internet Connection and DHCP

Right, the Wiki page.  You will have to forgive me as I am coming from distros where the documentation is weak at best.  Arch is very well documented and organized.  Kudos!

Offline

#15 2005-03-22 00:03:57

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Trouble Setting Up My Internet Connection and DHCP

yeah, the wiki has gotten pretty good,
when I started using arch there was no wiki at all and I was totally clueless(even more than now)
mrgreen helped me fix my network then,


arch + gentoo + initng + python = enlisy

Offline

#16 2005-03-22 05:16:17

El Guapo
Member
From: 51N 114W
Registered: 2005-03-21
Posts: 13

Re: Trouble Setting Up My Internet Connection and DHCP

I just wanted to post and say thanks for all the help.  Everything is working now and life is good.  I am upgraded and I have found the Wiki to get everything else all set up.

Thanks again for all of your help, I have never had issues resolved so fast on a forum before!   big_smile

Offline

#17 2005-03-22 05:39:09

z4ziggy
Member
From: Israel
Registered: 2004-03-29
Posts: 573
Website

Re: Trouble Setting Up My Internet Connection and DHCP

El Guapo wrote:

...I have never had issues resolved so fast on a forum before!   big_smile

we work at Arch speed... 8)

Offline

#18 2005-03-22 05:44:09

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: Trouble Setting Up My Internet Connection and DHCP

z4ziggy wrote:
El Guapo wrote:

...I have never had issues resolved so fast on a forum before!   big_smile

we work at Arch speed... 8)

Another happy customer. Gives me a warm, fuzzy feeling. Or maybe that's just my hat. lol


·¬»· i am shadowhand, powered by webfaction

Offline

#19 2005-03-22 05:57:56

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Trouble Setting Up My Internet Connection and DHCP

shadowhand wrote:
z4ziggy wrote:
El Guapo wrote:

...I have never had issues resolved so fast on a forum before!   big_smile

we work at Arch speed... 8)

Another happy customer. Gives me a warm, fuzzy feeling. Or maybe that's just my hat. lol

i vote hat

Offline

Board footer

Powered by FluxBB