You are not logged in.

#1 2005-03-21 20:57:02

Miszcz
Member
Registered: 2004-09-25
Posts: 24

Problem with HP 690C

# ptal-init setup

Probe parallel port "-base 0x378 -basehigh 0x778 -device /dev/lp0" (y/[n])?  y

    *** Found "DESKJET 690C" but failed to communicate with it!
    *** Elapsed time for this attempt was 0 second(s).
    *** Check syslog file for ptal-mlcd error messages.
    *** See hpoj documentation for troubleshooting information.

Press <Enter> alone to continue, or if you would like to probe an
undetected parallel port, then enter its hexadecimal base address
# tail /var/log/lpr.log

Mar 21 21:49:04 Misiek ptal-mlcd: SYSLOG at ExMgr.cpp:3524, dev=<mlc:par:probe>, pid=5486, e=2, t=1111438144         Using parallel port '-porttype bpp -base 0x378'.
Mar 21 21:49:04 Misiek ptal-mlcd: SYSLOG at ExMgr.cpp:652, dev=<mlc:par:probe>, pid=5487, e=2, t=1111438144         ptal-mlcd successfully initialized.
Mar 21 21:49:04 Misiek ptal-mlcd: ERROR at /home/tobias/Install/Arch/eigene-packages/hpoj/src/hpoj-0.91/mlcd/ParPort.h:782, dev=<mlc:par:probe@/dev/lp0>, pid=5487, e=11, t=1111438144         setModes: negotiate(0x18) failed!
Mar 21 21:49:04 Misiek ptal-mlcd: ERROR at /home/tobias/Install/Arch/eigene-packages/hpoj/src/hpoj-0.91/mlcd/ParPort.h:641, dev=<mlc:par:probe@/dev/lp0>, pid=5487, e=25, t=1111438144         write: invalid mode=0x000!
Mar 21 21:49:04 Misiek ptal-mlcd: ERROR at ExMgr.cpp:3606, dev=<mlc:par:probe@/dev/lp0>, pid=5487, e=25, t=1111438144         llioSetup: write(reset byte) failed!
Mar 21 21:49:04 Misiek ptal-mlcd: ERROR at ExMgr.cpp:2559, dev=<mlc:par:probe@/dev/lp0>, pid=5487, e=25, t=1111438144         Couldn't set up MLC interface!

Can someone help me ?

Offline

#2 2005-03-21 22:13:21

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Problem with HP 690C

Did you load the modules for the parallel port? They are parport_pc and parport

Offline

#3 2005-03-21 22:37:19

Miszcz
Member
Registered: 2004-09-25
Posts: 24

Re: Problem with HP 690C

yes

Offline

#4 2005-03-22 07:55:10

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Problem with HP 690C

lp


Mr Green

Offline

#5 2005-03-22 13:55:42

Miszcz
Member
Registered: 2004-09-25
Posts: 24

Re: Problem with HP 690C

ptal-init setup befor 1st post

Probe for parallel-connected devices ([y]/n)?  

Successfully loaded kernel module "lp" for the device probe.

Warning: Probing incorrect I/O port addresses could result in system
instability and/or data loss!  Consult your hardware documentation, BIOS
setup and/or kernel messages to verify correct base addresses in the
following prompts.   Also, take care not to probe parallel ports that
have non-printer devices (such as disk or tape drives) connected.

Offline

#6 2005-03-22 14:02:00

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,750

Re: Problem with HP 690C

I used a hp deskjet 660c via paralell port....

rc.conf

lp parport-pc

have you got printers.conf in /etc/cups ????

/dev/lp0 ??

HTH...


Mr Green

Offline

Board footer

Powered by FluxBB