You are not logged in.

#1 2010-05-02 13:08:21

OK100
Member
From: [U==]
Registered: 2010-04-26
Posts: 453

problem compiling fatrat

Hi,

I can't build fatrat package. Each time I try to compile it I get this error:

[eee@701 ~]$ yaourt -S fatrat
==> Resuming previous build

==> Downloading fatrat PKGBUILD from AUR...
--2010-05-02 14:58:24--  http://aur.archlinux.org/packages/fatrat/fatrat.tar.gz
Resolving aur.archlinux.org... 208.92.232.29
Connecting to aur.archlinux.org|208.92.232.29|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 711 [application/x-tgz]
Saving to: "fatrat.tar.gz"

100%[======================================>] 711         --.-K/s   in 0s      

2010-05-02 14:58:26 (24.0 MB/s) - "fatrat.tar.gz" saved [711/711]

bsdtar: Removing leading '/' from member names
x fatrat.install
x PKGBUILD

    
      First Submitted: Sun, 04 May 2008 14:49:20 +0000    
fatrat 1.1.2-1 : QT4 based download manager with support for HTTP, FTP, SFTP, BitTorrent, rapidshare and more
( Unsupported package: Potentally dangerous ! )
==>  Edit PKGBUILD ? [Y/n] ("A" to abort)
==>   ----------------------------------------------
==>n


==> fatrat dependencies:
 - gloox (already installed)
 - curl (already installed)
 - qt (already installed)
 - libtorrent-rasterbar (already installed)
 - asio (already installed)
 - cmake (already installed)
 - libssh2 (already installed)
==>  Edit fatrat.install ? [Y/n] ("A" to abort)
==>   ----------------------------------------------
==>n

==>  Continue the building of fatrat ? [Y/n]
==>   ----------------------------------------------
==>


==> Install or build missing dependencies for fatrat:
==> Building and installing package

==> fatrat dependencies:
 - gloox (already installed)
 - curl (already installed)
 - qt (already installed)
 - libtorrent-rasterbar (already installed)
 - asio (already installed)
 - cmake (already installed)
 - libssh2 (already installed)
==> Making package: fatrat 1.1.2-1 i686 (Sun May  2 15:04:15 CEST 2010)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
  -> Found fatrat-1.1.2.tar.gz in build dir
==> Validating source files with md5sums...
    fatrat-1.1.2.tar.gz ... Passed
==> Extracting Sources...
  -> Extracting fatrat-1.1.2.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
-- libtorrent found OK
-- boost-datetime found OK
-- gloox 1.0 found OK
Reading collection config file...
Generating help for fatrat.qhp...
Building up file structure...
Insert custom filters...
Insert help data for filter section (1 of 1)...
Insert files...
Insert contents...
Insert indices...
Documentation successfully generated.
Creating collection file...
-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/yaourt-tmp-eee/aur-fatrat/fatrat/src/fatrat-1.1.2
[  1%] Building CXX object CMakeFiles/fatrat.dir/src/AppTools.cpp.o
In file included from /usr/include/libtorrent/hasher.hpp:41:0,
                 from /usr/include/libtorrent/storage.hpp:59,
                 from /usr/include/libtorrent/create_torrent.hpp:41,
                 from /tmp/yaourt-tmp-eee/aur-fatrat/fatrat/src/fatrat-1.1.2/src/tools/CreateTorrentDlg.h:35,
                 from /tmp/yaourt-tmp-eee/aur-fatrat/fatrat/src/fatrat-1.1.2/src/AppTools.cpp:35:
/usr/include/zlib.h:1583:39: error: declaration of C function 'off_t gzseek64(void*, off_t, int)' conflicts with
/usr/include/zlib.h:1567:30: error: previous declaration 'off64_t gzseek64(void*, off64_t, int)' here
/usr/include/zlib.h:1584:39: error: declaration of C function 'off_t gztell64(void*)' conflicts with
/usr/include/zlib.h:1568:30: error: previous declaration 'off64_t gztell64(void*)' here
/usr/include/zlib.h:1585:41: error: declaration of C function 'off_t gzoffset64(void*)' conflicts with
/usr/include/zlib.h:1569:30: error: previous declaration 'off64_t gzoffset64(void*)' here
/usr/include/zlib.h:1586:46: error: declaration of C function 'uLong adler32_combine64(uLong, uLong, off_t)' conflicts with
/usr/include/zlib.h:1570:26: error: previous declaration 'uLong adler32_combine64(uLong, uLong, off64_t)' here
/usr/include/zlib.h:1587:44: error: declaration of C function 'uLong crc32_combine64(uLong, uLong, off_t)' conflicts with
/usr/include/zlib.h:1571:26: error: previous declaration 'uLong crc32_combine64(uLong, uLong, off64_t)' here
make[2]: *** [CMakeFiles/fatrat.dir/src/AppTools.cpp.o] Error 1
make[1]: *** [CMakeFiles/fatrat.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: Build Failed.
    Aborting...
Error: Makepkg was unable to build fatrat package.

missing dependency for evince : gnome-icon-theme>=2.30.2
missing dependency for kdemod-extragear-opera : qtmod
[eee@701 ~]$

Any idea?

Offline

#2 2010-05-13 05:08:58

deadpink
Member
Registered: 2007-04-16
Posts: 8

Re: problem compiling fatrat

I have the exact same problem also!

Offline

#3 2010-05-13 15:15:48

n0dix
Member
Registered: 2009-09-22
Posts: 956

Re: problem compiling fatrat

Try with fatrat-git package, also in AUR.

Offline

#4 2010-05-14 07:44:41

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,009

Re: problem compiling fatrat

Seems to be a zlib issue.

Offline

#5 2010-05-17 04:06:42

deadpink
Member
Registered: 2007-04-16
Posts: 8

Re: problem compiling fatrat

fatrat-git returns for me the same error,

Offline

#6 2010-05-18 17:57:21

tomd123
Developer
Registered: 2008-08-12
Posts: 565

Re: problem compiling fatrat

Offline

Board footer

Powered by FluxBB