You are not logged in.

#1 2010-03-06 00:48:20

Fire-Ice
Member
From: Indiana
Registered: 2006-09-14
Posts: 8

Headphones no longer mute speakers with 2.6.33

Hi,

I upgraded my kernel from 2.6.31 to 2.6.33 and plugging in my headphones no longer causes my laptop's speakers to mute. According to lspci, my sound card is:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Anyone else have this same issue/know a workaround?

Edit: 'lsmod | grep snd' gives the following:

snd_hda_codec_realtek   185636  1 
snd_seq_dummy           1067  0 
snd_seq_oss            24727  0 
snd_seq_midi_event      4452  1 snd_seq_oss
snd_seq                41675  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          4281  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_hda_intel          19369  4 
snd_pcm_oss            33405  0 
snd_hda_codec          60497  2 snd_hda_codec_realtek,snd_hda_intel
snd_mixer_oss          14491  1 snd_pcm_oss
snd_hwdep               5006  1 snd_hda_codec
snd_pcm                57393  4 snd_hda_intel,snd_pcm_oss,snd_hda_codec
snd_timer              15642  3 snd_seq,snd_pcm
snd                    43532  17 snd_hda_codec_realtek,snd_seq_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm_oss,snd_hda_codec,snd_mixer_oss,snd_hwdep,snd_pcm,snd_timer
soundcore               5071  1 snd
snd_page_alloc          5841  2 snd_hda_intel,snd_pcm

Last edited by Fire-Ice (2010-03-06 00:52:33)

Offline

#2 2010-03-06 20:12:44

barzam
Member
From: Sweden
Registered: 2009-01-27
Posts: 277

Re: Headphones no longer mute speakers with 2.6.33

I noticed the same thing (using kernel-netbook 2.6.33-3 from the aur). I haven't found a fix yet, atm I'll just manually mute my speaker in alsamixer. Sound chip is
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Eeepc 1005HA

Offline

#3 2010-03-10 00:56:36

vanoff
Member
Registered: 2009-08-20
Posts: 1

Re: Headphones no longer mute speakers with 2.6.33

I was in the library earlier today, so as a break after an hour of studying I decided to put some music on. I happen to like Dr DRE's beats so I put on a song called "F*ck You".

Needless to say, the people were not happy when I broke the silence and their concentration with "I just wanna f*ck bad bitches..." ... you can google the rest of the lyrics

More than a minute after the vulgarity of the situation a girl interrupted me to tell me to turn off the music... I just blushed and double checked if indeed that's the case because I could definitely hear the song via the headphones, but when it's loud I couldn't notice the speakers also at the same time..


Actually I'm an ubuntu user, so now I just boot into a previous stable kernel where it all worked well.

I'm digging around for a workaround with the latest kernel smile

Offline

#4 2010-03-11 02:07:24

lynucs
Member
Registered: 2008-05-05
Posts: 67
Website

Re: Headphones no longer mute speakers with 2.6.33

vanoff, ymmd!


Pinky, are you pondering what I'm pondering?

Offline

#5 2010-04-11 08:48:01

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,495

Re: Headphones no longer mute speakers with 2.6.33

May i join the party?
Yesterday, late night, my wife was sleeping but i can't, so i decided to listen some music in another room.
five minutes later, on the end of bohemian rhapsody, i see her very hungry... "ARE YOU MAD?" seems she said.
Then i realized all.

By the way, adding:
options snd-hda-intel model=auto
to /etc/modprobe.d/modprobe.conf
solved the issue; at least on asus 1005ha on kernel26 2.6.33.2-1

In case you ask, the internal mic is still unseen by the system.

Last edited by kokoko3k (2010-04-11 08:48:39)

Offline

#6 2010-04-14 02:03:54

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: Headphones no longer mute speakers with 2.6.33

Yep, same problem here with Intel ALC269.  Adding the line in modprobe.conf as suggested above worked like a charm.

Offline

#7 2010-04-14 02:27:23

shinythings
Member
Registered: 2010-03-06
Posts: 6

Re: Headphones no longer mute speakers with 2.6.33

Same problem here (Asus eee 901)

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Has this been reported in the bugtracker or upstream with the kernel devs? Works fine with 2.6.32.10, so definitely a regression.

Offline

#8 2010-04-30 15:18:09

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: Headphones no longer mute speakers with 2.6.33

vanoff wrote:

I was in the library earlier today, so as a break after an hour of studying I decided to put some music on. I happen to like Dr DRE's beats so I put on a song called "F*ck You".

Needless to say, the people were not happy when I broke the silence and their concentration with "I just wanna f*ck bad bitches..." ... you can google the rest of the lyrics

More than a minute after the vulgarity of the situation a girl interrupted me to tell me to turn off the music... I just blushed and double checked if indeed that's the case because I could definitely hear the song via the headphones, but when it's loud I couldn't notice the speakers also at the same time..

Haha, got my kernel upgrade this morning.  I've been at work for a few hours, and someone just came by to point out my music was coming though the laptop speakers.  Very embarrassing....

Offline

#9 2010-05-19 01:36:09

Fire-Ice
Member
From: Indiana
Registered: 2006-09-14
Posts: 8

Re: Headphones no longer mute speakers with 2.6.33

This issue appears to be fixed in the 2.6.34 kernel. However, if you're an EeePC 901 user like myself, you should wait to upgrade because you need a firmware file for the rt2860sta wireless driver.

Offline

#10 2010-10-20 02:38:59

Slax
Member
Registered: 2010-08-11
Posts: 39

Re: Headphones no longer mute speakers with 2.6.33

vanoff wrote:

I was in the library earlier today, so as a break after an hour of studying I decided to put some music on. I happen to like Dr DRE's beats so I put on a song called "F*ck You".

Needless to say, the people were not happy when I broke the silence and their concentration with "I just wanna f*ck bad bitches..." ... you can google the rest of the lyrics

More than a minute after the vulgarity of the situation a girl interrupted me to tell me to turn off the music... I just blushed and double checked if indeed that's the case because I could definitely hear the song via the headphones, but when it's loud I couldn't notice the speakers also at the same time..

Actually I'm an ubuntu user, so now I just boot into a previous stable kernel where it all worked well.

I'm digging around for a workaround with the latest kernel smile

Sorry to bump an ANCENT thread, but I just had to say. This happened to me just now and I thought of this thread.

I'm in the library jamming out some hardstyle on some IEMs for like 30 minutes and then the guy in front of me taps the table and is like " ... ".

The odd thing about my case is that my laptop has three speakers, 2 small drivers and a "subwoofer" that just sounds like a driver with no high-end response.
Anyway, it's a Lenovo Y550P, and when I plug in headphones, only the "2" of this "2.1" system is muted. That is, the "subwoofer" is not muted.

I'm so embarrassed because I rarely listen to hardstyle and this was some pretty hardbeat cheesy shit.

Audio devies according to lspci are:
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

I'd like to find a solution to the problem. Plugging in headphones should mute my "subwoofer".
Is there something I can change in a config file to let ALSA or OSS know that I have three speakers.

Last edited by Slax (2010-10-20 02:51:19)

Offline

#11 2010-10-27 10:32:36

Erus_Iluvatar
Member
Registered: 2010-04-01
Posts: 102

Re: Headphones no longer mute speakers with 2.6.33

Same here with "00:08.0 Audio device [0403]: nVidia Corporation MCP79 High Definition Audio [10de:0ac0] (rev b1)" (since 2.6.34)


I'm french, don't mind my mistakes in english.

Offline

Board footer

Powered by FluxBB