You are not logged in.

#1 2005-03-25 03:48:10

Registered: 2004-07-16
Posts: 14

problem with mencoder's oac option

I am having difficulty using mencoder to record output from a tv capture card.  Specifically it gives me an error that I have not specified a -oac option for the audio codec, however I have (and yes I have checked that the codec is enabled).  It also gives me the same error if I choose the -nosound option.  I am hoping that another Arch user out there can help me out with this.  Here is sample of the problem.

[alex@espc3 ~]$ /usr/bin/mencoder tv:// -tv driver=v4l2 width=360 height=288 outfmt=yuy2 input=0 device=/dev/v4l/video0 norm=NTSC chanlist=us-cable channel=3 adevice=/dev/dsp -oac mp3lame -lameopts cbr:br=256:mode=0 -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=1600 -ffourcc divx -o test.avi
MEncoder 1.0pre6-3.4.3 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

File not found: 'frameno.avi'
Failed to open frameno.avi
success: format: 9  data: 0x0 - 0x0
TV detected! ;-)
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <>
comment: first try, more to come ;-)
Selected device: BT878 video (Hauppauge (bt878))
Tuner cap:
Tuner rxs: LANG1 LANG2
Capabilites:  video capture  video overlay  VBI capture device  tuner  read/write  streaming
supported norms: 0 = PAL; 1 = NTSC; 2 = SECAM; 3 = PAL-Nc; 4 = PAL-M; 5 = PAL-N; 6 = NTSC-JP; 7 = PAL-60;
inputs: 0 = Television; 1 = Composite1; 2 = S-Video; 3 = Composite3;
Current input: 0
Current format: YUV420
v4l2: current audio mode is : LANG1
[V] filefmt:9  fourcc:0x32315659  size:640x480  fps:25.00  ftime:=0.0400

No audio encoder (-oac) selected. Select one (see -oac help) or use -nosound.




#2 2005-03-25 04:09:00

Registered: 2004-07-16
Posts: 14

Re: problem with mencoder's oac option

Problem solved!!

It turns out that mencoder freaks out at spaces in the -tv options.  Replacing the spaces in the -tv options with :'s solves the problem.



Board footer

Powered by FluxBB