You are not logged in.

#1 2005-03-25 04:33:03

OCNubStylee
Member
Registered: 2005-03-15
Posts: 25

Turning off GDM

I was loading X from runlevel 3 in inittab, but I recently restarted my computer and GDM loaded, and I can't figure out how to turn it off. My /etc/inittab is below:

#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)    Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

id:3:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

c1:2345:respawn:/sbin/agetty 38400 vc/1 linux
c2:2345:respawn:/sbin/agetty 38400 vc/2 linux
c3:2345:respawn:/sbin/agetty 38400 vc/3 linux
c4:2345:respawn:/sbin/agetty 38400 vc/4 linux
c5:2345:respawn:/sbin/agetty 38400 vc/5 linux
c6:2345:respawn:/sbin/agetty 38400 vc/6 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

#x:5:respawn:/usr/X11R6/bin/xdm -nodaemon
x:5:respawn:/opt/gnome/bin/gdm -nodaemon

# End of file

Anyone have any ideas?

Offline

#2 2005-03-25 04:50:45

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Turning off GDM

comment out this line:

x:5:respawn:/opt/gnome/bin/gdm -nodaemon 

also check your DAEMONS array in rc.conf... is gdm there?

Offline

#3 2005-03-25 04:54:43

smith
Member
From: Crescent City, CA
Registered: 2005-02-19
Posts: 77

Re: Turning off GDM

Check your /etc/rc.conf for gdm.


I have nothing to say, and I am saying it.

Offline

#4 2005-03-25 05:38:58

OCNubStylee
Member
Registered: 2005-03-15
Posts: 25

Re: Turning off GDM

Ah that was it, I forgot I added it there.

Thanks for the help!

Offline

#5 2005-03-25 13:15:24

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Turning off GDM

x:5:respawn:/usr/X11R6/bin/xdm -nodaemon

I have this line in my inittab and I'm using kde. Should I change it? What does that line actually mean?

Offline

#6 2005-03-25 18:48:02

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Turning off GDM

Penguin wrote:
x:5:respawn:/usr/X11R6/bin/xdm -nodaemon

I have this line in my inittab and I'm using kde. Should I change it? What does that line actually mean?

If everything is working fine, you don't need to change it. This line is to select the display manager to start by default. If you have

id:5:initdefault: 

in your inittab, your line will start xdm automatically.  Otherwise, it won't be used.
I use kdm (and KDE) so I have

id:5:initdefault:

and

x:5:respawn:/opt/kde/bin/kdm

Offline

#7 2005-03-25 19:28:31

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Turning off GDM

ok, I haven't touched my file:

#
# /etc/inittab
#

#  Runlevels:
#    0    Halt
#    1(S)    Single-user
#    2    Not used
#    3    Multi-user
#    4    Not used
#    5    X11
#    6    Reboot

id:3:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown
su:S:wait:/sbin/sulogin -p

c1:2345:respawn:/sbin/agetty 38400 vc/1 linux
c2:2345:respawn:/sbin/agetty 38400 vc/2 linux
c3:2345:respawn:/sbin/agetty 38400 vc/3 linux
c4:2345:respawn:/sbin/agetty 38400 vc/4 linux
c5:2345:respawn:/sbin/agetty 38400 vc/5 linux
c6:2345:respawn:/sbin/agetty 38400 vc/6 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

x:5:respawn:/usr/X11R6/bin/xdm -nodaemon

# End of file

where exactly would

id:5:initdefault:

be placed? Does it matter?

The way I've setup kde to start automatically was by adding kdm to the end of my daemons list.

The only reason why I am considering this inittab approach is because I cant get the cron daemon to work for regular user without manually restarting it as root (/etc/rc.d/crond restart) every time I log in. The same is true for ivman, although I am able to start a regular user instance of it without any root privaleages, which may be how it works but, it seems I'm the only one with the crond problem as regular user. Could this runlevel 5 in inittab be the answer to these strange problems? What are the advantages of setting kde to runlevel 5 versus 3 or what ever it is as default?

Offline

#8 2005-03-25 19:39:44

smith
Member
From: Crescent City, CA
Registered: 2005-02-19
Posts: 77

Re: Turning off GDM

You change the line

id:3:initdefault:

to

id:5:initdefault:

.  The benefit of using this approach is that kdm (and hence X) won't start on say run level 3.  This can be useful for fixing problems sometimes.  I don't know whether it will fix your crontab trouble.


I have nothing to say, and I am saying it.

Offline

#9 2005-03-25 20:09:11

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Turning off GDM

Well I made the change and it didn't make a difference.  :?  Oh well, nice to know how its set that up though, thanks alot for the help.

Offline

Board footer

Powered by FluxBB