You are not logged in.

#1 2005-03-29 01:13:40

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

running hot & loud

since the last kernel update (or possibly something else) my laptop has been running alot hotter than it used to.
I came home today and put it on my lap and now my leg is sweating...

I am running cpudynd with the following parameters : "-d -acpi -d -i 1 -p 0.5 0.90 -t 120 -h /dev/hda", but that's not really for this... it's the only acpi based service I have, and the acpi events are the from the default arch package...

I rebooted this morning, did nothing... when I came home it was at 57C... now we're at 50C, but it's still pretty warm.... the fan also seems a bit noisy...

any help or ideas? program recommendations?

Offline

#2 2005-03-29 01:14:56

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: running hot & loud

cpu frequency scaling? that is kernel specific isnt it?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-03-29 02:45:31

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: running hot & loud

have you tried powernowd? it has worked great for me when other power mgt daemons have failed, cpufreqd, etc. [edit: 2.6.10 kernel]

double check to make sure nothing is running in the background?

i hope powernowd will fix it, otherwise we'd probably need more info on your hardware and kernel options to help more.

Offline

#4 2005-03-29 03:14:48

polarrr
Member
Registered: 2004-09-12
Posts: 91

Re: running hot & loud

I have pretty much the same problem and I posted on laptop forum but...  Fans go off at 60 and stops at 50, but it runs up and down between 50 and 60 at 2 minutes interval when idle. So you can probably imagine this is one noisy laptop. I tried cpudyn, kernel cpufreq but nothing really worked.  :cry:

Offline

#5 2005-03-29 15:51:52

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: running hot & loud

yeah, I guess freq scaling would work... but I'm still concerned why it's running hot... and I rebooted into windows so I could play some warcraft3, and it kept overheating and crashing... so maybe it's just the hardware... ugh

Offline

#6 2005-03-29 17:40:00

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: running hot & loud

did your bios settings get changed somehow? if it's happening in windows too it now sounds more like a hardware or low-level issue.

Offline

#7 2005-03-29 19:01:47

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: running hot & loud

I haven't touched the bios... but I also haven't touched the windows install in like 4 months...

maybe there's some junk in the fan... I do have cats 8)
I'll crack it open and check it out later tonight

Offline

#8 2005-03-30 03:35:30

ramjet
Member
Registered: 2005-02-16
Posts: 37

Re: running hot & loud

concerning powernowd
aside from building and putting  it in rc.conf as a daemon is there anythign else u have to do to get it working?...
will it work with the default archlinux kernel?

Offline

#9 2005-03-30 09:13:48

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: running hot & loud

well..... why dont you have a look in top? check your cpu usage line

Cpu(s):  2.3% us,  0.3% sy,  0.0% ni, 97.0% id,  0.0% wa,  0.3% hi,  0.0% si

id means idle, so unused cycles, for me im only usin about 3% cpu. Check yours, could be an errant kernel process or something.

Offline

#10 2005-03-30 16:24:49

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: running hot & loud

ramjet wrote:

concerning powernowd
aside from building and putting  it in rc.conf as a daemon is there anythign else u have to do to get it working?...
will it work with the default archlinux kernel?

just build cpu frequency scaling into your kernel and run the daemon. one of the first things i always do is make a custom kernel, so i don't remember if arch has that in by default. but it's not a big deal, just select what you need in the power management section.

Offline

Board footer

Powered by FluxBB