You are not logged in.

#1 2010-06-18 06:39:46

com.tihon
Member
Registered: 2009-12-04
Posts: 7

Monodevelop File name has not been set.

Hi all! Have monodevelop 2.2.2-1, openbox 3.4.11.2-1 and some problems with starting debuging in monodevelop in external console.
When I select the run in external console feature i got this error:
Cannot execute "/home/tihon/Projects/helloworld/helloworld/bin/Debug/helloworld.exe". File name has not been set.
System.InvalidOperationException: File name has not been set
  at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
  at System.Diagnostics.Process.Start () [0x00000] in <filename unknown>:0
  at MonoDevelop.Core.Execution.ProcessWrapper.Start () [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) MonoDevelop.Core.Execution.ProcessWrapper:Start ()
  at MonoDevelop.Core.Execution.ProcessService.StartConsoleProcess (System.String command, System.String arguments, System.String workingDirectory, IDictionary`2 environmentVariables, IConsole console, System.EventHandler exited) [0x00000] in <filename unknown>:0
  at MonoDevelop.Core.Execution.NativePlatformExecutionHandler.Execute (MonoDevelop.Core.Execution.ExecutionCommand command, IConsole console) [0x00000] in <filename unknown>:0
  at MonoDevelop.Core.Execution.MonoPlatformExecutionHandler.Execute (MonoDevelop.Core.Execution.ExecutionCommand command, IConsole console) [0x00000] in <filename unknown>:0
  at MonoDevelop.Core.Execution.DotNetExecutionHandler.Execute (MonoDevelop.Core.Execution.ExecutionCommand command, IConsole console) [0x00000] in <filename unknown>:0
  at MonoDevelop.Core.Execution.DefaultExecutionHandler.Execute (MonoDevelop.Core.Execution.ExecutionCommand command, IConsole console) [0x00000] in <filename unknown>:0
  at MonoDevelop.Projects.DotNetProject.DoExecute (IProgressMonitor monitor, MonoDevelop.Projects.ExecutionContext context, MonoDevelop.Projects.ConfigurationSelector configuration) [0x00000] in <filename unknown>:0
Need help. reinstalling java and monodevelop didn't help.
s_1276843370_a077c939f3.png

Last edited by com.tihon (2010-06-18 06:50:54)

Offline

#2 2013-03-13 21:37:32

marcs
Member
From: Italy
Registered: 2007-09-07
Posts: 50
Website

Re: Monodevelop File name has not been set.

Got the same problem. First time using MonoDevelop!

Offline

Board footer

Powered by FluxBB