You are not logged in.

#1 2005-04-01 22:37:12

rabadash
Member
From: Seattle
Registered: 2005-04-01
Posts: 41

[solved]Autofs not working

So I followed the archwiki guide on autofs, but when I put a cd in my drive nothing comes up in the media directory, just like it says it would in the bottom of th wikir.  Now what I don't undertand, is how am I supposed to access the cdrom if I can't see it?  I wan't to play a cd using xmms, which xmms can't see my cdrom drive either.    I'm using xfce4 and a toshiba M1712 DVD-rom drive.

Offline

#2 2005-04-01 22:51:16

smith
Member
From: Crescent City, CA
Registered: 2005-02-19
Posts: 77

Re: [solved]Autofs not working

Why would you need to mount an audio cd?  You should be able to play it directly.


I have nothing to say, and I am saying it.

Offline

#3 2005-04-01 22:53:55

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: [solved]Autofs not working

Autofs doesn't work with music CD because they can't be mounted.  To play CD with XMMS, you'll need *I think* a plugin:
pacman -S xmms-cdparanoia
I can't give more details right now (not in Arch).

Offline

#4 2005-04-01 23:00:21

rabadash
Member
From: Seattle
Registered: 2005-04-01
Posts: 41

Re: [solved]Autofs not working

Stay with me, I'm switching over from ubuntu.  When I open xmms I go to play directory and it lists /dev/cdroms but no cdrom0.  If I go to into the filemanager, it lists /dev/cdroms/cdrom0 but I can't open cdrom0.  How do I access an audiocd?

Offline

#5 2005-04-01 23:18:55

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: [solved]Autofs not working

you need to add your user to the "audio" and "optical" groups - audio for the output, and optical for the cdrom

also, xmms doesn't need a plugin to play audio cds - if you don't have that little cable connecting the cdrom drive to the sound card, you need to make sure you select "digital output" or something like that in the xmms options for audio cds

Offline

#6 2005-04-02 00:33:02

rabadash
Member
From: Seattle
Registered: 2005-04-01
Posts: 41

Re: [solved]Autofs not working

I already added my user to audio and optical but here's something new.  When I go into xmms->preferences->audio I/O plugins->configure cd audio player->check drive I get an error message saying

Failed to open device /dev/cdrom/
Error: No such file or directory

Failed to open /mnt/cdrom
Error: No such file or directory

Offline

#7 2005-04-02 00:40:55

rabadash
Member
From: Seattle
Registered: 2005-04-01
Posts: 41

Re: [solved]Autofs not working

I changed those settings to say /dev/cdroms/cdrom0 instead of /dev/cdrom and I get this message when I hit check drive.

Device /Dev/cdroms/cdrom0 OK
Disc has 12 tracks
Total length 43:29
Digital audio extraction test: OK

Failed to check directory /mnt/cdrom
Error: No such file or directory

Offline

#8 2005-04-02 00:44:06

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: [solved]Autofs not working

Error: No such file or directory

have you created the folder cdrom in the /mnt/ directory?

Offline

#9 2005-04-02 00:54:17

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 460

Re: [solved]Autofs not working

less /etc/fstab

then

ls /mnt

Compare.

and as Mssr Pingu suggested, maybe create the directories needed, as highlighted by fstab

Offline

#10 2005-04-02 01:10:43

rabadash
Member
From: Seattle
Registered: 2005-04-01
Posts: 41

Re: [solved]Autofs not working

Ok I think I got it figured out with new directories.

Offline

Board footer

Powered by FluxBB