You are not logged in.

#1 2007-09-23 20:43:27

mikezackles
Member
Registered: 2007-09-23
Posts: 40

Can't get jackplug (alsa <-> jack converter) to work for mono

I'm trying to set up Skype to interface with JACK.  I'm using alsa-lib 1.0.14-5 and jack-audio-connection-kit 0.103.0-1 on an echo indigo io card.  My .asoundrc is exactly as suggested by the alsa wiki:

pcm.jackplug {
  type plug
  slave { pcm "jack" }
}

pcm.jack {
  type jack
  playback_ports {
    0 alsa_pcm:playback_1
    1 alsa_pcm:playback_2
  }
  capture_ports {
    0 alsa_pcm:capture_1
    1 alsa_pcm:capture_2
  }
}

With jackd running via qjackctl, aplay -D jackplug sound.wav works just fine if sound.wav is stereo.  However, when sound.wav is mono, aplay tells me it is playing the file, but I get no sound.  Likewise, the sound effects in Skype work with jackplug, and calls will connect without error, but the voice input and output give no sound.  I am thinking that this is because the sound effects are stereo and the voice is mono.  Running Skype from a terminal, I get quite a few of the following:
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL jack

I've been trying to better understand the .asoundrc syntax, but the alsa wiki seems more geared toward cut and paste, and I didn't have much luck sifting through the alsa-lib documentation.  I read Shinlun's solution to the similar problem at http://bbs.archlinux.org/viewtopic.php?pid=260657, but my aplay isn't giving me errors.  Has this been fixed?

I'm also somewhat unsure about whether this solution will allow me to route audio between native jack applications and Skype.  Is this just connecting the audio in and out of any app using jackplug directly to the audio in and out of my soundcard?  Any help/clarification would be much appreciated.  Thanks!

Offline

#2 2007-09-24 18:55:32

mikezackles
Member
Registered: 2007-09-23
Posts: 40

Re: Can't get jackplug (alsa <-> jack converter) to work for mono

I got it working!
All I had to do was bypass the jackplug plugin and call the jack plugin directly from Skype.  Now I am able to route everything to my heart's desire via patchage.:D

For anyone interested, here's what (I think) is going on:
The jackplug plugin (which calls the jack plugin) is of type plug.  I think the purpose of the plug plugin is to 'automagically' convert sample rate, mono/stereo, etc., but evidently it doesn't always work in my scenario.  Luckily, I think Skype's sample rate already matches that of my JACK server (48000Hz), so there is no conversion necessary.  So, if you're experiencing a similar problem, try setting jackd to run at 48000Hz and call the jack plugin directly from Skype.  If you need another sample rate, you might have to try converting explicitly via another alsa plugin, but that's beyond my current expertise...  Hope this is helpful!

Last edited by mikezackles (2007-09-24 18:57:20)

Offline

#3 2010-07-10 16:39:39

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 459

Re: Can't get jackplug (alsa <-> jack converter) to work for mono

man, are you still active here?

I need to make Skype in- and output in jack

alsa-jack plugin is working fie with outer programs, only with skype I get an error-message.

I selected "jack" as the output in skype-preferences - when I start to make a call I get: "there is a problem with the reprodution"

I tried diferent samplerates and even forced jck to 16bit but it doesn't solve (never did a difference in Ubuntu, where this worked great)

a problem could be that I am on 64bit a skype is 32-bit but I have jack-32bit-lib installed.

if anybody could help me out......

Offline

#4 2010-07-14 12:07:19

mikezackles
Member
Registered: 2007-09-23
Posts: 40

Re: Can't get jackplug (alsa <-> jack converter) to work for mono

I'm still here, but I haven't messed with this in several years so I don't think I can be of much help.  Sorry!

Offline

#5 2010-07-14 18:21:41

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 459

Re: Can't get jackplug (alsa <-> jack converter) to work for mono

mikezackles wrote:

I'm still here, but I haven't messed with this in several years so I don't think I can be of much help.  Sorry!

ok, thanks for the reply anyways

Offline

#6 2012-11-15 22:42:55

lemondreas
Member
Registered: 2011-05-11
Posts: 27

Re: Can't get jackplug (alsa <-> jack converter) to work for mono

Is anyone still interested in solutions?
Got skype to work, yeah!
I'm quite happy, a whole day fighting with jack, finally everything (and i mean EVERYTHING) makes noiz.

2ahddxdvgabt.png

$ cat /etc/asound.conf 

# convert alsa API over jack API

# use this as default
pcm.!default {
    type plug
    slave { pcm "jack" }
}

ctl.mixer0 {
    type hw
    card 1   #### I'm not sure if you have to change the number if you have different cards / more/less cards
}

# pcm type jack
pcm.jack {
    type jack
    playback_ports {
        0 system:playback_1
        1 system:playback_2
    }
    capture_ports {
        0 system:capture_1
        1 system:capture_2
    }
}

Packages installed:

$ pacman -Qs jack
local/jack2-multilib 1.9.8-4
    The next-generation JACK with SMP support & mixed mode
local/libflashsupport-jack 20121116-1
    JACK-audio-connection-kit support for Flash
local/qjackctl 0.3.9-2
    A Qt front-end for the JACK low-latency audio server

$ pacman -Qs alsa
local/alsa-lib 1.0.26-1
    An alternative implementation of Linux sound support
local/alsa-plugins 1.0.26-1
    Extra alsa plugins
local/alsa-utils 1.0.26-1
    An alternative implementation of Linux sound support
local/lib32-alsa-lib 1.0.26-1
    An alternative implementation of Linux sound support (32 bit)
local/lib32-alsa-plugins 1.0.26-1
    Extra alsa plugins (32-bit)

Last edited by lemondreas (2012-11-16 14:26:33)

Offline

Board footer

Powered by FluxBB