You are not logged in.

#1 2010-07-28 22:01:02

kulpae
Member
From: Bremen
Registered: 2010-02-06
Posts: 34

GRUB Error 17 & "/boot/grub/stage1 not read correctly" Phenomenon

Hello guys, I just encountered a very interesting grub phenomenon.
I've already fixed it accidentally, but I wanted to share it with you, so if anyone has the same problem, she/he can be helped here.

I had two linux installations on my thinkpad R60 laptop drive: kubuntu and archlinux. Archlinux was put atop an old win7 beta installation.
So everything worked fine, as I used grub2 from my kubuntu installation.

But two days ago I decided to install win7 atop my kubuntu installation, as I wasn't using it anymore and I needed windows for starcraft 2 for the best experience.
Windows put its own boot manager into MBR, as expected.
Today I decided to reinstall grub1 from my arch installation and failed. Why? GRUB refused the setup. I've already managed how to chroot into arch from the archlinux installation cd and I still got errors like /boot/grub/stage1 or Error 17 in the /tmp/grub-install.log.xxxx log files...

So I checked fdisk -l and there was nothing suspicious.
But I had a feeling that the problem lies inside the partition table...

So I played around with fdisk...
Here is "fdisk -l" I saw at first:

Device        Boot        Start        End        Blocks    Id   System
/dev/sda1        *        2046         206847     102400    7    HPFS/NTFS              <- some ibm rescue media
/dev/sda2                 206848       82118655   40955904  7    HPFS/NTFS              <- archlinux
/dev/sda3                 82131840     234435599  76151880  5    Extended               <- thanks to gparted
/dev/sda5                 82131903     86017679   1942888+  82   Linux Swap / Solaris   <- swap for kubuntu/archlinux, now only for arch
/dev/sda6                 86018048     234434559  74208256  7    HPFS/NTFS              <- win7 with starcraft 2 ;)

So the weirdest thing was, that my archlinux was on /dev/sda2!
I saw, that it was somehow marked as an ntfs partition (it was win7 beta initially) so I changed it with "fdisk t" to Linux (83) and I could install grub.
Now everything is working fine.

Maybe we can add this hint to the GRUB's wikipage?
So people won't waste to much time fixing it, as it's a very easy fix...

Cheers, kulpae

Last edited by kulpae (2010-08-01 19:06:55)

Offline

#2 2010-07-28 22:30:16

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: GRUB Error 17 & "/boot/grub/stage1 not read correctly" Phenomenon

http://wiki.archlinux.org/index.php/Grub#GRUB_Error_17
Feel free to add anything you think is missing.

Offline

Board footer

Powered by FluxBB