You are not logged in.

#1 2005-04-07 00:40:11

Registered: 2005-04-07
Posts: 14

artsd giving me 'CPU overload' problem.

Hello everybody,

I've just installed Arch Linux, along with X, KDE, and the like. Now, when I boot into KDE, I get this error message saying "Sound server fatal error: cpu overload, aborting".

The error message appears in an artsmessage window.

My computer becomes very slow before I get this error as artsd uses 99% of cpu before it crashes. I found this out using the `top` command.

I have alsa and all of it's modules compiled. The alsa module is also inserted into DAEMONS array.

So.. what does one do in this situation? Thanks.


#2 2005-04-07 03:48:35

From: MN, USA
Registered: 2004-02-19
Posts: 1,142

Re: artsd giving me 'CPU overload' problem.

Have you done a 'alsaconfig' to make sure your card is set up right?

·¬»· i am shadowhand, powered by webfaction


#3 2005-04-07 04:39:50

Registered: 2005-04-07
Posts: 14

Re: artsd giving me 'CPU overload' problem.

I just tried that. The utility tells me everything is good.

So I decide to try something new. I log in as root and start KDE. Artsd doesn't crash anymore, and it only eats up half of my CPU.

top - 00:34:26 up 14 min,  1 user,  load average: 2.94, 2.56, 1.38
Tasks:  80 total,   3 running,  77 sleeping,   0 stopped,   0 zombie
Cpu(s): 74.7% us, 25.3% sy,  0.0% ni,  0.0% id,  0.0% wa,  0.0% hi,  0.0% si
Mem:    739740k total,   350724k used,   389016k free,    54072k buffers
Swap:   987956k total,        0k used,   987956k free,   192836k cached

10466 root      25   0  1796  984  780 R 43.3  0.1   1:48.52 top
 9400 jeezus84  25   0 10460 6040 4052 R 41.6  0.8   5:22.37 artsd
12407 root      15  -1  151m  19m 2580 S  2.0  2.8   0:04.58 X
12659 root      15   0 30176  15m  11m S  2.0  2.1   0:00.57 konsole
    1 root      16   0  1388  504  444 S  0.0  0.1   0:00.85 init
    2 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/0
    3 root      34  19     0    0    0 S  0.0

I get a new window that pops up now, as soon as I log into KDE as root.

It's another artsmessage window, but this one says:
" Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Device or resource busy)
The sound server will continue, using the null output device."

So, i'm stumped. I was going to get rid of the arch installation of alsa, and reinstall from the files i find at the alsa website, but I can't remove alsa using Pacman because other programs need it.

Any advice is greatly appreciated. Aside from this minor wrinkle, i'm thoroughly impressed with Arch Linux. Having used Gentoo before this, it's embodies everything I liked about Gentoo without any of the bloody compiling. Good show.


#4 2005-04-07 07:54:34

From: Crescent City, CA
Registered: 2005-02-19
Posts: 77

Re: artsd giving me 'CPU overload' problem.

Arts uses realtime priority as root, hence the better performance.  There should be an option so you can run arts in realtime as user (setuid=root?).  If you don't mind building your own kernel, try compiling the sound drivers as modules.  If arts is still giving you trouble, disable it and use an alternative sound server.

I have nothing to say, and I am saying it.


Board footer

Powered by FluxBB