You are not logged in.

#1 2005-04-07 13:09:50

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 222

xmms problem after flac upgrading

*** glibc detected *** double free or corruption (out): 0xb6d4c5a4 ***
zsh: abort      xmms

Again...


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#2 2005-04-07 13:20:34

puntmuts
Member
Registered: 2005-02-22
Posts: 138

Re: xmms problem after flac upgrading

Same here  :cry:


Out / Gone
Mirgrating all my machines off ArchLinux . No longer part of the ArchLinux community / users .
Done. Goodbye.

Offline

#3 2005-04-07 13:46:50

JimboP
Member
From: UK
Registered: 2005-01-14
Posts: 22

Re: xmms problem after flac upgrading

This flac update also seems to have killed the sound in KDE - going back to flac 1.1.1-2 and the sound works fine

Offline

#4 2005-04-07 14:10:52

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: xmms problem after flac upgrading

This happened before. Then the flac-1.1.2 package was removed and 1.1.1 was put back into repos.

http://bugs.archlinux.org/index.php?do=details&id=2266

I don't know why it was upgraded again if it still doesn't work with xmms.

Offline

#5 2005-04-07 14:16:30

puntmuts
Member
Registered: 2005-02-22
Posts: 138

Re: xmms problem after flac upgrading

And it conflicts with mpd as well.


Out / Gone
Mirgrating all my machines off ArchLinux . No longer part of the ArchLinux community / users .
Done. Goodbye.

Offline

#6 2005-04-07 16:32:59

LavaPunk
Member
Registered: 2004-03-05
Posts: 129

Re: xmms problem after flac upgrading

Is there anybody either hosting flac-1.1.1 or able to email it to me.  I, embarrassingly, just cleared my cache before upgrading flac as my old flac-1.1.2 package was corrupt!  Sucks to be me eh?

I also requested to reopen the above bug report, I suspect we will see action before the end of the day, so if no one can help me out I imagine I will wait it out like everybody else smile

*EDIT* Fixed it by downgrading, you can get the package from this mirror however you please.  http://ftp.nluug.nl/ftp/pub/os/Linux/di … pkg.tar.gz

Offline

#7 2005-04-07 17:51:41

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: xmms problem after flac upgrading

BTW, there is always the CVS repo http://www.archlinux.org/cvs.php
where you can get PKGBUILD for  old versions of packages.

Offline

#8 2005-04-07 18:14:36

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: xmms problem after flac upgrading

I don't use XMMS or KDE, but I do use MPD. I recompiled MPD and changed the FLAC version to 1.1.2 and everything works fine for me.


·¬»· i am shadowhand, powered by webfaction

Offline

#9 2005-04-07 20:54:03

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: xmms problem after flac upgrading

Does this crap affect GStreamer, or is it, at worst, something a gst-register can fix?

Offline

#10 2005-04-07 22:50:55

WiLLiE
Member
From: Sweden
Registered: 2005-02-27
Posts: 133

Re: xmms problem after flac upgrading

This flac upgrade buggered three apps here: xmms, mpd and amarok:

[[[willie@ArchLinux:~]]] amarok
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: error while loading shared libraries: libFLAC.so.6: cannot open shared object file: No such file or directory

Offline

#11 2005-04-07 23:24:35

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: xmms problem after flac upgrading

you can have pacman ignore any flac updates in the future by adding

IgnorePkg = flac

to /etc/pacman.conf

Looking at flac's website, it sounds like this version isn't really necessary to have:
http://flac.sourceforge.net/

Offline

#12 2005-04-08 04:20:52

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: xmms problem after flac upgrading

Has anyone submitted a bug report about this? I added one specifically for mpd already, but this seems to be a bigger issue.


·¬»· i am shadowhand, powered by webfaction

Offline

#13 2005-04-08 06:14:15

Greycloack
Member
Registered: 2004-03-05
Posts: 166

Re: xmms problem after flac upgrading

On the other hand it seems the new flac is required for the new graveman pkg....

Offline

#14 2005-04-08 07:17:11

LavaPunk
Member
Registered: 2004-03-05
Posts: 129

Re: xmms problem after flac upgrading

Yes I have a bugreport listed for flac itself.

http://bugs.archlinux.org/index.php?do=details&id=2266

Offline

#15 2005-04-08 09:48:12

tmadhavan
Member
From: Wales :D
Registered: 2004-03-26
Posts: 441

Re: xmms problem after flac upgrading

As far as the Amarok problem is concerned:

# cd /usr/lib
# ln -s libFLAC.so.7 libFLAC.so.6
# exit

Offline

#16 2005-04-08 09:54:10

puntmuts
Member
Registered: 2005-02-22
Posts: 138

Re: xmms problem after flac upgrading

Well, I think when flac is upgraded it will be necessary to release upgraded/updated versions of software which is dependent on it as well. Maybe the package maintainer should wait for these updates/upgrades before releasing this to the current/extra repository.


Out / Gone
Mirgrating all my machines off ArchLinux . No longer part of the ArchLinux community / users .
Done. Goodbye.

Offline

#17 2005-04-08 10:55:12

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: xmms problem after flac upgrading

Yep. screws up Rhythmbox too. Bleh.

Offline

#18 2005-04-08 11:43:13

qsdickee
Member
From: China
Registered: 2004-04-25
Posts: 12

Re: xmms problem after flac upgrading

artsplay will not play .ogg files. sad

Offline

#19 2005-04-08 12:18:39

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: xmms problem after flac upgrading

tmadhavan wrote:

As far as the Amarok problem is concerned:

# cd /usr/lib
# ln -s libFLAC.so.7 libFLAC.so.6
# exit

Yes, already submitted a bugreport:
http://bugs.archlinux.org/index.php?do=details&id=2517

Offline

#20 2005-04-08 14:05:05

morgoth
Member
Registered: 2005-04-07
Posts: 21

Re: xmms problem after flac upgrading

ok. I'm a bit new to arch. So how can I roll back to flac-1.1.1?
I have the old tar.gz

Offline

#21 2005-04-08 14:11:49

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: xmms problem after flac upgrading

pacman -U /var/cache/pacman/pkg/flac-1.1.1-2.pkg.tar.gz

Offline

#22 2005-04-08 15:15:03

morgoth
Member
Registered: 2005-04-07
Posts: 21

Re: xmms problem after flac upgrading

thanks smile

Offline

#23 2005-04-08 15:35:29

puntmuts
Member
Registered: 2005-02-22
Posts: 138

Re: xmms problem after flac upgrading

easytag is affected as well.


Out / Gone
Mirgrating all my machines off ArchLinux . No longer part of the ArchLinux community / users .
Done. Goodbye.

Offline

#24 2005-04-08 19:33:18

Abaddon
Member
From: Poland
Registered: 2004-05-03
Posts: 222

Re: xmms problem after flac upgrading

Rebulding xmms doesn't help.


Gnome - The weakest link!
Linux, *not* GNU/Linux!

Offline

#25 2005-04-08 19:35:48

LavaPunk
Member
Registered: 2004-03-05
Posts: 129

Re: xmms problem after flac upgrading

Rebuilding flac with the patch attached to this bug report should do the trick.

*EDIT*  This has now been included in the 1.1.2-2 build of flac.

Offline

Board footer

Powered by FluxBB