You are not logged in.

#1 2003-10-12 07:49:41

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Problems on GNOME 2.4 update.

Like always, i dont do a pacman -Syu at once, because i dont use all the pkgs being actualized and i have dial up, so its not free to download unusefull pkgs.

I went with pacman -S gnome and got this:



orbit2-2.8.1-1.pkg.tar.g [####################################] 100% |    500K
vte-0.11.10-1.pkg.tar.gz [####################################] 100% |    964K
yelp-2.4.0-1.pkg.tar.gz  [####################################] 100% |    411K

loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  /opt/gnome/bin/gnome-font-viewer: exists in filesystem
  /opt/gnome/bin/gnome-thumbnail-font: exists in filesystem
  /opt/gnome/etc/gconf/schemas/fontilus.schemas: exists in filesystem
  /opt/gnome/etc/gnome-vfs-2.0/modules/font-method.conf: exists in filesystem
  /opt/gnome/lib/bonobo/servers/fontilus.server: exists in filesystem
  /opt/gnome/lib/gnome-vfs-2.0/modules/libfont-method.la: exists in filesystem
  /opt/gnome/lib/gnome-vfs-2.0/modules/libfont-method.so: exists in filesystem
  /opt/gnome/libexec/fontilus-context-menu: exists in filesystem
  /opt/gnome/share/application-registry/fontilus.applications: exists in filesys
tem
  /opt/gnome/share/gnome/vfolders/font-method.directory: exists in filesystem
  /opt/gnome/share/mime-info/fontilus.keys: exists in filesystem
  /opt/gnome/share/mime-info/fontilus.mime: exists in filesystem
  /opt/gnome/share/pixmaps/gnome-ccthemes.png: exists in filesystem
  /opt/gnome/etc/gconf/schemas/mailcheck.schemas: exists in filesystem
  /opt/gnome/etc/sound/events/mailcheck.soundlist: exists in filesystem
  /opt/gnome/share/gnome-2.0/ui/GNOME_MailCheckApplet.xml: exists in filesystem
...
...
it continues though all files

i guess i have to go with pacman -Sf gnome ??


thanks


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#2 2003-10-12 07:53:00

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Problems on GNOME 2.4 update.

you must force the upgrade (pacman -Syuf should do it)


AKA uknowme

I am not your friend

Offline

#3 2003-10-12 08:57:01

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: Problems on GNOME 2.4 update.

Ok, i forced gnome, it got installed, will try it later


I usually do a pacman -Syu just to see what pkgs are updated and what i will download. so i answer no at the end.
but from time to time i get things like this:


[root@archcrow crow]# pacman -Syu
:: Synchronizing package databases...
current.db.tar.gz        [####################################] 100% |     34K
unofficial.db.tar.gz     [####################################] 100% |     68K
unstable.db.tar.gz       [####################################] 100% |      0K
:: replace libgail-gnome with gail from "current"? [Y/n] n
:: replace at-spi with gail from "current"? [Y/n] n
:: replace gtk-thinice-engine with gnome-themes from "current"? [Y/n] n
:: replace bonobo-activation with libbonobo from "current"? [Y/n] n
:: replace fontilus with nautilus from "current"? [Y/n] n

Targets: aspell-0.50.3-2 automake-1.7.7-1 blackbox-0.65.0-3 curl-7.10.7-1
         dhcp-3.0pl2-2 dhcpcd-1.3.22pl4-2 exim-4.24-1 fetchmail-6.2.4-1
         flashplugin-6.0r79-6 gaim-0.71-1 gentoo-0.11.35-1 gimp-1.2.5-3
         gkrellm-2.1.20-1 icewm-1.2.13-1 initscripts-0.5-8 kdelibs-3.1.4-1
         kdebase-3.1.4-1 kdeaddons-3.1.4-1 kdeadmin-3.1.4-1 kdeartwork-3.1.4-1
         kdebindings-3.1.4-1 kdeedu-3.1.4-1 kdegames-3.1.4-1 kdegraphics-3.1.4-1
         kdemultimedia-3.1.4-1 kdenetwork-3.1.4-1 kdepim-3.1.4-1 kdesdk-3.1.4-1
         kdetoys-3.1.4-1 kdeutils-3.1.4-1 koffice-1.2.1-1 lftp-2.6.8-1
         lilo-22.5.8-1 pccts-1.33mr-3 portmap-5beta-9 postgresql-7.3.4-1
         qt-3.2.1-1 raidtools-1.00.3-2 ripperx-2.6.0-1 samba-3.0.0-2
         screen-4.0.1-1 sdl-1.2.6-1 tetex-2.0.2-3 x2x-1.27-3 xscreensaver-4.13-2

Proceed with upgrade? [Y/n] n


how do i make those replacements without doing a full system update??


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#4 2003-10-12 13:08:16

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Problems on GNOME 2.4 update.

pacman -Sf gnome


AKA uknowme

I am not your friend

Offline

#5 2003-10-13 05:41:56

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: Problems on GNOME 2.4 update.

Hi, i dont know if you read my post, but i already did that.
(when i say, i forced gnome, i meant i did just that)

Then when i do a pacman -Syu to see whats new, those questions keep poping up, so something is not updated or is a bug in pacman.


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#6 2003-10-13 05:47:46

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Problems on GNOME 2.4 update.

pacman -S gail gnome-themes libbonobo nautilus


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

Board footer

Powered by FluxBB