You are not logged in.

#1 2010-08-19 20:46:30

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

[SOLVED]LXDE with Compiz

I just did a fresh install of Arch and I installed LXDE. I want to use compiz instead of openbox, but I can't get it to start. I tried  "compiz --replace" which only took away my window borders. I have window decorations checked in ccsm and the command is set to emerald --replace. I also tried "emerald --replace", but that didn't do anything. I changed openbox-lxde in preferences->desktop session settings to compiz --replace, but that had no effect.So, could someone please tell me how to autostart compiz? I don't want to use the fusion icon because it will bring up the desktop first in openbox and then switch compiz. I want it to start in compiz right away. Thanks.

Last edited by Tux the penguin (2010-09-01 21:03:12)


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#2 2010-08-19 20:50:47

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: [SOLVED]LXDE with Compiz

Install ccsm and then enable "Window borders" , "resize window" and "move window" plugins. Then reenable compiz.

Offline

#3 2010-08-19 21:30:22

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]LXDE with Compiz

I already have ccsm and I have window decorations, resize window, and move window plugins enabled. I just need help enabling compiz. I can start it with the fusion icon, but I want to do it without the fusion icon.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#4 2010-08-20 20:08:14

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]LXDE with Compiz

I figured out that I can start compiz with the "compiz --replace ccp" command, but I still can't set it as the window manager. Openbox is still loaded even if I put "compiz --replace ccp" as the window manager under advanced options in preferences->Desktop Session Settings.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#5 2010-08-20 20:34:04

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 801

Re: [SOLVED]LXDE with Compiz

in  /etc/xdg/lxsession/LXDE/desktop.conf  I have

window_manager=compiz --sm-disable --ignore-desktop-hints ccp

Offline

#6 2010-08-20 21:38:32

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]LXDE with Compiz

Still uses openbox.

Last edited by Tux the penguin (2010-08-20 23:18:43)


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#7 2010-08-20 23:07:01

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]LXDE with Compiz

It finally works. I guess it just took two logout/logins. Thanks vacant

Last edited by Tux the penguin (2010-08-21 02:00:10)


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

Board footer

Powered by FluxBB