You are not logged in.

#176 2005-01-19 22:05:06

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

I've uploaded a .tar .gz with all the files needed to build arch packages of the new ati drivers in ftp.archlinux.org/incoming  , maybe someone could find it usefull

bye

Offline

#177 2005-01-21 19:19:17

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

The simplyest way to install ati drivers is to add the following lines at the end of your /etc/pacman.conf:

[link]
Server = ftp://ftp.archlinux.org/tur/link


Then just perform:

pacman -Syu
pacman -S ati-drivers

Offline

#178 2005-01-21 23:01:05

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

@qwerty: thx, your package works fine! i thought i would never get hardware with an ati-card! wink now i'm happy...

but i had to change something in my xorg

"XKbRules" "xfree86" to "xorg"
keyboard-driver "Keyboard" to "kbd"


sorry for my bad english smile

Offline

#179 2005-01-22 15:32:56

thegnu
Member
From: Brooklyn, NY
Registered: 2004-05-04
Posts: 280
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

This is just a friendly reminder to never buy ATI again.


fffft!

Offline

#180 2005-01-22 17:12:36

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 671

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

thanks thegnu - really helpful contribution to the discussion...

Offline

#181 2005-01-22 17:38:00

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

thegnu wrote:

This is just a friendly reminder to never buy ATI again.

IMHO, if ATI could get their driver development upto par with nVidia they would have, by far the better product. Hardware wise, ATI has always been pretty good. Just can' t write drivers to save their ass.

nVidia has always done pretty well in both areas and I always listed nVidia first on my list of choices for graphics cards but then the FX 5--- series came out and ruined that. I have a Raddy 8500 128MB around here that will give a GeForce FX a run for it's money (in Windows) on Doom 3.   lol

Offline

#182 2005-01-24 12:41:53

jrbeire
Member
From: Dublin, Ireland
Registered: 2004-09-29
Posts: 15
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Any reason why the new drivers would complain about kernel26-scsi package and attempt to remove it prior to installation?

Had a quick gander at the PKGBUILD and can't see a mention of kernel26 anywhere.

John

Offline

#183 2005-01-24 14:25:16

jrbeire
Member
From: Dublin, Ireland
Registered: 2004-09-29
Posts: 15
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Ok - solved the kernel26-scsi issue by downloading qwerty's .tar.gz from incoming and manually editing the PKGBUILD for ati-drivers-module-kernel26.

makepkg then works for both ati-drivers-module-kernel26 and ati drivers. Installation of ati-drivers-module-kernel26 goes fine but I get the following error when attempting the ati-drivers install:

checking for file conflicts...
error: the following file conflicts were found:
  ati-drivers: /usr/X11R6/lib/libGL.so.1.2: exists in filesystem


Any suggestions, John.

Offline

#184 2005-01-24 18:27:58

phunni
Member
From: Bristol, UK
Registered: 2003-08-13
Posts: 671

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

I just added the f option to the pacman install and it seemed to work.  Nothing appears broken (although this was only last night so give it time  wink ) and I have good 3D

Offline

#185 2005-01-25 23:11:07

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

suddenly the driver do not work. installed it a few days ago, all ok, but now this message:

$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0"
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.1)

onliest thing i changed were the fontpaths in xorg.conf.

any ideas?

sry for my english...


sorry for my bad english smile

Offline

#186 2005-01-25 23:29:41

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 357
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0"
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.1)

Assuming the module is loading fine, I believe pacman -Rd mesa should work. I always had problems with ATI drivers when an app would sneak mesa libs in. Might have to reinstall ATI drivers after removing it.


--
JSkier

Offline

#187 2005-02-01 03:53:28

DarkPath
Member
Registered: 2004-11-15
Posts: 50

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Alright, I'm getting the same problem that a few people have experienced here on the forums, but I can't seem to fix it on my comp. I'm referring to the module loading fine at boot, X.org loading the driver and apparently all is well, and looking at the Xorg.0.log it even says Direct Rendering is enabled. Now, I've been at this a while...I've compiled the drivers both with the PKGBUILD off of link's TUR with the patch posted in these forums and I've tried with the patch off the Rage3D boards. I've tried compiling with default settings and after clearning the compile flags in makepkg.conf. I've tried the default arch kernel as well as compiling my own kernel so there's no native DRI and to make agpgart a module. At first glance, almost ever since I tried installing the drivers, it seems everything loads fine but Direct Rendering just refuses to work in X. Well, now I think I finally know why, but I'm not sure what to do about it.

Taking the advice off a user on the Rage3D boards, I tried running the command

export LIBGL_DEBUG=verbose

and, after running 'glxinfo | grep direct' again, I get this:

libGL: XF86DRIGetClientDriverName: 8.8.25 fglrx (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/fglrx_dri.so
drmOpenByBusid: Searching for BusID PCI:1:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports PCI:1:0:0
fglrx: libGL version undetermined - OpenGL module is using glapi fallback
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

So, apparently something's wrong with the libGL that I'm using... or at least fglrx thinks there is. Is there anything I can do to fix this? ANY help would be appreciated.

Offline

#188 2005-02-01 21:25:14

DarkPath
Member
Registered: 2004-11-15
Posts: 50

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

tfpsly wrote:

Try to find all the libGL.* around your system, and move all but the fglrx's ones into a tmp folder. Then same player try again...

Well, I did that, but then got an error with startkde that it couldn't find libGL.so.1 because I had moved it... to solve this, I tried copying libGL.so.1.2 (the file from the ATI drivers) to libGL.so.1 and, lo and behold, IT WORKED! big_smile Finally I have direct rendering! fgl_glxgears ran fine at about 260FPS... I'm on a Mobility 9600 64MB, so I don't expect amazing performance, but I'm just happy that it's working. Now that I know what to do, I'm going to be looking into some better kernels... at the least, the -ck patchset and perhaps the -nitro patchset. wink

Offline

#189 2005-02-02 21:15:56

DarkPath
Member
Registered: 2004-11-15
Posts: 50

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

tfpsly wrote:
DarkPath wrote:

Well, I did that, but then got an error with startkde that it couldn't find libGL.so.1 because I had moved it... to solve this, I tried copying libGL.so.1.2 (the file from the ATI drivers) to libGL.so.1

Happy to have helped, but... Don't do a copy, make a link : ln -s libGL.so.1.2 libGL.so.1 so that when you'll update your system, libGL.so.1 will be up to date too.

Heh, already did that, actually... I was getting errors from... ldconfig, I think, while I was installing some things with pacman, so I deleted the copied file, changed it to a symlink, and all's well and good! big_smile Thank again. smile

Offline

#190 2005-02-18 18:43:33

Bralkein
Member
Registered: 2004-10-26
Posts: 354

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

This seems to be the thread for asking for help with ATI cards, so here I go!

I have managed to install the latest drivers from ATI's website using a similar method to the one described in this HOWTO. It all seems to work properly, with the module showing up in lsmod, xorg starting up properly, and the following commands give these results:

glxgears - I see the gears and:
29979 frames in 5.0 seconds = 5995.800 FPS
28979 frames in 5.0 seconds = 5795.800 FPS
30039 frames in 5.0 seconds = 6007.800 FPS
30157 frames in 5.0 seconds = 6031.400 FPS

fglrxinfo - I see:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9500 Pro Generic
OpenGL version string: 1.3.4893 (X4.3.0-8.10.19)

Also, I can run all of the KDE screensavers with a reasonable speed. However, if I try and play any OpenGL games (foobillard, glTron, Tuxracer), they all run at <1 FPS. Does anyone know why this happens? Are the drivers really so shit? Thanks in advance!

Offline

#191 2005-02-18 19:40:07

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

NEW ATI DRIVERS OUT!

http://ati.com/support/drivers/linux/radeon-linux.html

New Features:

The ATI Proprietary Linux software driver version introduces support for the ATI FireGL™ V5000.

Issues Resolved:


Starting X on a DVI display no longer results in noisy or flickering output with some displays
The Monitor autodetect no longer finds a phantom CRT display if none is connected either RADEON™ X800, X700, X300, or FireGL™ V5100, and V5000
The ATI Proprietary Linux driver now works with Apple Cinema display flat panels in single link mode
fglrxconfig now produces a proper xorg.conf X Server configuration file
Running certain 3D applications no longer result in system hangs on x86_64 systems with RADEON™ 9100/8500 series or FireGL™ 8800 installed
Kernel Module Driver compile support for Kernel 2.6.10 lbb
XVideo support now available in dualhead configuration lbb
3D geometry corruption no longer occurs with Celestia and other 3d apps
A blank screen or X failing to load and returning to the console no longer occurs under X.Org 6.8 when using the config file generated by fglrxconfig
64 Bit systems with 4 or more GB of RAM no longer hang the system while loading the X Server

Offline

#192 2005-04-07 08:05:24

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

tfpsly wrote:
iggy wrote:

suddenly the driver do not work. installed it a few days ago, all ok, but now this message:

[code]$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0"

Make sure you have  [code]Option "no_dri" "no"[/code] in your xorg.conf, and
chmod 666 /dev/dri/card0 as root under X (this dev is created only when X11 is started.

But I have another pb : each time I launch an OpenGL program, the screen would get black and X seems to crash. I may stiill reboot using the majick keys (altgr+ImprScr+SUV). Does anyone has a fix? (Xorg 6.8.2, fglrx_6_8_0-8.8.25-1.i386.rpm which should support it, using external agp gart on a nforce motherboard).

EDIT : it works, but X11 may crash every other boot (same under Windows, I'm going to exchange this noname card with a Sapphire one).

What if you dont have /dev/dri/card0, well actually my /dev/dri dir is completely empty. I have used my kernel config before and the same ati drivers, never had an issue


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#193 2005-04-08 16:23:00

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Are you trying to install new ati drivers???
Have u read something about them here:

http://bbs.archlinux.org/viewtopic.php?t=9264&start=75

Offline

#194 2005-04-09 23:49:03

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

ignore the above message ive got it all working now, again thanks to your help smile


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#195 2005-04-10 19:06:39

trapdoor
Member
Registered: 2005-03-27
Posts: 82
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Well, while making the package i got many errors, can anyone tell me what to do?

[root@rantanplan ati]# makepkg -fc
./PKGBUILD: line 10: build-time: command not found
mv: cannot stat `usr/share/gnome/apps/': No such file or directory
./PKGBUILD: line 26: lib/modules/fglrx/fglrx*.o: No such file or directory
./PKGBUILD: line 27: usr/X11R6/bin/*.bz2: No such file or directory
==> Making package: ati-drivers  (Sun Apr 10 21:01:28 CEST 2005)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==>     Using local copy of fglrx-4.3.0-3.11.1.i386.rpm
==> WARNING: MD5sums are missing or incomplete.  Cannot verify source integrity.
==> Extracting Sources...
==> Starting build()...
./PKGBUILD: line 14: rpmunpack: command not found

gzip: stdin: unexpected end of file
cpio: premature end of archive
mv: cannot stat `opt/kde3': No such file or directory
mv: cannot stat `usr/share/gnome/apps/': No such file or directory
==> Compressing man pages...
==> Stripping debugging symbols from libraries...
==> Stripping symbols from binaries...
==> Generating .PKGINFO file...
==> Copying install script...
==> Generating .FILELIST file...
==> Compressing package...
==> Cleaning up...
==> Finished making: ati-drivers  (Sun Apr 10 21:01:28 CEST 2005)

Offline

#196 2005-04-12 12:15:31

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

trapdoor wrote:

Well, while making the package i got many errors, can anyone tell me what to do?

[root@rantanplan ati]# makepkg -fc
./PKGBUILD: line 10: build-time: command not found
mv: cannot stat `usr/share/gnome/apps/': No such file or directory
./PKGBUILD: line 26: lib/modules/fglrx/fglrx*.o: No such file or directory
./PKGBUILD: line 27: usr/X11R6/bin/*.bz2: No such file or directory
==> Making package: ati-drivers  (Sun Apr 10 21:01:28 CEST 2005)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==>     Using local copy of fglrx-4.3.0-3.11.1.i386.rpm
==> WARNING: MD5sums are missing or incomplete.  Cannot verify source integrity.
==> Extracting Sources...
==> Starting build()...
./PKGBUILD: line 14: rpmunpack: command not found

gzip: stdin: unexpected end of file
cpio: premature end of archive
mv: cannot stat `opt/kde3': No such file or directory
mv: cannot stat `usr/share/gnome/apps/': No such file or directory
==> Compressing man pages...
==> Stripping debugging symbols from libraries...
==> Stripping symbols from binaries...
==> Generating .PKGINFO file...
==> Copying install script...
==> Generating .FILELIST file...
==> Compressing package...
==> Cleaning up...
==> Finished making: ati-drivers  (Sun Apr 10 21:01:28 CEST 2005)

first off you need rpmunpack

pacman -S rpmunpack

Also you can comment out the usr/share and opt/kde3 stuff if you dont use either of them


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#197 2005-05-11 15:20:29

Sting14
Member
Registered: 2005-05-03
Posts: 26

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

qwerty wrote:

The simplyest way to install ati drivers is to add the following lines at the end of your /etc/pacman.conf:

[link]
Server = ftp://ftp.archlinux.org/tur/link


Then just perform:

pacman -Syu
pacman -S ati-drivers

When trying to do this, when i pacman -S ati-drivers i get the following error:
ati-drivers-module-kernel26: requires kernel26=2.6.11.3-1 but it is not in the sync db

can anyone help me figure this out?

Offline

#198 2005-05-13 01:35:47

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Look at the wiki page:
http://wiki2.archlinux.org/index.php/At … rnel%202.6

It has been updated and there you can find all you need to make ati drivers work smile

Offline

#199 2005-05-16 01:24:30

mdirolf
Member
From: Princeton, NJ
Registered: 2004-05-21
Posts: 69

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

Hi,
I followed the new wiki to build the ati drivers myself, and they built and installed fine.  However, when I try 'modprobe fglrx' i get the following error:

FATAL: Error inserting fglrx (/lib/modules/2.6.11.7-ARCH/video/fglrx.ko): No such device

I have an ATI Mobility 9200, which I think is supposed to be supported in this latest version of the drivers.  Any suggestions?
Thanks,
Mike

Offline

#200 2005-07-10 02:12:20

mdirolf
Member
From: Princeton, NJ
Registered: 2004-05-21
Posts: 69

Re: [HOW-TO] Ati Radeon & Kernel 2.6 - Updated

are you also using a mobility radeon card?  im asking because i read on the ati website that for windows the drivers for mobility cards cannot be supplied by ati because that the cards used differ for each company using them or something like that.  I am wondering if that means my card will never be supported.

anyone using a mobility radeon (preferably 9200) with success??

-mike

Offline

Board footer

Powered by FluxBB