You are not logged in.

#1 2005-04-09 07:44:41

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Probleme after installation : grub>

I installed the Archlinux base 0.7 by FTP with only the package : base.
The bootloader : grub or lilo.
After the installation, i am blocked in the screen :
grub>
i have some commande like : password, kernel...it's seem it's a mini bash...but i can't continue...what is the probleme ? (for example i can't use the usually command like : ls, rm, etc... and i can't see the / (/root, /var etc...)

I don't understand smile


Noob

Offline

#2 2005-04-09 09:06:07

dauphin
Member
From: Scotland
Registered: 2003-07-09
Posts: 188

Re: Probleme after installation : grub>

Grub is just the bootloader so your new system has not yet been booted.  That's why you can't see the filesystem!
During the installation process, did you follow the instructions and edit the grub configuration file:  /boot/grub/menu.lst  ?
If not, I suggest you read the documentation thoroughly, then edit that file as necessary.  There are several ways to get into it to accomplish this, which have been discussed many times in these forums.  However, you can probably boot into the system by entering the grub parameters manually from the grub prompt you have there, eg. type:

root (hd?,?)    [Enter]
kernel (hd?,?)/boot/vmlinuz26 root=/dev/discs/disc?/part?     [enter]
boot      [enter]

Replace the ? with the appropriate settings for your system - you can work out what these should be by reading the installation instructions.  Basically you should input the same settings here as you should have put in  /boot/grub/menu.lst

If you did edit the grub configuration during the installation process, it sounds as if you made an error.  If you cannot track it down for yourself, post a copy of your grub configuration, as well as stating on which hard drive and partition you installed Arch.

Offline

#3 2005-04-12 20:50:48

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

When i make a autopart :

/dev/discs/disc0/
disc1 (boot NC primary ext2)
disc2 (linux swap)
disc3 ( ext3)

So what i have to write in the menu.lst ? please smile


Noob

Offline

#4 2005-04-12 20:58:03

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Probleme after installation : grub>

where did you install grub to? the MBR, or the partition boot record? it makes a difference:

in menu.lst you should have:
root=(hd0) #installed on mbr
root=(hd0,0) #installed on partition 0

you might also want to specify the kernel chunk as (hd0,0)/kernel-thingy to make sure it is able to find the file

Offline

#5 2005-04-12 21:05:42

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

I install it in the mbr


Noob

Offline

#6 2005-04-12 21:09:09

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Probleme after installation : grub>

>root (hd0,0)  <--points to your partition with the boot folder (it maybe root (hd0,2) if not 0,0)

>kernel /boot/vmlinuz26 root=/dev/discs/disc0/part3<--vmlinuz for 2.6 kernels only, vmlinuz for 2.4.

>setup (hd0)

>boot

Offline

#7 2005-04-12 21:39:24

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

error 15 : file not found...


Noob

Offline

#8 2005-04-12 21:41:01

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

(hd0,0) is good i think, because i can boot when i use this, ben i think kernel /boot/.... is wrong...i use the kernel 2.6 IDE.
Maybe i forget something...


Noob

Offline

#9 2005-04-12 21:42:02

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

I think i forget something because i can boot, but when i go to the /boot i can't see nothing and i have many fail when i boot...


Noob

Offline

#10 2005-04-12 21:43:33

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

but when i make : uname -r he detecte the kernel : 2.6.11.3 ARCH


Noob

Offline

#11 2005-04-12 21:45:32

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Probleme after installation : grub>

Vampyrx wrote:

I think i forget something because i can boot, but when i go to the /boot i can't see nothing and i have many fail when i boot...

your /etc/fstab file probably has your boot partition set to "noauto" - meaning it isn't automatically mounted... try "mount /boot"... you can also remove the "noauto" flag if you'd like

Offline

#12 2005-04-12 21:46:37

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

In my fstab i can't see the / and the others...
it miss something lol

When i make the installation, i install the package BASE the the kernel then grub...maybe i forget something


Noob

Offline

#13 2005-04-12 21:49:58

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Probleme after installation : grub>

you have an empty /etc/fstab file? that's not right... you may want to try reinstalling... I'm not sure what happened.

In an effort to help you, could you possibly provide more details when you post - it's hard to understand what's going on when your posts are so short.

Offline

#14 2005-04-12 21:53:09

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

Ok sorry i will write step by step what i do smile
Sorry, thanks a lot to help me !!!


Noob

Offline

#15 2005-04-12 22:04:27

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

1) i put the cd and i boot
2) boot : arch <enter>
3) i write /arch/setup to install
4) i choose a FTP installation source
5) Configure Network :  i probe my ethernet card in eth0 : SUCCEED
6) DHCP ? yes ---> network is configured
7)Prepare harddrive : Autoprepare
/dev/discs/disc0/disc will be completely erased (i have one disk) : SUCCEED
When i go to partition hard drives to see the partition i can see :
disc1 : boot, NC, Primary linux etx2
disc2 Primary Linux swap
disc3 primary Liunx ext3
(i do quit to keep this configuration)
8)Select package i use the first ftp : ftp-linux.cc.gatech.edu ---> i choose only BASE then i select all packages in base
9) then i install this package ---> it download with pacman (i don't keep the downloaded packages PACMAN -S --clean)
10) Install kernel : I choose the Kernel 2.6.X IDE it DL the kernel 26. : installation complete.
11) then i can edit the file configuration
rc.conf : i add KEYMAP=fr and TIMEZONE=France/Paris
grub : title Arch Linux [/boot/vmlinuz26]
root (hd0,0)
kernel /vmlinuz26 root=/dev/discs/disc0/part3 ro
fstab : /dev/discs/disc0/part3 / ext3 defautls 0 1
/dev/discs/disc0/part1 /boot ext2 defaults 0 1
/dev/discs/disc0/part2 swap swap defaults 0 0

I leave all by DEFAULT.
12) Install bootloader : GRUB then i have 4 choice : /dev/discs/disc0/disc
or /dev/discs/disc0/part1 or /dev/discs/disc0/part2 or /dev/discs/disc0/part3
I think disc is the mbr, and part1 is /boot.

So what i must to write in the menu.lst of grub and
what i have to choose to the bootloader  ?

Thanks smile


Noob

Offline

#16 2005-04-12 22:25:39

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: Probleme after installation : grub>

do you hit "done" after all steps during installlation?

otherwise this thing will happen,


arch + gentoo + initng + python = enlisy

Offline

#17 2005-04-12 22:33:07

Vampyrx
Member
Registered: 2005-04-09
Posts: 26

Re: Probleme after installation : grub>

Oh i am a good noob smile
It function, i leave all by default !
And i choose in the mbr.


So thanks smile
I think i have make a good tuto to a begining smile


Noob

Offline

#18 2005-04-13 02:09:11

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Probleme after installation : grub>

:shock:

Offline

Board footer

Powered by FluxBB