You are not logged in.

#1 2005-04-12 15:16:23

neo
Member
Registered: 2004-10-11
Posts: 11

after startx, I can not switch back to terminal

that is a fresh arch installation via harddisk. I used hwd to generate xorg.conf.  When I startx, I can not switch back to Terminal anymore, until I press CTRL + ALT + BackSpace to exit X.

Why CTRL + ALT + Fn(n= 1 to 6) is disable? I've never occurred this before.

Anyone have any sugguestion? solution?

Thanks.

Neo from Beijing, China

Offline

#2 2005-04-12 15:19:14

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: after startx, I can not switch back to terminal

Hmmm, some WMs could possibly override the keystroke... what WM are you using? Can you try hitting it twice? Sometimes mine requires me to jam on the keys (dunno why, I always just accepted it as user error).

Are you running an odd framebuffer device that would cause them to be invalidated?

What kind of video card, video driver, and xorg options do you have/use?

Offline

#3 2005-04-12 18:01:37

woodstock
Member
From: Toronto / Canada
Registered: 2004-11-21
Posts: 68

Re: after startx, I can not switch back to terminal

This might sound like a stupid suggest and it all depends on why kind of keyboard you have. But a friend of mine was once having this problem and it would seem that none of his F1-F12 keys would work. It turned out that his keyboard has one of those f-lock keys... which turns on by default, much like numlock turns off by default.

Just double check and see if that's the problem... though I don't see why ctrl+alt+backspace wouldn't work.

This is a far-fetched suggestion though, you might not even have that feature on your keyboard, but just check incase.


-- woodstock

Offline

#4 2005-04-12 20:39:11

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: after startx, I can not switch back to terminal

just following from woodstock, maybe check the keys in isolation. Just to be sure its not a keyboard or mapping problem.

Using XFCE4 wm, on mine, and probably Gnome/KDE

F1 should bring up "help" in many Applications,
Ctrl F1, Ctrl F2 etc  should change workspace, and
Alt F1 should bring up a browser with the xfce help page.

Maybe also check /etc/inittab   to see that VC's are actually set up. eg

c1:2345:respawn:/sbin/agetty 38400 vc/1 linux
c2:2345:respawn:/sbin/agetty 38400 vc/2 linux
etc etc

Offline

#5 2005-04-13 16:01:30

neo
Member
Registered: 2004-10-11
Posts: 11

Re: after startx, I can not switch back to terminal

my computer is an old latop -- Sony VAIO PCG-F350, made in last century.

I add nothing to xorg.conf.

Not only XFCE4, but also blackbox, icewn, all WMs cannot switch back to terminal.

When I start xterm in X and press CTRL +ALT +F1, xterm display a 'P' letter, and F2 is 'Q', and so on...

Why?

I remember this computer has no such problem with slackware(now I have replace it with arch, you see.)

Offline

#6 2005-04-13 16:41:07

Spider.007
Member
Registered: 2004-06-20
Posts: 1,151
Website

Re: after startx, I can not switch back to terminal

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option     "DontVTSwitch"

:?

Offline

#7 2005-04-13 20:12:13

mezoko
Member
Registered: 2005-03-26
Posts: 310
Website

Re: after startx, I can not switch back to terminal

All you got to do is edit the horz ver somethings
in /etc/X11/xorg.conf
if the refresh rate thing I have the same issue


"The only thing we have to fear is fear itself." - Franklin D. Roosevelt

Offline

#8 2005-04-14 01:04:52

neo
Member
Registered: 2004-10-11
Posts: 11

Re: after startx, I can not switch back to terminal

this is an xorg.conf configaration issue, I have fixed it by using xorgconfig to generate xorg.conf replace with hwd. It seems the keyboard setting's issue.

Thank you all.

Neo from Beijing, China

Offline

#9 2005-04-14 10:02:06

fetreney2000
Member
From: Malaysia
Registered: 2005-02-01
Posts: 81

Re: after startx, I can not switch back to terminal

Actually you only need to remove the word "nodeadkey" from the hwd generated xorg.conf to fix this problem. Its in the keyboard section of xorg.conf file.

Offline

Board footer

Powered by FluxBB