You are not logged in.

#1 2005-04-14 09:32:00

saintshakajin
Member
Registered: 2005-04-13
Posts: 32

[Solved]sane 1.0.15 and HP scanjet 3300c

Hello everybody,

I've a question about sane and my scanner. Normally it's supported in the version 1.0.15 of sane and under (k)Ubuntu, Fedora, Debian it works but here, I can't. When I launch kooka or xsane I see my scanner with the correct device but it allways says "device busy" so I can't scan sad

Thanks for your help

Offline

#2 2005-04-14 13:06:45

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: [Solved]sane 1.0.15 and HP scanjet 3300c

Create a "scanner" group, if you haven't one already, and add your current user to the group. Log out and back in, and it should work.
What's the output of "sane-find-scanner" as root, by the way?


Microshaft delenda est

Offline

#3 2005-04-14 13:54:06

saintshakajin
Member
Registered: 2005-04-13
Posts: 32

Re: [Solved]sane 1.0.15 and HP scanjet 3300c

[saintshakajin@LeGuerrierLegendaire ~]$ cat /etc/group|grep scan
scanner::96:saintshakajin

I'm in.

[root@LeGuerrierLegendaire saintshakajin]# sane-find-scanner

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x0205 [HP ScanJet 3300C]) at libusb:002:005
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program

I've tried scanimage in root and it works, it's strange because I'm in the group scanner.

Offline

#4 2005-04-14 14:02:23

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: [Solved]sane 1.0.15 and HP scanjet 3300c

You might have to grab and slot in this SANE backend:
http://sourceforge.net/projects/hp3300backend


Microshaft delenda est

Offline

#5 2005-04-14 14:19:28

saintshakajin
Member
Registered: 2005-04-13
Posts: 32

Re: [Solved]sane 1.0.15 and HP scanjet 3300c

My scanner works with sane 1.0.15 no need to patch. I've already used it under Debian etc... with sane 1.0.15 and no problem. Here it works in root however I'm in the scanner group.

Offline

#6 2005-04-14 14:51:57

saintshakajin
Member
Registered: 2005-04-13
Posts: 32

Re: [Solved]sane 1.0.15 and HP scanjet 3300c

I've found...
In root, I've done:

mknod /dev/usb/scanner0 c 180 48
chown root.scanner /dev/usb/scanner*
chmod g+rw /dev/usb/scanner0

and now, I can scan in user smile

Offline

#7 2005-04-20 12:09:37

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: [Solved]sane 1.0.15 and HP scanjet 3300c

Ummm, yes. It's not documented in the wiki exactly like that, but it does say to check the scanner backend configuration file- and at least my backend (epson.conf) suggests just what you've done!
Since none of the 3 included HP backends gives a very clear guide for your scanner, it was partially guessing...


Microshaft delenda est

Offline

Board footer

Powered by FluxBB