You are not logged in.

#1 2010-06-24 06:29:36

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Ayatana Project on Archlinux - official thread

There are already some threads regarding Ayatana libraries not compiling on Arch. Ive finally managed to make (ok, mostly i didnt made them, but tuned others work to compile) proper, working PKGBUILDs for this libraries, i plan also packaging new, Ayatana applets like Sound Menu, so i decided to start official thread for all Ayatana requests, bugs, etc. Please look also on my icons and themes thread. You can also check newest information about my packages on twitter - @dinth1906.

Some screenshots:
Workspace%201_032.png
Screenshot of newest Unity build on Ubuntu. We have long road ahead to get so spectacular effects on Arch
zrzutekranugs.th.png
My current desktop - still needs a lots of work


If you want to get better Ayatana experience,  install only mine development (bzr) packages. Mixing this with stable packages made by other people on AUR should work, but i cannot guarantee that this will work and will not eat your cat - nobody ever tested this. Feel warned and install manually only -bzr packages.

Working PKGBUILDS:
Main:
libdbusmenu-bzr: http://aur.archlinux.org/packages.php?ID=38317
libindicate-bzr: http://aur.archlinux.org/packages.php?ID=38318
indicator-applet-bzr: http://aur.archlinux.org/packages.php?ID=38319

Unity project:
clutk-bzr: http://aur.archlinux.org/packages.php?ID=38460
libunity-misc-bzr : http://aur.archlinux.org/packages.php?ID=38464
dee-bzr: http://aur.archlinux.org/packages.php?ID=38752

you dont want to install this right now, libbamf dont compile on Arch, so it isnt possible to compile unity]

Optional:
indicator-application-bzr: http://aur.archlinux.org/packages.php?ID=38372
indicator-session-bzr: http://aur.archlinux.org/packages.php?ID=38324
indicator-messages-bzr: http://aur.archlinux.org/packages.php?ID=38323
indicator-me-bzr: http://aur.archlinux.org/packages.php?ID=38322
indicator-datetime-bzr: http://aur.archlinux.org/packages.php?ID=38321
indicator-weather-bzr: http://aur.archlinux.org/packages.php?ID=38468
indicator-network-bzr: http://aur.archlinux.org/packages.php?ID=38467
(i will make indicator-sound when i will manage to compile libindicate-bzr trunk version, and i will make indicator-network, when i will think that ConnMan is better for me than NetworkManager+ModemManager)

External:
battery-status-bzr: http://aur.archlinux.org/packages.php?ID=38587 compiles properly but doesnt work for me, i dont know why
xchat-indicate plugin: http://aur.archlinux.org/packages.php?ID=38327
firefox notify-osd plugin: http://aur.archlinux.org/packages.php?ID=37443
liferea svn (with libindicate and ext4 patches): http://aur.archlinux.org/packages.php?ID=38331
evolution-indicator: http://aur.archlinux.org/packages.php?ID=38334
dropbox-experimental: http://aur.archlinux.org/packages.php?ID=29432 [not mine, but works with indicator-application out-of-box]
transmission-gtk-libappindicator-svn: http://aur.archlinux.org/packages.php?ID=38490

Other my PKGBUILDS: http://aur.archlinux.org/packages.php?SeB=m&K=Dinth

How can You contribute and help me?

You can contact me on Jabber or MSN - my account is "dinth1906@gmail.com" on both.

You can fix compile-time bugs:
* indicator-sound dont want to compile because vala definitions broken in Arch (??)
* unity deps: dee and libbamf cannot compile
* mono bindings cannot compile in any of packages

You can fix usablity bugs:
* indicator-session cannot restart computer
* what is "indicator applet appmenu" and why it isnt working ?
* indicator-sound isnt controlling rhythmbox
* evolution isnt showing in indicator-messages, when run from autostart. running manually works.
* battery-status compiles properly but doesnt work for me, i dont know why
* transmission-gtk-libappindicator-svn indicator doesnt work on some installs and works on others

You can help me packaging applications which i want to package:
* brasero
* power management
* rhythmbox
* gwibber bzr, sqlite, blip version

You can package applications which im not intrested in packaging:
* http://www.omgubuntu.co.uk/2010/05/add- … -menu.html

Last edited by Dinth (2010-07-07 08:24:17)

Offline

#2 2010-06-24 07:32:41

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,616
Website

Re: Ayatana Project on Archlinux - official thread

Is this related to Colibri?


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#3 2010-06-24 08:07:23

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

I dont think so. Ayatana is Ubuntu usablity project, which contains notify-osd (GNOME precursor of Colibri), and also libdbusmenu, libindicate, libindicator, indicator-applet, and many applet menus.

https://wiki.ubuntu.com/Ayatana

Offline

#4 2010-06-24 11:50:11

Mad Fish
Member
Registered: 2009-09-22
Posts: 295

Re: Ayatana Project on Archlinux - official thread

Can you please make a wiki page on wiki.archlinux.org for Ayatana? I think that could be useful.

Offline

#5 2010-06-24 12:43:17

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

I will try when i'll make some more Ayatana packages, but im not very good in english.
Now i have problem with very important indicator-applications, which depends on nunit, but unfortunately pkg-config dont see existing aur/nunit (could someone help me with proper nunit packaging??)
I also have many problems with unity dependencies.

Coming soon:
* indicator-applications
* indicator-weather
* unity
* empathy git with libindicate patch (current aur stable version of empathy with libindicate patch is out-of-date, besides that i like git packages:) ) [edit - unable to build git version, propably it is gnome 3.0 depended]
* evolution-indicator

Last edited by Dinth (2010-06-24 14:59:58)

Offline

#6 2010-06-25 14:45:56

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

indicator-application-bzr is finally out. Unfortunatelly without python or mono bindings (if someone needs _python_ bindings please write here, i can repair this, and didnt do that from lazyness )

Im looking for testing.

[edit]
Im preparing indicator-weather which needs python bindings for indicator-application, so stay tuned for update

Last edited by Dinth (2010-06-25 14:58:12)

Offline

#7 2010-06-26 17:58:42

blamed
Member
Registered: 2009-10-27
Posts: 15

Re: Ayatana Project on Archlinux - official thread

hmm indicator-application showing "No indicators" in gnome-panel..

Offline

#8 2010-06-26 23:27:03

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

This is appmenu indicator, not indicator-application. Im not sure, but i think that propably this should display something like global menu..

Offline

#9 2010-06-27 09:05:09

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

Ive made indicator-network package, indicator-weather (but ive got trouble with running it, it cannot find my city, maybe some problem with national chars), and finally updated libindicate to newest trunk version (unfortunatelly without mono bindings, which i cannot compile under Arch).

I have problems compiling indicator-sound package. Propably vala definitions are broken in arch. Location of one header in .c file is broken, patch is here:

--- ./src/music-player-bridge.c.orig<-->2010-06-26 16:02:41.522989542 +0200
+++ ./src/music-player-bridge.c>2010-06-26 16:02:00.423237760 +0200
@@ -34,7 +34,7 @@
 #include <gee.h>
 #include <stdlib.h>
 #include <string.h>
-#include <gio/gdesktopappinfo.h>
+#include <gio-unix-2.0/gio/gdesktopappinfo.h>
 #include <gio/gio.h>

unfortunatelly this .c file is generated from .vala file in make process, so to compile with it, i must first do ./make, which fails, then patch generated .c file, and run another ./make; cannot do this in PKGBUILD unfortunatelly, because fail of first make causes fail of makepkg.

Also i have problem with compiling gnome-power-manager with ubuntu patches. Here is PKGBUILD: http://rapidshare.com/files/403255018/g … ar.gz.html
and here is error: http://pastebin.com/g4urKwHP

Last edited by Dinth (2010-06-27 14:00:38)

Offline

#10 2010-06-29 19:06:33

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

There are some applications which have indicator patches, but im not intrested in packaging them, for example here: http://www.omgubuntu.co.uk/2010/05/add- … -menu.html

And if you want to follow my packages, you can find me on twitter @dinth1906

Last edited by Dinth (2010-06-30 17:45:03)

Offline

#11 2010-06-30 20:00:31

Wutzara
Member
Registered: 2010-03-23
Posts: 11

Re: Ayatana Project on Archlinux - official thread

I really want to contribute - you can contact me admin A T wutzara.de

Maybe we can divide the work

Offline

#12 2010-07-07 16:46:59

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

We have all unity dependencies compile on Arch! Unfortunatelly unity itself still doesnt compile, and we must workaround or fix many compilation errors first. But stay tuned, here is screenshot of ubuntu binary packages installed on arch:
zrzutekranu4.th.png
zrzutekranu5p.th.png

Last edited by Dinth (2010-07-07 16:55:29)

Offline

#13 2010-07-07 20:23:54

Ryuujin
Member
Registered: 2009-07-04
Posts: 31

Re: Ayatana Project on Archlinux - official thread

Wow man, great job !

Probably not related, but did you by any chance managed to get Gwibber (http://aur.archlinux.org/packages.php?ID=24544) working with libwebkit 1.2.1?

I also want to contribute to this, however I don't know much about packaging but I would be happy to read, learn and help out. Would you mind sharing what parts of the arch wiki you read to get started working with packages/aur?

Thanks.

Offline

#14 2010-07-08 10:08:00

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: Ayatana Project on Archlinux - official thread

Ryuujin: when i learned (and i learn all the time, im not pkgbuild mastah) i took example file, try to change it to my needs, and when i dont know how to do something, i look in other pkgbuilds.
If you want to contribute, but arent really into pkgbuilds, you can help with arch wiki page or testing existing pkgbuilds - this are bzr pkgbuilds, so it is possible that some revisions wouldnt compile or must have additional patches, and also there are lots of unresolved bugs, like indicator-sound dont showing rhythmbox controlls (if it needs some kind of rhythmbox version, or patch/extensions), or indicator-session (it cannot reboot computer, if it needs hal, or some permissions for user, etc).

Last edited by Dinth (2010-07-08 10:11:15)

Offline

#15 2010-07-09 20:36:37

fresh24
Member
From: Austria / Vienna
Registered: 2009-11-27
Posts: 28

Re: Ayatana Project on Archlinux - official thread

Dinth wrote:

* what is "indicator applet appmenu" and why it isnt working ?

This? https://wiki.ubuntu.com/DesktopExperien … cationMenu

Looks like a clone of globalmenu...


"Arch Linux - One update away from learning chroot" - Griemak

Offline

#16 2010-08-03 14:14:49

dfetter88
Member
Registered: 2010-06-02
Posts: 33

Re: Ayatana Project on Archlinux - official thread

@Dinth: How is the indicator-applet coming along? Last time I checked, I could not get any apps to show up in it? I'm particularly interested in rhythmbox.

Offline

#17 2010-08-20 22:33:29

samkpo
Member
Registered: 2009-11-12
Posts: 9

Re: Ayatana Project on Archlinux - official thread

i compiled the packages, but with a couple of changes.
For indicator-datetime-bzr you need glib2>=2.25.11
for ido, you need to compile the 0.1.11 version for indicator-sound (the bzr version, you can use ido=0.1.5 for indicator-sound<=0.2.3). But it needs gtk2>=2.21.6 with an ubntu patch, http://archive.ubuntu.com/ubuntu/pool/m … u1.diff.gz
this patch is needed becouse the ido compilling shows this error:
idoscalemenuitem.c: En la función 'ido_scale_menu_item_button_press_event':
idoscalemenuitem.c:471: error: declaración implícita de la función 'ubuntu_gtk_widget_set_has_grab'
make[2]: *** [idoscalemenuitem.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
    Abortando...

Offline

#18 2010-08-30 07:50:39

trusktr
Banned
From: .earth
Registered: 2010-02-18
Posts: 907
Website

Re: Ayatana Project on Archlinux - official thread

Hey Dinth, I noticed that you packages in the AUR mistakenly point to caarlos0's packages.

You should probably fix this so that someone installing one of your "bzr" packages will aquire only bzr packages. Currently, If i install "indicator-applet-bzr" from the AUR using yaourt, it will also install the dependencies from caarlos0. It won't install the bzr dependencies.

It says indicator-applet-bzr depends on indicator-messages and indicator-sessions, but instead it should depend on indicator-messages-bzr and indicator-sessions-bzr!


joe@trusktr.io - joe at true skater dot io.

Offline

#19 2010-08-30 07:51:56

trusktr
Banned
From: .earth
Registered: 2010-02-18
Posts: 907
Website

Re: Ayatana Project on Archlinux - official thread

By the way, would we use the indicator applet to replace the "notification area" applet?


joe@trusktr.io - joe at true skater dot io.

Offline

#20 2010-09-14 17:36:34

fresh24
Member
From: Austria / Vienna
Registered: 2009-11-27
Posts: 28

Re: Ayatana Project on Archlinux - official thread

It would be cool if you would try to compile indicator-sound again - it looks pretty awesome and is useful too wink

http://www.webupd8.org/2010/09/maverick … -gets.html


"Arch Linux - One update away from learning chroot" - Griemak

Offline

#21 2010-09-24 07:08:05

nemolivier
Member
Registered: 2010-09-24
Posts: 12

Re: Ayatana Project on Archlinux - official thread

I realy like your builds.
I've got a fail yesteday on libindicate-bzr :
/usr/bin/vapigen --library=Indicate-0.2 \
        --pkg glib-2.0 \
        --pkg Dbusmenu-Glib-0.2 \
        --vapidir=../src \
        Indicate-0.2.gir
Indicate-0.2.gir:5.1-8.94: error: unsupported GIR version 1.0 (supported: 1.2)
Generation failed: 1 error(s), 0 warning(s)
make[3]: *** [Indicate-0.2.vapi] Erreur 1
make[3]: quittant le répertoire « /tmp/yaourt-tmp-nemo/aur-libindicate-bzr/src/libindicate-build/libindicate »
make[2]: *** [all] Erreur 2
make[2]: quittant le répertoire « /tmp/yaourt-tmp-nemo/aur-libindicate-bzr/src/libindicate-build/libindicate »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /tmp/yaourt-tmp-nemo/aur-libindicate-bzr/src/libindicate-build »
make: *** [all] Erreur 2

Since we're near the official ubuntu 10.10 Why don't you use the « official » ayatana realese (or upgrade the non-bzr aur) ?

Offline

#22 2010-09-24 08:52:58

Wutzara
Member
Registered: 2010-03-23
Posts: 11

Re: Ayatana Project on Archlinux - official thread

thats an Introspection failure - if you append in the configure-step a --disable-introspection it should work

Offline

#23 2010-09-24 09:18:43

nemolivier
Member
Registered: 2010-09-24
Posts: 12

Re: Ayatana Project on Archlinux - official thread

Wutzara wrote:

thats an Introspection failure - if you append in the configure-step a --disable-introspection it should work

It work's Thank's. Hope we soon get a simplier way to installe the ayatana* things.

Offline

#24 2010-09-24 09:26:52

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Ayatana Project on Archlinux - official thread

if you really want g-i support, you have to wait until gnome 2.32 is released and g-i 0.9.6 is in the repos.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#25 2010-09-24 11:41:23

Cosmin
Member
Registered: 2008-10-06
Posts: 248

Re: Ayatana Project on Archlinux - official thread

nemolivier wrote:
Wutzara wrote:

thats an Introspection failure - if you append in the configure-step a --disable-introspection it should work

It work's Thank's. Hope we soon get a simplier way to installe the ayatana* things.

a meta packages would be nice big_smile or two

ayatana - for project specific packages

and

ubuntu-desktop - to get an all the ubuntu desktop packages installed.

Offline

Board footer

Powered by FluxBB