You are not logged in.

#1 2010-02-12 15:21:24

jai134
Member
Registered: 2008-11-26
Posts: 234

Skype + microphone = growling[SOLVED]

Hello. Really needs some help to get microphone working with Skype. After a lot of testing I can hear my voice in testcall but it is an octave to low an distorted. I am using a Zotac ION motherboard with Nvidia. Can't figure out mixersettings. It sounds like half speed when playbacking my voice.

Last edited by jai134 (2010-02-13 12:36:35)

Offline

#2 2010-02-12 17:08:01

grey
Member
From: Europe
Registered: 2007-08-23
Posts: 679

Re: Skype + microphone = growling[SOLVED]

Is it only skype, or are other sound recording programs also affected?


Good ideas do not need lots of lies told about them in order to gain public acceptance.

Offline

#3 2010-02-13 12:36:03

jai134
Member
Registered: 2008-11-26
Posts: 234

Re: Skype + microphone = growling[SOLVED]

I have finally solved it. Playing with soundrecorder for about half an hour and now it works. Don't really understand why but thats a minor annoyance for the moment. Thankyou for a good question.

Offline

#4 2010-02-14 16:20:33

capeta
Member
From: Minas Gerais, Brazil
Registered: 2007-08-13
Posts: 8

Re: Skype + microphone = growling[SOLVED]

Same problem here, don't know how to solve it...

Offline

#5 2010-02-17 19:03:48

ELWisty
Member
From: Helsinki, Finland
Registered: 2009-10-13
Posts: 55
Website

Re: Skype + microphone = growling[SOLVED]

Same problems on skype, same soundcard on 64bit Arch with latest kernel and KDE. These problems appeared after the update to KDE 4.4.

Offline

#6 2010-02-17 19:40:44

maruda_san
Member
Registered: 2009-02-28
Posts: 2

Re: Skype + microphone = growling[SOLVED]

jai134, how exactly did you solve it? i have exactly the same problem with octave lower growling sound. This seems to be Skype issue, when I record my voice in Audacity the sound is clean.

Offline

#7 2010-02-17 20:42:12

ELWisty
Member
From: Helsinki, Finland
Registered: 2009-10-13
Posts: 55
Website

Re: Skype + microphone = growling[SOLVED]

Well, in my case it appeared to be a matter of conflicting sound modules which had, I believe, come with the latest kernel update: I have an external USB sound card which I use as first priority, but since it doesn't work on Skype I need the laptop's NVidia card there. Before the kernel update I'd used asoundconf without problems but it worked only patchily after. I now set the sound module preferences properly in /etc/modprobe.d/modprobe.conf as per the Arch Wiki's ALSA page (USB audio first, NVidia second), and that solved the Skype problem as well:

There are two sound devices in Skype which do give sound to the mic:

1. HDA Nvidia, ALC663 analog (hw:1,0) - this gave and still gives a distorted sound

2. HDA NVidia, ALC663 Analog Default Audio Device (default:CARD=NVidia) - this didn't give any sound with the mic before I sorted out the module preferences, now works fine.

Offline

#8 2010-02-18 05:36:40

ELWisty
Member
From: Helsinki, Finland
Registered: 2009-10-13
Posts: 55
Website

Re: Skype + microphone = growling[SOLVED]

Well, I need to take it back some: the mic is fine with the Skype test call, but now I called a friend who said the sound is really bad.

Offline

#9 2010-02-22 16:52:18

capeta
Member
From: Minas Gerais, Brazil
Registered: 2007-08-13
Posts: 8

Re: Skype + microphone = growling[SOLVED]

It worked for me: http://wiki.archlinux.org/index.php/Sky … _for_Skype
I just add those lines to the .asoundrc (only the first block).

Last edited by capeta (2010-02-22 16:55:43)

Offline

#10 2010-02-22 19:48:13

maruda_san
Member
Registered: 2009-02-28
Posts: 2

Re: Skype + microphone = growling[SOLVED]

Thanks capeta! it solved the problem for me, now the voice is clean.

Offline

#11 2010-03-07 14:09:46

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: Skype + microphone = growling[SOLVED]

I have the same issue, but I have been unable to resolve it thusfar.
I have an MSI P55-GD65 motherbord, which uses a Realtek ALC889. This chip is a implementation of Azalia by Intel, pretty standard stuff one could say. lspci lists it as: 00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)

I use my front mic input, in Skype this input is called: HDA Intel, ALC889 Analog (hw:0,2).

This input used to work correctly in Skype, but does not anymore. This problem arose about one or two months ago, now it also makes me sound an octave to low and garbled. You can't understand a word I'm saying.
At first, I considered my headset might be broken. But after testing on a Windows machine it works fine. I installed Audacity on this computer, it records my voice perfectly using the hw:0,2 input (which is front mic).
So it's Skype messing up here...
I've tried selecting different capture devices, no sound. Also tried the Mic input (hw:0,0) and plugging in my headset mic at the back of my PC, same issue.
Also tried the above mentioned .asoundrc file and set Skype to use in inputs it creates, no sound.
I do not have the alsa-oss emulation module loaded while doing so.

I could use some pointers on which way to go next.

Offline

#12 2010-03-07 23:31:57

xelados
Member
Registered: 2007-06-02
Posts: 314
Website

Re: Skype + microphone = growling[SOLVED]

capeta's fix worked for me as well. Arch users save the day once again! Great work.

Offline

#13 2010-03-08 01:03:11

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: Skype + microphone = growling[SOLVED]

xelados wrote:

capeta's fix worked for me as well. Arch users save the day once again! Great work.

Could you be more precise what it is you are doing and on which hardware?
Because I've been trying several things to no avail... I'm probably missing something obvious again... tongue OR the fix just does not work for me

Last edited by Ultraman (2010-03-08 01:03:42)

Offline

#14 2010-03-17 01:52:47

xelados
Member
Registered: 2007-06-02
Posts: 314
Website

Re: Skype + microphone = growling[SOLVED]

Correction on my testimony; Skype works fine but I cannot use aplay while skype's running and mpd seems to be borked as well, using 'dmixer' as the device. Using the older version of skype crashes the instant I try to open a chat.

So, there doesn't seem to be a cleancut fix for this yet.

EDIT: Following the guide on the wiki, just change Skype's ringing and speaker output to dmixer while using skypein for your mic. Works AOK for me.

Last edited by xelados (2010-03-17 02:11:11)

Offline

#15 2010-03-23 17:40:34

MrPrise
Member
Registered: 2010-03-23
Posts: 2

Re: Skype + microphone = growling[SOLVED]

I have exactly the same sound hw like Ultraman and I have the same problem with skype and with skype, only.
The .asoundrc fix does not work for me. Someone please give me an idea how to fix this?
Thank you.

Offline

#16 2010-03-31 15:15:04

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: Skype + microphone = growling[SOLVED]

MrPrise wrote:

I have exactly the same sound hw like Ultraman and I have the same problem with skype and with skype, only.
The .asoundrc fix does not work for me. Someone please give me an idea how to fix this?
Thank you.

I was annoyed by the phone bill again so I put some more work into this and it seems I finally fixed it! With help from you guys and the wiki smile

Used the entire .asoundrc file.
Also changed the hw address in the wiki .asoundrc to "hw:0,2" because that is my front input.
Starting Skype using

ALSA_OSS_PCM_DEVICE="skype" aoss skype

And using the "skypein" device as Microphone in the settings, works now.
Mixing also seems to work, I can listen to music at the same time as using Skype.

Last edited by Ultraman (2010-03-31 15:26:01)

Offline

#17 2010-04-30 17:54:30

Singul
Member
Registered: 2010-03-24
Posts: 25

Re: Skype + microphone = growling[SOLVED]

I had that "an octave lower growling" stuff too, capeta's fix worked for me big_smile ..thanks very much, man, now I don't have to use an external microphone anymore smile

Offline

#18 2010-08-30 01:55:40

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: Skype + microphone = growling[SOLVED]

I'm getting this too on a MacBook Pro 2,2. Anyone know how to fix it without the asoundrc hack? I don't really want to do that. Maybe we should fix whatever thing makes this happen. The recording works fine in not-Skype, though, so maybe we can contact someone at Skype to get it fixed.

Last edited by cookiecaper (2010-08-30 01:56:36)

Offline

#19 2010-09-01 15:49:39

cookiecaper
Member
Registered: 2007-09-22
Posts: 196

Re: Skype + microphone = growling[SOLVED]

I wrote Skype Customer Service and they indicated that this problem could be solved by removing ~/.Skype/shared.xml. It seemed to work in my case. If you don't want to create a dummy ALSA device, you can try doing that.

Offline

Board footer

Powered by FluxBB