You are not logged in.

#1 2010-09-05 15:09:45

Registered: 2010-08-29
Posts: 30

(SOLVED) uinput doesn't create "/dev/misc/uinput"

Hello smile!

After closely following the Wiimote connection guide for the third time, I decided to ask you gurus here on the forums about the issue.

The instructions say:

First you need to make sure to load the uinput module:
$ sudo modprobe uinput
You should have a device in /dev/misc/uinput now.

However, the "/dev/misc" folder NEVER gets created, even after a reboot with "uinput" placed in the modules section of the rc.conf.

Therefore later, when I try to make the Wiimote function as an input device (with the "wminput" command), it gives out the error:
"unable to open uinput".

Is this a kernel error?

Does anyone know a way around it?

I found this information about a similar problem being resolved by using mknod here:

To summarize, the idea of this bug on Redhat is:

module loads but device node is not created.
If created manually with mknod everything works fine.

Expected results:
udev should create the device node

Thank you for all your help in advance,

Last edited by UFOKatarn (2010-09-05 20:12:45)


#2 2010-09-05 18:53:23

Registered: 2009-08-27
Posts: 88

Re: (SOLVED) uinput doesn't create "/dev/misc/uinput"

"modprobe uinput" creates the device node in /dev, not in /dev/misc. You have to create a special udev rule for that.


#3 2010-09-05 20:12:02

Registered: 2010-08-29
Posts: 30

Re: (SOLVED) uinput doesn't create "/dev/misc/uinput"

big_smile Thanks for the tip!

All I had to do was to allow non-root users access to uinput.

For all that might be ssearching the forum and stumble upon the same problem, this is done like this:

create a new file in the folder /etc/udev/rules.d
I named it user.rules, but the name and/or its extension don't matter

paste the following line into it
KERNEL=="uinput", GROUP="wheel", MODE:="0660"

I think MODE:="0660" allows all users to use uinput, but I'm not sure.
Solely having my user in the "wheel" group and NOT having the "MODE:="0660" in the rule didn't allow my user to access uinput.


start the command "wminput" as a normal user



Board footer

Powered by FluxBB