You are not logged in.

#1 2009-10-18 06:17:16

delmonico
Member
Registered: 2004-06-27
Posts: 82

Prevent wine from registering notepad as default text editor in GNOME

I'm not kidding. It does that. On a clean arch with gnome install, after I installed wine, opening text files really uses notepad.exe! That must be a practical joke of the wine developers, right? How can I fix this? I'm going to build my own wine package w/o notepad (just kidding. but why are they allowed to ship it in the first place?)

thanks for your help, c

Last edited by delmonico (2009-10-18 06:17:30)

Offline

#2 2009-10-18 06:40:31

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,723

Re: Prevent wine from registering notepad as default text editor in GNOME

I've noticed that too.  Try right clicking on the file, select properties then open with.  Select whatever you actually want the file to open with.  If notepad is present in the list remove it.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#3 2009-10-18 06:43:56

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Prevent wine from registering notepad as default text editor in GNOME

I have noticed this behaviour too...

They're not 'shipping' notepad. It's not like MS would allow them to. They have written a similar editor that imitates notepad (so Windows programs run through Wine don't do get lost, so to say).


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#4 2009-10-18 11:18:34

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Prevent wine from registering notepad as default text editor in GNOME

delete notepad and other wine apps you don't want in "~/.local/share/applications"

Offline

#5 2010-09-06 10:50:06

SoleSoul
Member
From: Israel
Registered: 2009-06-29
Posts: 309

Re: Prevent wine from registering notepad as default text editor in GNOME

I know this is old but I'm very grateful jarryson for your true answer to the problem.

Offline

#6 2010-09-06 11:24:31

PirateJonno
Forum Fellow
From: New Zealand
Registered: 2009-04-13
Posts: 372

Re: Prevent wine from registering notepad as default text editor in GNOME

there's an even better solution - disable winemenubuilder.exe in the libraries tab of winecfg. this will prevent wine from making any file associations at all. search the forums for more details


"You can watch for your administrator to install the latest kernel with watch uname -r" - From the watch man page

Offline

#7 2010-09-06 11:49:56

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,647
Website

Re: Prevent wine from registering notepad as default text editor in GNOME

This is an all too common question: https://bbs.archlinux.org/viewtopic.php?id=102939

Last edited by graysky (2010-09-06 12:05:35)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#8 2010-09-06 14:56:33

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,855

Re: Prevent wine from registering notepad as default text editor in GNOME

PirateJonno's answer is the 'right' way to handle things. And SoleSoul, please don't bump old threads, this wasn't even an accident....


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

Board footer

Powered by FluxBB