You are not logged in.

#1 2010-09-16 19:42:41

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

[SOLVED]lspci command is wrong

When I run the lspci command it gets my graphics card wrong. I have a NVIDIA GeForce 8200M G, but lspci gives me this in the vga line:
02:00.0 VGA compatible controller: nVidia Corporation C79 [GeForce 9200M G] (rev b1)

Could someone please tell me how to make it give correct information? I can deal with it since I already know what my card is, but I am afraid it might be part of a larger problem.

Last edited by Tux the penguin (2010-09-16 21:47:56)


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#2 2010-09-16 19:45:32

codycarey
Member
Registered: 2009-08-21
Posts: 154

Re: [SOLVED]lspci command is wrong

What does the following command output?

lspci -vvnns 02:00.0

Some manufacturers share IDs between devices so it's likely that is what's happening.

Last edited by codycarey (2010-09-16 19:49:50)

Offline

#3 2010-09-16 20:13:39

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]lspci command is wrong

It outputed this:

[root@awesome penguins]# lspci -vvnns 02:00.0
02:00.0 VGA compatible controller [0300]: nVidia Corporation C79 [GeForce 9200M G] [10de:086f] (rev b1) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. Device [1462:1012]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 23
    Region 0: Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
    Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Region 3: Memory at f6000000 (64-bit, prefetchable) [size=32M]
    Region 5: I/O ports at dc00 [size=128]
    [virtual] Expansion ROM at fafe0000 [disabled] [size=128K]
    Capabilities: [60] Power Management version 2
        Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
        Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Address: 0000000000000000  Data: 0000
    Kernel driver in use: nvidia
    Kernel modules: nvidia, nouveau, nvidiafb

Sorry, but I don't know what that means. Thanks for the quick reply.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#4 2010-09-16 20:31:03

codycarey
Member
Registered: 2009-08-21
Posts: 154

Re: [SOLVED]lspci command is wrong

Now try running the same command but adding a Q to the arguments and post the output. The Q argument is going to do the same thing but it's going to query the central PCI database for its resolution whereas before 'lspci' was looking at a database on your local machine. Most of the output is useless in this situation except the first few and last lines but it's easiest to just paste it all.

lspci -Qvvnns 02:00.0

The hope is that the output of this command will be different (more accurate) than before. Aside from giving you incorrect output you shouldn't have any problems because of it so don't be too worried.

Offline

#5 2010-09-16 20:42:57

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]lspci command is wrong

Here it is:


[root@awesome penguins]# lspci -Qvnns 02:00.0
02:00.0 VGA compatible controller [0300]: nVidia Corporation C79 [GeForce 9200M G] [10de:086f] (rev b1) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. Device [1462:1012]
    Flags: bus master, fast devsel, latency 0, IRQ 23
    Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f6000000 (64-bit, prefetchable) [size=32M]
    I/O ports at dc00 [size=128]
    [virtual] Expansion ROM at fafe0000 [disabled] [size=128K]
    Capabilities: [60] Power Management version 2
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Kernel driver in use: nvidia
    Kernel modules: nvidia, nouveau, nvidiafb

Thanks for your quick replies. If it is not a problem, other than incorrect output, then that is ok. Thanks for your help.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#6 2010-09-16 20:57:15

codycarey
Member
Registered: 2009-08-21
Posts: 154

Re: [SOLVED]lspci command is wrong

Just for reference, http://pci-ids.ucw.cz/read/PC/10de/086f this shows that they know about it. And http://www.pcidatabase.com/search.php?d … rch=Search has the correct device listed. These lists are maintained by different sets of people. 'lspci' pulls information from the first one.

Offline

#7 2010-09-16 21:18:23

stefanwilkens
Member
From: Enschede, the Netherlands
Registered: 2008-12-10
Posts: 624

Re: [SOLVED]lspci command is wrong

2009-04-06 16:26:47

might be time to send them an e-mail to wake up


Arch i686 on Phenom X4 | GTX760

Offline

#8 2010-09-16 21:47:33

Tux the penguin
Member
From: Tomorrow
Registered: 2010-05-25
Posts: 196

Re: [SOLVED]lspci command is wrong

Thanks for the replies. As long as it is only a minor issue, I don't really mind. I will mark this thread as solved.


I don't suffer from insanity. I enjoy every minute of it.
MSI CR600 / 3GB Memory / 320GB HDD / Intel Pentium Dual-Core CPU T4200 @ 2.00 GHz | Archlinux x86_64

Offline

#9 2010-09-17 03:18:31

fphillips
Member
From: Austin, TX
Registered: 2009-01-24
Posts: 201

Re: [SOLVED]lspci command is wrong

You can also see below where 086f translates to a 8200M:

http://us.download.nvidia.com/XFree86/L … chips.html

Offline

Board footer

Powered by FluxBB