You are not logged in.

#1 2010-09-12 17:28:58

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 378

ati rage 2c resolution [solved]

i have installed arch on pentium 3 with this card.

arch used "vesa" as driver in xorg.conf and i had only tow options in resolution

480*640 and 600*800.

i changed the driver to "ati" and "mach64" and now i have to more resolution - but lower.

i also added the mode line  "1024x768" "800x600" "640x480" but that dose'nt work also.

here is the relevant sections of xorg.conf

Section "Module"
    Load  "dri"
    Load  "glx"
    Load  "dbe"
    Load  "extmod"
    Load  "dri2"
    Load  "record"
#        Load  "r128"

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "DefaultRefresh"         # [<bool>]
        #Option     "ModeSetClearScreen"     # [<bool>]
    Identifier  "Card0"
#    Driver      "ati"
        Driver      "mach64"
#    Driver      "vesa"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
      Modes "1024x768" "800x600" "640x480"

    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
      Modes "1024x768" "800x600" "640x480"

    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
      Modes "1024x768" "800x600" "640x480"

    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
      Modes "1024x768" "800x600" "640x480"

    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
      Modes "1024x768" "800x600" "640x480"

    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
      Modes "1024x768" "800x600" "640x480"

    EndSubSection
EndSection

is this the correct driver and the xorg file?

where is the display preferences in arch gnome? (i found only monitor's)

Last edited by shulamy (2010-09-18 15:48:15)

Offline

#2 2010-09-12 22:07:34

xvello
Member
Registered: 2010-05-15
Posts: 81
Website

Re: ati rage 2c resolution [solved]

Hello

I think you should have a look at /var/log/Xorg.0.log to understand better why 1024x768 does not work.
I am guessing the issue is the monitor configuration. If you have an old CRT monitor, you have to specify HorizSync and VertRefresh values in your xorg.conf (as xorg relies on DDC, which might not be correctly implemented on your monitor). If setting correct refresh rates isn't sufficient, you will have to look at modesettings.

Regards

Offline

#3 2010-09-13 16:51:18

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 378

Re: ati rage 2c resolution [solved]

thanks for the answer.

i think you are right about the monitor.

DDC read failed.

the monitor is old and not unknown to arch.

i'll try to enter the vrefresh and hsync after i find the syntax.

and if it does'nt work i'll try another monitor - i have some.

but i have fedora on the same computer and it have no

problem with this monitor.

ezik

Last edited by shulamy (2010-09-18 15:49:52)

Offline

#4 2010-09-18 15:55:53

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 378

Re: ati rage 2c resolution [solved]

i change monitor to DDC supported and copied the refresh values

from /var/log/xorg.0.log  to  /etc/xorg.conf

ezik

Offline

Board footer

Powered by FluxBB