You are not logged in.

#26 2010-09-22 20:14:26

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: Show installed version and current version for out of date packages

Version 0.4-paste

/usr/bin/sudo /usr/bin/pacman -Sy &> /dev/null

# printf: hard precision on package names, easy on version numbers
/usr/bin/paste -d " " <(/usr/bin/printf "%-20.20s %-12s => \n" $(/usr/bin/pacman -Qu))  \
<(/usr/bin/pacman -Sdp --config <(grep -v "^Ignore" /etc/pacman.conf) --print-format "%v" $(/usr/bin/pacman -Qqu))

Changes wrt to 0.3-paste (thanks, falconindy!):
- config file is created on the fly,
- no need for sudo with 'pacman -Sdp'



Also, I've noticed that after adding a repo that has xf86-video-intel-newest - [archstuff] - pacman *does* suggest replacing xf86-video-intel-legacy:

[karol@black ~]$ sudo pacman -Su
:: Starting full system upgrade...
warning: hdparm: local (9.29-1) is newer than core (9.28-1)
warning: intel-dri: ignoring package upgrade (7.5.1-2 => 7.8.2-1)
warning: kernel26: ignoring package upgrade (2.6.34.3-1 => 2.6.35.5-1)
warning: libgl: ignoring package upgrade (7.5.1-2 => 7.8.2-1)
warning: lrzip: local (0.46-1) is newer than archlinuxfr (0.45-1)
warning: stfl: local (0.21-2) is newer than dragonlord (0.21-1)
warning: xf86-input-evdev: ignoring package upgrade (2.2.5-1 => 2.4.0-2)
warning: xf86-input-keyboard: ignoring package upgrade (1.3.2-2 => 1.4.0-2)
warning: xf86-input-mouse: ignoring package upgrade (1.4.0-2 => 1.5.0-2)
warning: ignoring package replacement (xf86-video-intel-legacy-2.3.2-3 => xf86-video-intel-newest-2.12.0-1)
warning: xf86-video-vesa: ignoring package upgrade (2.2.0-1 => 2.3.0-2)
warning: xorg-server: ignoring package upgrade (1.6.3.901-1 => 1.8.1.902-1)
warning: xorg-server-utils: ignoring package upgrade (7.4-7 => 7.5-6)
 there is nothing to do

Offline

Board footer

Powered by FluxBB