You are not logged in.

#2476 2010-09-24 02:27:14

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

stlifey wrote:

It seems not working.
make: Entering directory `/usr/src/linux-2.6.35-bfs'
  CC [M]  /home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/firegl_public.o
  CC [M]  /home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_acpi.o
  CC [M]  /home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_agp.o
  CC [M]  /home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_debug.o
  CC [M]  /home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.o
  CC [M]  /home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_io.o
/home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.c: In function 'KCL_IOCTL_AllocUserSpace32':
/home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.c:196:5: error: implicit declaration of function 'COMPAT_ALLOC_USER_SPACE'
/home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.c:196:24: warning: initialization makes pointer from integer without a cast
make[1]: *** [/home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod/kcl_ioctl.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: *** wait: No child processes.  Stop.
make: *** [_module_/home/henry/Desktop/Temp/catalyst-test/src/archive_files/common/lib/modules/fglrx/build_mod] Error 2
make: Leaving directory `/usr/src/linux-2.6.35-bfs'

strange... can you paste your /lib/modules/`uname -r`/build/arch/x86/include/asm/compat.h file?

Also: is 10.9 working fine? + what architecture you are using?

Edit: oh i guess i know... you are using some unpatched x86_64 kernel (<=2.6.35.4) or i686 kernel and it's not working because catalyst has no patch for older (unpatched) kernels - because it's directed to ubuntu and they have got some fancy solutions instead of original kernel's patches... I will try to provide such patch...

Edit2: ok, catalyst-test has been updated, it should work now.

Last edited by Vi0L0 (2010-09-24 03:16:31)

Offline

#2477 2010-09-24 03:15:56

stlifey
Member
Registered: 2010-08-07
Posts: 7

Re: The AMD/ATI Bar & Grill

catalyst 10.9 works fine.
I used the kernel26-bfs,the version is 2.6.35.5-330,is not the newset version?Then i found the fglrx-installer patch in here:
http://launchpadlibrarian.net/55947752/ … u5.debdiff
It works OK.

Last edited by stlifey (2010-09-24 03:18:34)

Offline

#2478 2010-09-24 03:19:46

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

stlifey wrote:

catalyst 10.9 works fine.
I used the kernel26-bfs,the version is 2.6.35.5-330,is not the newset version?Then i found the fglrx-installer patch in here:
http://launchpadlibrarian.net/55947752/ … u5.debdiff
It works OK.

can you try with catalyst-test 10.10-333 that i just uploaded?

or... wait i sec i will try t fix it wink

Last edited by Vi0L0 (2010-09-24 03:23:45)

Offline

#2479 2010-09-24 03:28:24

stlifey
Member
Registered: 2010-08-07
Posts: 7

Re: The AMD/ATI Bar & Grill

ok,I try it.

Offline

#2480 2010-09-24 03:30:50

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

stlifey wrote:

ok,I try it.

i made a typo in 333, 444 should work fine

Offline

#2481 2010-09-24 03:54:52

stlifey
Member
Registered: 2010-08-07
Posts: 7

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
stlifey wrote:

ok,I try it.

i made a typo in 333, 444 should work fine

Thanks,everything works OK!:D

Offline

#2482 2010-09-24 12:52:05

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 499

Re: The AMD/ATI Bar & Grill

I enabled testing repo and upgraded all packages (new qt4 version also) installed catalyst-test and works very very well really. With catalyst 10.9 i had some problems with  snes-gtk and water effect from compiz was broken, 10.10 fixed these issues. I am not too much interested on xvba accel because i have an intel core i5 so i couldn't test it, but i heard that evergreen is supported now. So i will keep beta drivers.


Excuse my poor English.

Offline

#2483 2010-09-24 13:49:08

Hamsterkill
Member
Registered: 2009-05-05
Posts: 45

Re: The AMD/ATI Bar & Grill

It might be good to show pacman's output for catalyst-generator so that the user knows something is actually being installed.

EDIT: Also, from looking at the source, it looks like this method may leave unnecessary catalyst-xxx packages installed whenever either the kernel or catalyst version number increases. Is this the case? If so, besides being messy, couldn't this also lead to file conflicts?

Last edited by Hamsterkill (2010-09-24 13:57:15)

Offline

#2484 2010-09-24 14:01:35

aqamar
Member
Registered: 2008-09-01
Posts: 49

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
aqamar wrote:

why doesn't work glxinfo or glxgears with the new catalyst 10.9? when i run glxinfo or glxgears appears:

$glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  18
  Current serial number in output stream:  18

I understand that you are updating(?)

If so - are you using repo or aur? if repo - note that catalyst package provides only fglrx module for stock kernel26.
catalyst-utils package is necessary.

Please paste file generated by /usr/sbin/atigetsysteminfo.sh on some pastebin server (and give us link to it wink ).

I'm using this repo http://catalyst.apocalypsus.net/repo/catalyst/i686 ... I install catalyst and catalyst-utils and here is my atigetsysteminfo.sh http://paste.archlinux.co.cc/434

Offline

#2485 2010-09-24 20:59:19

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

Hamsterkill wrote:

It might be good to show pacman's output for catalyst-generator so that the user knows something is actually being installed.

I have upgraded catalyst-generator, now there's no log (because actually we don't need it here), and everything is putted into default output.
Plus you can now run `catalyst_build_module` as a non-root user, so it's safer - only install package operation need root privileges now, so you will be asked for he's password to proceed it.

Hamsterkill wrote:

EDIT: Also, from looking at the source, it looks like this method may leave unnecessary catalyst-xxx packages installed whenever either the kernel or catalyst version number increases. Is this the case? If so, besides being messy, couldn't this also lead to file conflicts?

Yes, it's leaving unnecessary catalyst-xxx packages whenever the kernel (not catalyst) number increases.
But you can remove those unused packages by typing catalyst_build_module remove.
As i said - i want this package to be as manual as it can be smile, i believe user know what to do.

It's actually less messy than previous `catalyst_build_module` because fglrx modules are packed into pacman's packages, so there are no files just thrown here and there like trashes wink  -- i mean even if some fglrx module is needed and is in use it looks like trash because it's not related with any pacman's package.
And no - this shouldn't lead to any file conflict.

Offline

#2486 2010-09-24 21:03:59

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

aqamar wrote:
Vi0L0 wrote:
aqamar wrote:

why doesn't work glxinfo or glxgears with the new catalyst 10.9? when i run glxinfo or glxgears appears:

$glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  18
  Current serial number in output stream:  18

I understand that you are updating(?)

If so - are you using repo or aur? if repo - note that catalyst package provides only fglrx module for stock kernel26.
catalyst-utils package is necessary.

Please paste file generated by /usr/sbin/atigetsysteminfo.sh on some pastebin server (and give us link to it wink ).

I'm using this repo http://catalyst.apocalypsus.net/repo/catalyst/i686 ... I install catalyst and catalyst-utils and here is my atigetsysteminfo.sh http://paste.archlinux.co.cc/434

Huh... i really dunno why fglrx module doesn't fit to your kernel... Look at Xorg.0.log lines:

[    28.535] (WW) fglrx(0): Kernel Module version does *not* match driver.
[    28.535] (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
[    28.535] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[    28.535] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0xb788e000
[    28.535] (WW) fglrx(0): ***********************************************************
[    28.535] (WW) fglrx(0): * DRI initialization failed                               *
[    28.536] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[    28.536] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
[    28.536] (WW) fglrx(0): ***********************************************************

I checked this package on my own i686 system and it's working fine with stock kernel...
Edit: Maybe type:
modprobe fglrx
depmod -a
Or maybe try to use catalyst-hook from repo to build module...

Last edited by Vi0L0 (2010-09-24 21:06:10)

Offline

#2487 2010-09-25 01:52:10

aqamar
Member
Registered: 2008-09-01
Posts: 49

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
aqamar wrote:
Vi0L0 wrote:

I understand that you are updating(?)

If so - are you using repo or aur? if repo - note that catalyst package provides only fglrx module for stock kernel26.
catalyst-utils package is necessary.

Please paste file generated by /usr/sbin/atigetsysteminfo.sh on some pastebin server (and give us link to it wink ).

I'm using this repo http://catalyst.apocalypsus.net/repo/catalyst/i686 ... I install catalyst and catalyst-utils and here is my atigetsysteminfo.sh http://paste.archlinux.co.cc/434

Huh... i really dunno why fglrx module doesn't fit to your kernel... Look at Xorg.0.log lines:

[    28.535] (WW) fglrx(0): Kernel Module version does *not* match driver.
[    28.535] (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
[    28.535] (II) fglrx(0): [uki] removed 1 reserved context for kernel
[    28.535] (II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0xb788e000
[    28.535] (WW) fglrx(0): ***********************************************************
[    28.535] (WW) fglrx(0): * DRI initialization failed                               *
[    28.536] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[    28.536] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
[    28.536] (WW) fglrx(0): ***********************************************************

I checked this package on my own i686 system and it's working fine with stock kernel...
Edit: Maybe type:
modprobe fglrx
depmod -a
Or maybe try to use catalyst-hook from repo to build module...

mmm I think what happen... before to know the catalyst PKGBUILD, i download the driver directly of the page of amd and i run it... (# sh ./ati-driver-installer-10-8-x86.x86_64.run)
and then i install the catalyst 10.8 of AUR...

now, I run the ati-driver-installer-10-9-x86.x86_64.run and glxgears is working... but now i have 304 frames in 5.0 seconds = 60.739 FPS, before i got more FPS :'(.... something to do for uninstall this driver?

Offline

#2488 2010-09-25 03:16:20

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

@aqamar: there was a script to perform uninstall...
IIRC: /usr/share/ati/fglrx-uninstall.sh

however such frame-rate means only that your v-sync is working fine wink

Offline

#2489 2010-09-25 13:24:58

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

I am confused with chromium and gpu experiences here. I'm not sure if I am doing something wrong...but when I enable all parms...some accel works and some not (for example http://blog.chromium.org/2010/09/unleas … n-web.html nothing from these bechs there). Some other from IE page works. Webgl works fine too.
http://www.nevermindthebullets.com/strip.html#1-1 there no accel.
http://www.thewildernessdowntown.com/ and this is crashing with accel on

I have HD3450. Is it normal?

Offline

#2490 2010-09-25 18:34:04

LeCrayonVert
Member
Registered: 2010-09-01
Posts: 133

Re: The AMD/ATI Bar & Grill

Vi0L0  >> I've got a question about xorg18 repository, how come there is no xorg18.files.tar.gz file in the repo (http://catalyst.apocalypsus.net/repo/xorg18/$arch/) ? (pkgfile daily cron script complains about this missing file)
Thx wink


I believe in a world I can and do understand. A rational universe, explained through rational means.

Offline

#2491 2010-09-25 19:39:47

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

LukynZ wrote:

I am confused with chromium and gpu experiences here. I'm not sure if I am doing something wrong...but when I enable all parms...some accel works and some not (for example http://blog.chromium.org/2010/09/unleas … n-web.html nothing from these bechs there).

Hmm... on my hd4850 i'm getting ~60fps with 1000 fishes @ aquarium, wall of photos also work, Collectibles Painter got some problems, and Field isn't looking good.

LukynZ wrote:

I have HD3450. Is it normal?

I guess yes, chromium-dev is in hard development, and i guess we need to wait to gain full functionality.
Plus i think that some problems could be caused by catalyst.

Btw i got problems with youtube's webm when accel is enabled.
Edit: on catalyst-test it's working better but still got some problems with fullscreen

Last edited by Vi0L0 (2010-09-25 19:46:40)

Offline

#2492 2010-09-25 19:43:42

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

LeCrayonVert wrote:

Vi0L0  >> I've got a question about xorg18 repository, how come there is no xorg18.files.tar.gz file in the repo (http://catalyst.apocalypsus.net/repo/xorg18/$arch/) ? (pkgfile daily cron script complains about this missing file)
Thx wink

There's no such file because i wasn't actually aware that this file could exist and could be useful smile. Now i can see it could be, but still i dunno how to create such file (quick web search and quick asking on #archlinux gives me nothing). So i guess you will have to wait for it.
Edit: ok, i think i got it... update soon

Last edited by Vi0L0 (2010-09-25 20:24:29)

Offline

#2493 2010-09-25 21:25:53

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

Request To Testers.

Because i'm gonna be afk - i don't wanna leave [catalyst] repo users without catalyst-test (xserver 1.9 support) package.
And because i cannot be sure that there will be no kernel26 update while my afking - i decided to put catalyst-generator into catalyst-test.
I believe that catalyst-generator is in good shape now and it's ready to be tested, it's also safer than hook or daemon.
It's only disadvantage is that it's not supporting auto-recompilation, but i believe that typing:
catalyst_build_module remove
catalyst_build_module all
after kernel's update is also pretty easy.

So my request to testers is to test those packages:
x86_64: http://catalyst.apocalypsus.net/repo/ca … pkg.tar.xz
i686:   http://catalyst.apocalypsus.net/repo/ca … pkg.tar.xz

I need one sign-off for each architecture. Thanks in advance

After installing please run catalyst_build_module as unprivileged user.

I haven't updated aur's catalyst-test with new catalyst-generator funcionality, although i think i will do it because of it's support for multi-kernels systems.
For x86_64 i'm also gonna put lib32-catalyst-utils-test into [catalyst] repo.

And ofcourse i'll update wiki with all needed informations, but for now - it will be very nice if you would test those packages for me.

Offline

#2494 2010-09-25 23:03:01

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

for x86_64 was installation and module building fine, everything works smile Nice job smile

Offline

#2495 2010-09-26 10:28:14

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

I'm on 10.10-444 now too, and somethings changing on hd 5xxx (mine is hd5650). Like HW accel video playback:

http://ompldr.org/vNW44cA

vNW44cA

it was unrecognizable before. now it's something closer to what it should look... smile

Last edited by timong (2010-09-26 10:29:11)


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#2496 2010-09-26 10:35:08

LeCrayonVert
Member
Registered: 2010-09-01
Posts: 133

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
LeCrayonVert wrote:

Vi0L0  >> I've got a question about xorg18 repository, how come there is no xorg18.files.tar.gz file in the repo (http://catalyst.apocalypsus.net/repo/xorg18/$arch/) ? (pkgfile daily cron script complains about this missing file)
Thx wink

There's no such file because i wasn't actually aware that this file could exist and could be useful smile. Now i can see it could be, but still i dunno how to create such file (quick web search and quick asking on #archlinux gives me nothing). So i guess you will have to wait for it.
Edit: ok, i think i got it... update soon

Thanks wink


I believe in a world I can and do understand. A rational universe, explained through rational means.

Offline

#2497 2010-09-26 14:00:46

subzero316
Member
From: Melbourne
Registered: 2010-05-03
Posts: 28
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Request To Testers.
So my request to testers is to test those packages:
x86_64: http://catalyst.apocalypsus.net/repo/ca … pkg.tar.xz

Perfect works fine Including HD playback. Also notice a drop in X CPU usage (using Xorg-server 1.9) Memory usage still high though  ~ 400MB. Blur Effect smooth. BUT still having issues with flash full-screen sometimes with composting enables sometimes w/o.

@timong even after libva xbva-video mplayer-vaaapi update?

EDIT: Flickering has disappeared on videos (windowed) but a bit sluggish though.

Last edited by subzero316 (2010-09-26 14:21:24)

Offline

#2498 2010-09-26 14:15:32

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

@timong:
is this Will Smith with an eyes of a fly? lol

I'm also catching some artifacts (on hd4850) but only in one fullhd mkv movie:

http://ompldr.org/vNW5iOA

vNW5iOA

(no, this choper shouldn't have giant hole in it's tail wink )

Offline

#2499 2010-09-26 17:53:00

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

UPDATE

[catalyst] repo: added packages:
- catalyst-test 10.10 and lib32-catalyst-utils-test 10.10
- catalyst-generator 10.9

AUR: modified catalyst-test so now it contains catalyst-generator (same as in repo)

wiki: informations about catalyst-test and catalyst-generator



Big thanks to LukynZ and subzero316 for tests.

Last edited by Vi0L0 (2010-09-26 18:36:36)

Offline

#2500 2010-09-26 22:10:24

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: The AMD/ATI Bar & Grill

I gave catalyst-test a try yesterday, but the screen corruption issue that I have since 10.9 still exists in 10.10. Therefore, I rolled back to 10.8 for now. sad

Last edited by foutrelis (2010-09-26 22:10:54)

Offline

Board footer

Powered by FluxBB