You are not logged in.

#51 2010-09-06 08:12:26

rwd
Member
Registered: 2009-02-08
Posts: 646

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

I encountered  a bug in the 'prepare harddrive' part. I have a luks encrypted partition, and at some point  the script asks whether to unlock the partition. If I choose 'no' the install script freezes.

Last edited by rwd (2010-09-06 08:15:31)

Offline

#52 2010-09-11 10:51:45

b52
Member
From: Germany
Registered: 2009-03-20
Posts: 48
Website

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Im going to use your archboot image to setup my laptop with its new SSD and I'm
wondering what I need to consider to align each partition correct.

I wanna use a partition layout like this:

(grub-partition?)
/boot  ext2   75MB
/      btrfs  15GB
/home  btrfs  remaining

I hope someone can help me to get going.

Thanks
Oli


srsly?

Offline

#53 2010-09-11 13:42:46

steve___
Member
Registered: 2008-02-24
Posts: 439

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

I suggust creating a new thread for this if you're unsure, as it is not related to this topic.

That said, have you read through http://wiki.archlinux.org/index.php/SSD ?

Offline

#54 2010-09-11 14:03:27

b52
Member
From: Germany
Registered: 2009-03-20
Posts: 48
Website

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

I already created a new thread, check this: https://bbs.archlinux.org/viewtopic.php?id=104675
And I also read the wiki page, but it doesn't seem to fit my needs.


srsly?

Offline

#55 2010-09-12 11:35:18

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

for correct allignmrnt i would recommend to use parted it will align it correct.
Don't start at sector 0, use 1 instead that way 1mb allignment will be used and all should be fine.

Offline

#56 2010-09-15 14:18:40

FingeringFu
Member
From: United States
Registered: 2010-09-15
Posts: 5

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Tpowa,

I just wanted to let you know that Archboot 2k10-R6 worked fine for me. The only thing I didn't care for was being asked to provide file system labels before being asked if I even wanted to use labels (I prefer UUID).

Nice work!

Offline

#57 2010-09-15 15:17:45

ArchIMEDE
Member
Registered: 2010-04-20
Posts: 14

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

FingeringFu is right.

A good way should be:

1. Ask to user to select how he wants to identify his partitions ("UUID", "Label", "Standard") dialog
2a. Skip "Label" dialogs if user didn't choose "Label" option
2b. Force user to input labels in all partitions if he chose "Label" option

Offline

#58 2010-09-15 18:24:49

venky80
Member
Registered: 2007-05-13
Posts: 996

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

How can I select a default console font, I have no idea what to pick.


DELL XPS 1640 with ATI Mobility Radeon  HD 3670. Arch Linux KDE Minimal Install

Offline

#59 2010-09-17 13:01:08

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

hi Arch Community

I've tried to install arch 2010.05 but because of the old kernel I couldn't use my Atheros AR8151 (Ethernet Controller) out-of-the-box. So I picked archboot 2k10-R6.

installed it, using usb, no problem.
My laptop has 2 x 500 gb harddrives.
on sda1 — 100 mb system reserved (win7)
on sda2 — windows 7
on sdb1 — 250 gb for data (NTFS)
on sdb2 — 250 for arch ( / )

installed packages without any problems from ftp mirror (germany)
sdb2 is ext4

then I tried to install grub2 but it gave me error so I installed grub to sda

so arch has only one partition (/) and in grub is

root (hd1,1) # /dev/sdb2

but it fails loading arch. it gives me

Error 15: file not found...

cimg0054q.jpg

I tried:

grub> find /boot/grub/stage1
it gives me (hd1,1)

then I tried:

grub> kernel /boot/vmlinuz26 root=/dev/sdb2 # instead of the uuid by default.
it gives me Error 15: File not found...

so I wanted to check if there are images!

grub> find /boot/grub/menu.lst
gives: (hd1,1) # it means /boot/grub/menu.lst exists. double-checked by: cat /boot/grub/menu.lst

but if I try:

grub> find /boot/vmlinuz26 OR find /boot/kernel26.img

both give me as output: "Error 15: File not found"

I reinstalled (including deleting partition, creating new partition) Arch 3 times.. but every time it gives me the same Error 15

/arch/setup at the end gives NO ERRORS, it says everything was successfully installed. grub successfully installed to hd0 = sda

but after installation finishes I can't boot into Arch. so I have fresh installed arch but can't boot even first time right after installation finishes and I type: reboot

p.s. arch 2010.05 grub was installed to hd0 as well so it's not the problem but I can't update it or install anything because wi-fi and lan don't work (wpa_supplicant configured correctly but it won't connect to my wi-fi router..)

I guess VM images are missing...

Please tell me how can I fix it.

Last edited by _artem_ (2010-09-17 13:03:09)

Offline

#60 2010-09-17 13:07:54

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Try

kernel (hd1,1)/boot/vmlinuz26 root=/dev/....... etc.


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#61 2010-09-17 13:52:30

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

skodabenz wrote:

Try

kernel (hd1,1)/boot/vmlinuz26 root=/dev/....... etc.

nothing changed... sad

root (hd1,1)
chainloader +1
boot

doesn't help aswell

Offline

#62 2010-09-17 20:46:06

_artem_
Member
Registered: 2010-09-17
Posts: 37

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

solved by extracting kernel26-* and linux-firmware* packages to flash drive.
installing 2010.05.. booting into it without any eth0, updating with pacman -U /media/flash/*
reboot and i'm already in kernel 2.6.35 ifconfig shows me eth0 and there is already my internal ip.
pinging archlinux.org give me positive result smile
then upgraded via pacman -Syu

Offline

#63 2010-09-18 18:14:27

OrangeRoot1000
Member
From: TN -- USA
Registered: 2008-08-07
Posts: 106
Website

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

TPOWA!!!!!!!!!!!

Dude, your new DVD is top notch! I am a user that for all intents and purposes am totally solid state. Your train of thought, automatic setting up of the 1MB mandatory space before the 2nd partition, asking if you want to use GPT.

Parted was pretty self explanatory once I figured out the UNITs. I like how you break down, base, devel, and support and as an easy way to do it ask if the user wants all the packages installed. It's a snap to run through and uncheck a half dozen if need be. In addition when the DVD fires up you can choose a regular kernel or LTS. Massive time saver..

Thanks. It makes the new technology easier to utilize. BTW this install is on a Zotac dual core N510 Atm 1.6GhZ.

vp

Last edited by OrangeRoot1000 (2010-09-18 18:15:24)

Offline

#64 2010-09-19 05:19:44

baka
Member
Registered: 2010-05-18
Posts: 11

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

No big changes in last couple of weeks in git ,  Ready for next release ?

Offline

#65 2010-09-21 12:05:43

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Next release will happen with EFI support, which needs still to be implemented.
I have no clue when i have enough spare time to do this at the moment but i try to do it soon.

Offline

#66 2010-09-25 01:07:31

xrchz
Member
Registered: 2009-04-03
Posts: 36

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

By EFI support do you mean being able to boot the iso on an efi-only system, or do you mean putting options in the installer so that the newly installed system will use efi? Is it possible to do the latter manually at the moment?

Offline

#67 2010-09-25 06:04:41

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

xrchz wrote:

By EFI support do you mean being able to boot the iso on an efi-only system, or do you mean putting options in the installer so that the newly installed system will use efi? Is it possible to do the latter manually at the moment?

EFI booting support to the iso is complete but not yet implemented into Archboot. Download the latest Archboot iso and use this script http://gist.github.com/549014 (after editing archboot_ver variable) to create a efi bootable iso/usb.

The installer is not yet ready for efi so you have to manually install the grub2-efi package from the terminal. First mount you EFISYS partition at /boot/efi and then follow the instructions provided while installing the package to setup grub2 in the efisys part.

If you have a non-mac uefi system go for grub2-efi-x86_64 package (grub2 for 64-bit UEFI). Otherwise check the instructions in the link http://www.zdnet.com/blog/apple/will-yo … serve/4712 to find out whether you have 32-bit or 64-bit efi and install the appropriate package. Download the packages from http://misc-sk.4shared.com .


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#68 2010-09-25 23:14:22

xrchz
Member
Registered: 2009-04-03
Posts: 36

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Thanks much for the information skodabenz!

Since I'm not 100% sure, I should ask whether Intel desktop boards support EFI boot. It seems difficult to find an official list of EFI-supporting hardware (i.e. that ships with the requisite firmware). The generic Intel BIOS settings glossary (http://www.intel.com/support/motherboar … 030894.htm) says there's an option in the BIOS to "Enable UEFI boot", but I don't know if that applies to my board specifically (DH57JG). The manual for my board doesn't say anything specific, but has Port 80h error codes that are meant to indicate EFI services starting etc.

I won't be installing on my new computer for at least a week. Do you think grub2 1.99 and/or the new Archboot might be released officially by then?

Offline

#69 2010-09-26 06:41:39

skodabenz
Banned
From: Tamilnadu, India
Registered: 2010-04-11
Posts: 382

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

xrchz wrote:

Thanks much for the information skodabenz!

Since I'm not 100% sure, I should ask whether Intel desktop boards support EFI boot. It seems difficult to find an official list of EFI-supporting hardware (i.e. that ships with the requisite firmware). The generic Intel BIOS settings glossary (http://www.intel.com/support/motherboar … 030894.htm) says there's an option in the BIOS to "Enable UEFI boot", but I don't know if that applies to my board specifically (DH57JG). The manual for my board doesn't say anything specific, but has Port 80h error codes that are meant to indicate EFI services starting etc.

I won't be installing on my new computer for at least a week. Do you think grub2 1.99 and/or the new Archboot might be released officially by then?

As far as I know most of the server motherboards from Intel has efi support built-in. I do not know about Desktop motherboards. Just explore your bios settings to check for such an option. Most of the motherboards documentation regarding efi support is terrible. But if it exists then you can surely go for 64-bit efi (grub2-efi-x86_64 package). For your motherboard http://downloadcenter.intel.com/Detail_ … 4&lang=eng and http://www.intel.com/products/desktop/m … erview.htm .

As for archboot, you have to ask tpowa. Grub2 1.99 is ost likely to be released in 2nd or 3rd week of October, though it would be better if asked the grub2 devs in irc (#grub in freenode). Do not use 1.98 tarball for efi. It is too old and fails to boot linux in efi systems. The grub2 package in extra repo may be splitted according to my PKGBUILD once 1.99 is released.

Last edited by skodabenz (2010-09-26 06:53:46)


My new forum user/nick name is "the.ridikulus.rat" .

Offline

#70 2010-09-26 13:20:10

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

rwd wrote:

I encountered  a bug in the 'prepare harddrive' part. I have a luks encrypted partition, and at some point  the script asks whether to unlock the partition. If I choose 'no' the install script freezes.

I cannot reproduce this issue here in kvm all is fine if i chose no.
I need more details on this, what exactly are you doing and what device is asked to open.

thanks
greetings
tpowa

Offline

#71 2010-09-27 12:05:19

evot
Member
From: Finland
Registered: 2010-02-26
Posts: 96

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Thanks

This is just what i needed.
I installed Arch on my new netbook and only this new kernel version provided working internet connection.

Last edited by evot (2010-09-27 12:06:41)

Offline

#72 2010-09-27 18:01:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

ArchIMEDE wrote:

FingeringFu is right.

A good way should be:

1. Ask to user to select how he wants to identify his partitions ("UUID", "Label", "Standard") dialog
2a. Skip "Label" dialogs if user didn't choose "Label" option
2b. Force user to input labels in all partitions if he chose "Label" option

In order to provide suitable label names for udev it should be set in filesystem creation step,
I could add some kind of default name in the dialog field instead of empty field.

Offline

#73 2010-10-01 19:45:23

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

Ok guys, final testing of new iso will start now, stay tuned for new release soon.
Efi booting support works now, setup support will be delayed for next release.

Offline

#74 2010-10-03 05:53:13

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,263

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

New image released please continue there:
https://bbs.archlinux.org/viewtopic.php?id=105927

Offline

#75 2010-10-03 05:56:38

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: 2010.08-1 archboot "2k10-R6" ISO hybrid image released

New ISO, new thread smile.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

Board footer

Powered by FluxBB