You are not logged in.

#1 2010-09-28 05:38:04

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

iwl3945 64 bit low speeds

I have a Dell Vostro 1310 laptop with this wireless card: 06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)). When I first connect to the network it works as it should, but after some time I get maximum 100k/s downloads and very annoying intermitent paused browsing. This is happening for a few weeks (i'm thinking it's something about the kernel module after an upgrade).

This never happens on Win 7, which I use only for skype nor in Ubuntu 10.04, which I tested these days.

Before re-installing I would like to hear some ideas on this issue, maybe someone else had them. I'll post logs and configs if needed.

Offline

#2 2010-09-28 07:31:56

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: iwl3945 64 bit low speeds

this should be moved to "Networking" ... I don't know how it ended in here neutral

Offline

#3 2010-09-28 17:18:16

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: iwl3945 64 bit low speeds

bump?

Offline

#4 2010-09-29 15:16:51

slumslayer
Member
From: Belgium
Registered: 2008-09-14
Posts: 66

Re: iwl3945 64 bit low speeds

I noticed this too. Don't know about Windows but on Archlinux, the connection is really slow and sometimes I can't even auth with my AP (even if I am next to it).
This bug might be related : http://bugzilla.intellinuxwireless.org/ … gi?id=1932

Offline

#5 2010-09-30 15:47:43

slumslayer
Member
From: Belgium
Registered: 2008-09-14
Posts: 66

Re: iwl3945 64 bit low speeds

I tried with kernel26-lts (2.6.32.?) and it works. So it's definitely a kernel problem.

Last edited by slumslayer (2010-09-30 15:48:09)

Offline

#6 2010-10-01 06:18:26

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: iwl3945 64 bit low speeds

that makes sense... maybe I'll switch to one of the custom kernels in AUR until it gets fixed... thanks for confirmation!

Offline

#7 2010-10-03 09:42:55

RaisedFist
Member
From: Romania
Registered: 2007-01-30
Posts: 553
Website

Re: iwl3945 64 bit low speeds

looks like it's not this... after 2-3 days of use, the problem is back and as I can see, the intelwireless devs didn't do anything for more that one year about this problem.. it sucks.

Offline

Board footer

Powered by FluxBB