You are not logged in.

#2526 2010-09-29 23:20:03

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
DarksideEE7 wrote:

So what is the consensus on xorg 1.9 vs Catalyst 10.9, 10.10, or else?

10.9 doesn't support xserv 1.9 at all, so either use:
* catalyst-test
or
* 10.9 + [xorg18] repo

i think that 10.10 will support xserv 1.9 when it will be finally released

ps. i versioned catalyst-test as 10.10-xxx because ubuntu 10.10 is it's target

Excellent, thanks.  Right after posting that I installed:

catalyst-2.6.35-ARCH 10.10-666
catalyst-test 10.10-666
xorg-server-catalyst-maximize-fix 1.9.0-1

so far so good.  Crossfire is enabled as per

sudo aticonfig --lscs

Compositing in kwin works fine as well.

Offline

#2527 2010-09-30 06:07:19

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: The AMD/ATI Bar & Grill

foutrelis wrote:

I gave catalyst-test a try yesterday, but the screen corruption issue that I have since 10.9 still exists in 10.10. Therefore, I rolled back to 10.8 for now. sad

I tried it again today and I no longer have screen corruption!

@Vi0L0: Is the driver in catalyst-test 10.10-666 different from that in 10.10-444?

Offline

#2528 2010-09-30 06:44:20

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 673

Re: The AMD/ATI Bar & Grill

Excellent, thanks.  Right after posting that I installed:

catalyst-2.6.35-ARCH 10.10-666
catalyst-test 10.10-666
xorg-server-catalyst-maximize-fix 1.9.0-1

I tried yesterday the catalyst-test with plain xorg-server 1.9 from official Arch repository. Everything works smooth, no artifacts and fast windows resizing with kwin compositing using Ati 2D acceleration. It worked well also with 10.9 + 1.8, so I think that patched xorg-server won't be needed anymore...

Last edited by snack (2010-09-30 07:30:40)

Offline

#2529 2010-09-30 07:29:45

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

snack wrote:

Excellent, thanks.  Right after posting that I installed:

catalyst-2.6.35-ARCH 10.10-666
catalyst-test 10.10-666
xorg-server-catalyst-maximize-fix 1.9.0-1

I tried yesterday the catalyst-test with plain xorg-server 1.9 from official Arch repository. Everything works smooth, no artifacts and fast windows resizing with kwin compositing using Ati 2D acceleration. It worked well also with 10.9 + 1.8, so I think that patched xorg-server won't be needed anymore...

Same here.  It's been smooth-sailing since I installed those packages, and I've been multi-tasking like a madman tonight smile

Offline

#2530 2010-09-30 09:42:01

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: The AMD/ATI Bar & Grill

I would update catalyst package on aur with 10.10 beta. It works better than 10.9 and supports arch current xserver version... What do you think?

Last edited by agapito (2010-09-30 09:42:15)


Excuse my poor English.

Offline

#2531 2010-09-30 09:47:07

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 673

Re: The AMD/ATI Bar & Grill

agapito wrote:

I would update catalyst package on aur with 10.10 beta. It works better than 10.9 and supports arch current xserver version... What do you think?

I tried catalyst-test (which is catalyst 10.10)  from catalyst repo. On my x86_64 system it works with xorg-server 1.9 from official Arch repo. I think you should have no problem.

Offline

#2532 2010-09-30 10:06:17

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: The AMD/ATI Bar & Grill

snack wrote:
agapito wrote:

I would update catalyst package on aur with 10.10 beta. It works better than 10.9 and supports arch current xserver version... What do you think?

I tried catalyst-test (which is catalyst 10.10)  from catalyst repo. On my x86_64 system it works with xorg-server 1.9 from official Arch repo. I think you should have no problem.

I am using 10.10 since day one. I meant update official catalyst package from aur with beta version.


Excuse my poor English.

Offline

#2533 2010-09-30 10:09:23

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 673

Re: The AMD/ATI Bar & Grill

agapito wrote:
snack wrote:
agapito wrote:

I would update catalyst package on aur with 10.10 beta. It works better than 10.9 and supports arch current xserver version... What do you think?

I tried catalyst-test (which is catalyst 10.10)  from catalyst repo. On my x86_64 system it works with xorg-server 1.9 from official Arch repo. I think you should have no problem.

I am using 10.10 since day one. I meant update official catalyst package from aur with beta version.

Sorry, I misunderstood, my fault smile
I would wait for the official release before updating the catalyst package. Actually 10.10 is still formally a beta/prerelease.

Offline

#2534 2010-09-30 13:52:58

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

foutrelis wrote:
foutrelis wrote:

I gave catalyst-test a try yesterday, but the screen corruption issue that I have since 10.9 still exists in 10.10. Therefore, I rolled back to 10.8 for now. sad

I tried it again today and I no longer have screen corruption!

@Vi0L0: Is the driver in catalyst-test 10.10-666 different from that in 10.10-444?

No, it's the same driver. Maybe some fixes in kernel?

snack wrote:
agapito wrote:

I meant update official catalyst package from aur with beta version.

I would wait for the official release before updating the catalyst package. Actually 10.10 is still formally a beta/prerelease.

And i was/am always waiting for official release before updating catalyst.
This 10.10-xxx isn't even a beta/prerelease, it's just a driver for ubuntu.

OT: did you know that in the arch repos there's no nvidia driver with official xserver 1.9 support?
There is a stable driver which is working with IgnoreAbi option, but it's slow on xserv 1.9.
From the other hand there is also nvidia's beta driver in aur (which can not be pulled to [extra] because it's a beta).
Even then arch's devs decided to pull out xserv 1.9 (it was waiting in [testing] for month) into [extra], and i think they do right thing.
There should be no situation when binary blob is blocking Arch Way.

Last edited by Vi0L0 (2010-09-30 13:55:45)

Offline

#2535 2010-09-30 13:55:55

Gillian00
Member
From: Belgium
Registered: 2010-05-25
Posts: 100

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
foutrelis wrote:
foutrelis wrote:

I gave catalyst-test a try yesterday, but the screen corruption issue that I have since 10.9 still exists in 10.10. Therefore, I rolled back to 10.8 for now. sad

I tried it again today and I no longer have screen corruption!

@Vi0L0: Is the driver in catalyst-test 10.10-666 different from that in 10.10-444?

No, it's the same driver. Maybe some fixes in kernel?

I have the same issues  mostly with chromium-dev

I have another issue with 10.10 and xorg 1.9 : laptop freeze with flash videos on youtube

EDIT: however, qt 4.7 + catalyst 10.10 + xorg 1.9 + raster option in kde  is very smooth, thanks Vi0L0  ;-)

Last edited by Gillian00 (2010-09-30 13:56:58)


Dell Studio XPS 1647 | i5-560m | 4go ddr3 | ATI radeon mobility 4670HD 1go gddr3 | Seagate Momentus 7200.4 G-force | wled 1600x900

Offline

#2536 2010-09-30 14:04:40

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

@Gillian00:
some catalyst's beta tester said on phoronix forum that 10.10 will be much better than 10.9, and 10.11 will be better than 10.10
(yes, they have been testing beta of 10.11 for like half of a month)

Last edited by Vi0L0 (2010-09-30 14:10:41)

Offline

#2537 2010-09-30 14:30:34

unknwn
Member
Registered: 2008-02-02
Posts: 34

Re: The AMD/ATI Bar & Grill

I have installed kernel26-ck and built catalyst-test.  Now direct rendering doesn't work. When i try to run a movie with mplayer -vo vaapi:gl -va vaapi  i get "error while loading shared libraries: libGLU.so.1".
glxinfo | grep direct gives glxinfo: command not found.

EDIT: ahh, nevermind forgot to install mesa package. smile

Also catalyst control center doesn't work for me.
How to enable vsync while using compiz?

Last edited by unknwn (2010-09-30 16:33:52)

Offline

#2538 2010-09-30 17:20:31

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: The AMD/ATI Bar & Grill


Excuse my poor English.

Offline

#2539 2010-09-30 18:47:31

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

unknwn wrote:

Also catalyst control center doesn't work for me.
How to enable vsync while using compiz?

Even when you are running amdcccle as root or with sudo?

You can enable v-sync by changing VSyncControl line of /etc/ati/amdpcsdb file, so it may look like this:

[AMDPCSROOT/SYSTEM/BUSID-1:0:0-0/OpenGL]
VSyncControl=V3

V3 is always on

Offline

#2540 2010-09-30 18:59:28

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

Yes, thanks, but i won't update catalyst with it smile

This hotfix isn't working with fresh fixed kernels, it still needs arch_compat patch to compile module...

Let me explain...
hotfix's kcl_ioctl.c file contains those lines:

void* ATI_API_CALL KCL_IOCTL_AllocUserSpace32(long size)
{
    void __user *ret = COMPAT_ALLOC_USER_SPACE(size);

    /* prevent stack overflow */
    if (!access_ok(VERIFY_WRITE, ret, size))
        return NULL;

    return (void *)ret;
}

which just won't work with fresh fixed kernels because their code will not fit to this ati crappy code!
ATi has changed more catalyst's files to fit to this crappy solution...

I've got no freakin idea where from ati is taking such "fixes"... from ubuntu? Oh i'm pretty sure this will work with ubuntu... but, uhhhh... nevermind, no comments...

Edit: from the other hand make.sh file is directly telling what it should do when fresh fixed kernel is present... i will look at it when i will find some time.

Last edited by Vi0L0 (2010-09-30 19:56:36)

Offline

#2541 2010-09-30 22:55:06

unknwn
Member
Registered: 2008-02-02
Posts: 34

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
unknwn wrote:

Also catalyst control center doesn't work for me.
How to enable vsync while using compiz?

Even when you are running amdcccle as root or with sudo?

You can enable v-sync by changing VSyncControl line of /etc/ati/amdpcsdb file, so it may look like this:

[AMDPCSROOT/SYSTEM/BUSID-1:0:0-0/OpenGL]
VSyncControl=V3

V3 is always on

I turned on vsync but now  i can't use mplayer normally. Then i try to switch between fullscreen and windowed modes  mplayer stops responding in full screen mode. Had to restart X.

Last edited by unknwn (2010-09-30 22:56:03)

Offline

#2542 2010-10-01 00:43:22

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

Sure that it stops responding and doesn't only seem to because the screen doesn't get redrawn? This is the freezing framebuffer we described before and changing to a tty and then changing back to X solved it...


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2543 2010-10-01 03:46:14

kismet010
Member
Registered: 2009-09-02
Posts: 137

Re: The AMD/ATI Bar & Grill

kernel26-2.6.35.7-1 + xorg-server 1.9 + catalyst-test = good login but freezy screen

uname-a: 2.6.34-ARCH #1 SMP PREEMPT Mon Jul 5 22:12:11 CEST 2010 x86_64 Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz GenuineIntel GNU/Linux

EDIT: problem solved, removing kernel, xorg, catalyst and xf86-input-evdev. enabled testing repo (i don't think this is necesary) and reinstalling all

Last edited by kismet010 (2010-10-01 07:55:31)

Offline

#2544 2010-10-01 14:19:07

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

kismet010 wrote:

kernel26-2.6.35.7-1

and

kismet010 wrote:
uname-a: 2.6.34-ARCH

?
i'm not fallowing...

Offline

#2545 2010-10-01 14:37:23

kismet010
Member
Registered: 2009-09-02
Posts: 137

Re: The AMD/ATI Bar & Grill

i edited the post after rebooting and did some test with kernels and catalyst, don't know when did the uname -a..
but problem is solved
thanks Vi0L0 for your work big_smile

Offline

#2546 2010-10-01 15:32:36

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

I looked at how ati is doing job with fresh fixed kernels in their make.sh (on catalyst-test and 10.9 hotfix), i figured it out and moved to my pkgbuild, but it wasn't working on .36 kernels (ofcourse also with 2.6.36.patch), <sigh>... so i dropped their way and im still using compat and arch_compat patches.
Edit: oooh! i just found it! smile ati forgot to add some lines into their Makefile... (no comments tongue)... i fixed it and now it's always working fine without compat patches, catalyst-test-10.10-888 will be available soon smile

Although i've found that make.sh got some interesting module's compilation options, and i decided to put it into our ancient, as simple as it could be, compile method. Firstly into catalyst-test and if it will work fine for you - then probably also into all catalyst pkgs.

So now we've got modflags:
- smp which should be useful on smp kernels
- page_attrx and modversions which could be useful on some custom kernels
- and others.

[catalyst] repo has been updated with catalyst-test-10.777.
Note: don't forget to run catalyst_build_module after update
AUR will be updated after your testing smile

I already tested it on both arches and on some custom kernels and it seams to be fine.

But please tell me is it working ok, and - what's most important - tell me when it fail.

Thanks.

Last edited by Vi0L0 (2010-10-01 15:51:26)

Offline

#2547 2010-10-01 17:50:57

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Here's the error I got using 2.6.36 rc5. Running catalyst_build_module as regular user:

==> Starting build()...
patching file firegl_public.c
patch unexpectedly ends in middle of line
Hunk #2 succeeded at 411 with fuzz 1.
patching file kcl_ioctl.c
patching file kcl_ioctl.c
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /lib/modules/2.6.36-rc5-mainline/build/include/generated/autoconf.h says: SMP=1
file /lib/modules/2.6.36-rc5-mainline/build/include/generated/autoconf.h says: MODVERSIONS=
make: Entering directory `/usr/src/linux-2.6.36-rc5-mainline'
  CC [M]  /tmp/catalyst.iEfkJA/src/firegl_public.o
/tmp/catalyst.iEfkJA/src/firegl_public.c:415:5: warning: initialization from incompatible pointer type
/tmp/catalyst.iEfkJA/src/firegl_public.c: In function '__fgl_cmpxchg':
/tmp/catalyst.iEfkJA/src/firegl_public.c:1460:30: error: implicit declaration of function '__xg'
/tmp/catalyst.iEfkJA/src/firegl_public.c:1460:46: error: invalid type argument of unary '*' (have 'int')
/tmp/catalyst.iEfkJA/src/firegl_public.c:1466:46: error: invalid type argument of unary '*' (have 'int')
/tmp/catalyst.iEfkJA/src/firegl_public.c:1472:46: error: invalid type argument of unary '*' (have 'int')
/tmp/catalyst.iEfkJA/src/firegl_public.c: In function 'KAS_AtomicCompareExchangePointer':
/tmp/catalyst.iEfkJA/src/firegl_public.c:5661:5: warning: return makes pointer from integer without a cast
/tmp/catalyst.iEfkJA/src/firegl_public.c: In function 'KAS_AtomicExchangePointer':
/tmp/catalyst.iEfkJA/src/firegl_public.c:5681:5: warning: return makes pointer from integer without a cast
/tmp/catalyst.iEfkJA/src/firegl_public.c: In function '__fgl_cmpxchg':
/tmp/catalyst.iEfkJA/src/firegl_public.c:1458:9: error: memory input 2 is not directly addressable
/tmp/catalyst.iEfkJA/src/firegl_public.c:1464:9: error: memory input 2 is not directly addressable
/tmp/catalyst.iEfkJA/src/firegl_public.c:1470:9: error: memory input 2 is not directly addressable
make[1]: *** [/tmp/catalyst.iEfkJA/src/firegl_public.o] Error 1
make: *** [_module_/tmp/catalyst.iEfkJA/src] Error 2
make: Leaving directory `/usr/src/linux-2.6.36-rc5-mainline'
    Aborting...

Any ideas?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#2548 2010-10-01 18:07:43

o1911
Member
From: Hobart, Australia
Registered: 2009-04-28
Posts: 106

Re: The AMD/ATI Bar & Grill

.888 worked fine for me ViOLO, just played some Starcraft 2.  Thanks for all your efforts smile


Arch x86_64

Offline

#2549 2010-10-01 18:08:57

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,306
Website

Re: The AMD/ATI Bar & Grill

@dcc24:
i can see that you are using 777, i just uploaded 888, can you test it? although it's strange that's not working, i can see it was patched with all needed patches...

Was it working with previous 666 test?

IIRC you are using i686 system, on i686 i've tested only stock kernel.

x86_64 2.6.36 rc6 is also working fine.

Are you using testing? I've heard that it's make got some problems sometimes.

Offline

#2550 2010-10-01 18:16:36

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

@Vi0L0: I'm not using testing, the kernel is a mainline build with a stripped down config file I've prepared. Maybe I've disabled something in the kernel that breaks catalyst.

Anyway, I've just upgraded to the 2.6.36 rc6 from AUR, and it works fine. Thanks.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

Board footer

Powered by FluxBB