You are not logged in.

#1 2010-10-16 07:38:30

cruznick
Member
From: México
Registered: 2010-07-15
Posts: 37
Website

[Solved]Missing dependency [dbus-sharp]

I recently adopted a PKGBUILD that I like it's docky-stacks-bzr and when trying to fix it I'm getting this error :

Running aclocal -I . -I m4/shamrock  ...
Running automake --copy --gnu  ...
Running autoconf ...
Running intltoolize --force --copy --automake ...
Running ./configure --prefix=/usr ...
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a pax tar archive... gnutar
checking whether NLS is requested... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking for intltool >= 0.35.0... 0.41.1 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.12.1
checking for XML::Parser... ok
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for catalogs to be installed...  ast bg bn ca cs da de el en_GB es et eu fi fo fr gl he hi hr hu id is it ja ko lt nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_CN zh_HK zh_TW
checking for pkg-config... /usr/bin/pkg-config
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) none
checking for ANSI C header files... (cached) yes
checking for mono... /usr/bin/mono
checking for gmcs... /usr/bin/gmcs
checking pkg-config is at least version 0.9.0... yes
checking for GCONF... yes
checking for gconftool-2... /usr/bin/gconftool-2
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for GCONF_SHARP_20... yes
checking for GLIB_SHARP_20... yes
checking for GIO_SHARP... yes
checking for GNOME_DESKTOP_SHARP_20... yes
checking for GNOME_KEYRING_SHARP... yes
checking for GTK_SHARP_20... yes
checking for LIBRSVG_SHARP... yes
checking for MONO_ADDINS... yes
checking for MONO_ADDINS_GUI... yes
checking for MONO_ADDINS_SETUP... yes
checking for MONO_CAIRO... yes
checking for DBUS_SHARP_10... no
configure: error: Package requirements (dbus-sharp-1.0 >= 0.7) were not met:

No package 'dbus-sharp-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DBUS_SHARP_10_CFLAGS
and DBUS_SHARP_10_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
    Abortando...

I looked in the repos and couldn't find it and looking in other places I found this http://www.ndesk.org/DBusSharp  but I am confussed about dbus-sharp and ndesk-dbus can some guide me

thanks in advance

Last edited by cruznick (2011-01-10 07:25:30)

Offline

#2 2010-10-16 09:02:02

Bl@ster
Member
From: Rome
Registered: 2009-10-09
Posts: 51
Website

Re: [Solved]Missing dependency [dbus-sharp]

cruznick wrote:

I recently adopted a PKGBUILD that I like it's docky-stacks-bzr and when trying to fix it I'm getting this error :

Running aclocal -I . -I m4/shamrock  ...
Running automake --copy --gnu  ...
Running autoconf ...
Running intltoolize --force --copy --automake ...
Running ./configure --prefix=/usr ...
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a pax tar archive... gnutar
checking whether NLS is requested... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking for intltool >= 0.35.0... 0.41.1 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.12.1
checking for XML::Parser... ok
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for catalogs to be installed...  ast bg bn ca cs da de el en_GB es et eu fi fo fr gl he hi hr hu id is it ja ko lt nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_CN zh_HK zh_TW
checking for pkg-config... /usr/bin/pkg-config
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) none
checking for ANSI C header files... (cached) yes
checking for mono... /usr/bin/mono
checking for gmcs... /usr/bin/gmcs
checking pkg-config is at least version 0.9.0... yes
checking for GCONF... yes
checking for gconftool-2... /usr/bin/gconftool-2
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for GCONF_SHARP_20... yes
checking for GLIB_SHARP_20... yes
checking for GIO_SHARP... yes
checking for GNOME_DESKTOP_SHARP_20... yes
checking for GNOME_KEYRING_SHARP... yes
checking for GTK_SHARP_20... yes
checking for LIBRSVG_SHARP... yes
checking for MONO_ADDINS... yes
checking for MONO_ADDINS_GUI... yes
checking for MONO_ADDINS_SETUP... yes
checking for MONO_CAIRO... yes
checking for DBUS_SHARP_10... no
configure: error: Package requirements (dbus-sharp-1.0 >= 0.7) were not met:

No package 'dbus-sharp-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DBUS_SHARP_10_CFLAGS
and DBUS_SHARP_10_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
    Abortando...

I looked in the repos and couldn't find it and looking in other places I found this http://www.ndesk.org/DBusSharp  but I am confussed about dbus-sharp and ndesk-dbus can some guide me

thanks in advance

And you marked docky-bzr for this? tongue
By the way, I'm having the same issue; writing a PKGBUILD for ndesk-dbus-git didn't work: the configure continues to ask me about dbus-sharp-1.0 -.-

EDIT: Solved; we have to update from ndesk-dbus to dbus-sharp wink
I'm working from now on a dbus-sharp PKGBUILD smile

EDIT²: PKGBUILDs for dbus-sharp and dbus-sharp-glib are now on AUR; the only issue is that they are "heavy" forks of ndesk dbus, so installing them you will broke many of your Mono apps, until Arch will not build them with dbus-sharp support. I tried to recompile Tomboy without any patch but it doesn't build.
GNOME Do works (with some warnings) out of the box; Docky needs to be rebuilt using the GIT tree.

Last edited by Bl@ster (2010-10-16 09:48:22)

Offline

#3 2010-10-16 09:52:29

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved]Missing dependency [dbus-sharp]

dbus-sharp was recently removed from repos.


Give what you have. To someone, it may be better than you dare to think.

Offline

#4 2010-10-16 09:54:36

Bl@ster
Member
From: Rome
Registered: 2009-10-09
Posts: 51
Website

Re: [Solved]Missing dependency [dbus-sharp]

wonder wrote:

dbus-sharp was recently removed from repos.

Can you tell me why? hmm
As I can see, dbus-sharp is the updated fork of ndesk-dbus, so...

Offline

#5 2010-10-16 09:56:27

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved]Missing dependency [dbus-sharp]

not used by any package from our repos.


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2010-10-16 10:02:37

Bl@ster
Member
From: Rome
Registered: 2009-10-09
Posts: 51
Website

Re: [Solved]Missing dependency [dbus-sharp]

wonder wrote:

not used by any package from our repos.

Let me understand, we had ndesk-dbus and dbus-sharp in our repos at the same time?
Aren't they conflictual packages?

Offline

#7 2010-10-16 10:07:32

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [Solved]Missing dependency [dbus-sharp]

no freaking idea big_smile /me doesn't know anything about mono and wants to stay like that.


Give what you have. To someone, it may be better than you dare to think.

Offline

#8 2010-10-16 10:16:46

Bl@ster
Member
From: Rome
Registered: 2009-10-09
Posts: 51
Website

Re: [Solved]Missing dependency [dbus-sharp]

wonder wrote:

no freaking idea big_smile /me doesn't know anything about mono and wants to stay like that.

Oh, great lol
They can stay together, and my system doesn't transform itself in an ugly giant package fight.
Great news, I will update my AUR packages so tongue

Offline

#9 2010-10-16 14:17:44

cruznick
Member
From: México
Registered: 2010-07-15
Posts: 37
Website

Re: [Solved]Missing dependency [dbus-sharp]

@ Bl@ster  oh crap sorry  about your pkg I was sure I had marked my own pkg  (I was kind of sleepy ) but hey look at the brigth side tongue now works again also you can mark mine until I fix it tongue 
@ wonder Thanks for letting me know that dbus-sharp was moved from the repos now I know I'm not crazy I was sure I it was there

And so ndesk-dbus and dbus-sharp doesn't conflict and the trouble will come only from mono apps ?
also thanks Bl@ster for the PKGBUILDs I'll  change mine when back from work

Offline

#10 2010-10-16 21:29:43

Bl@ster
Member
From: Rome
Registered: 2009-10-09
Posts: 51
Website

Re: [Solved]Missing dependency [dbus-sharp]

cruznick wrote:

@ Bl@ster  oh crap sorry  about your pkg I was sure I had marked my own pkg  (I was kind of sleepy ) but hey look at the brigth side tongue now works again also you can mark mine until I fix it tongue 
@ wonder Thanks for letting me know that dbus-sharp was moved from the repos now I know I'm not crazy I was sure I it was there

And so ndesk-dbus and dbus-sharp doesn't conflict and the trouble will come only from mono apps ?
also thanks Bl@ster for the PKGBUILDs I'll  change mine when back from work

Nothing about troubles, these libraries are forks but different so you can install both of them and not to encounter any problem big_smile
In you PKGBUILD you have to change ndesk-dbus deps to dbus-sharp deps big_smile

Offline

Board footer

Powered by FluxBB