You are not logged in.

#1 2005-04-26 17:43:20

From: Cologne, Germany
Registered: 2004-07-29
Posts: 7

alsa/gstreamer problems (again) [probably solved]

Hello everybody,

I've got some sound problems here. I've read all the wiki stuff and search about the forums, but nothing could help me. The closest match to my problem was: … highlight=

There is one difference - I don't use kernel modules, I don't like them. So I've built the necessary modules into the kernel. I did it carefully and I surely have everything necessary in it. My setup also works with totem/xine and tvtime. And if I use OSS with a certain device -more on that later.

Alsa manages two soundcards, one from my tv card (Bt878) and the other from my real sound card (sblive - emu10k1). I have another on-board which is deactivated in BIOS.

cat /proc/asound/cards says:

0 [Bt878          ]: Bt87x - Brooktree Bt878
                     Brooktree Bt878 at 0xdb001000, irq 16
1 [Live           ]: EMU10K1 - Sound Blaster Live!
                     Sound Blaster Live! (rev.8) at 0xc000, irq 17

I use udev and my permissions are set correctly (owner:group = root:audio - user is in group audio) according to the wiki and my previous experience with alsa.
I've installed alsa oss-emulation.

Totem works perfectly. AFAIK Totem uses xine, so xine works also.
Tvtime works also. Tvtime uses the SB card as output and of course the SB gets input from Bt878.
I can use every mixer application you can think about. :-)
In fact I tried alsamixer, gnome sound mixer, aumix. Everything is okay.

There are several sound devices in /dev/sound:

crw-rw----  1 root audio 14, 30 2005-04-26 17:37 admmidi1
crw-rw----  1 root audio 14, 12 2005-04-26 17:37 adsp
crw-rw----  1 root audio 14, 28 2005-04-26 17:37 adsp1
crw-rw----  1 root audio 14, 29 2005-04-26 17:37 amidi1
crw-rw----  1 root audio 14,  4 2005-04-26 17:37 audio
crw-rw----  1 root audio 14, 20 2005-04-26 17:37 audio1
crw-rw----  1 root audio 14, 25 2005-04-26 17:37 dmmidi1
crw-rw----  1 root audio 14,  3 2005-04-26 17:37 dsp
crw-rw----  1 root audio 14, 19 2005-04-26 17:37 dsp1
crw-rw----  1 root audio 14,  0 2005-04-26 17:37 mixer
crw-rw----  1 root audio 14, 16 2005-04-26 17:37 mixer1
crw-rw----  1 root audio 14,  1 2005-04-26 17:37 sequencer
crw-rw----  1 root audio 14,  8 2005-04-26 17:37 sequencer2

If I use mpg321 with oss output and /dev/dsp it fails with:

Can't open libao driver with device /dev/dsp (is device in use?)

Same application with oss output and /dev/dsp1 works! Why is that?

lsof /dev/dsp says nothing.

Using mpg321 with alsa output and several devices (0:0, 1:0, 1:2) don't work. It gives the same message as with oss and /dev/dsp.

GStreamer doesn't produce any output, be it with osssink or alsasink as default sink. I guess a workaround would be use esdsink and have esd use /dev/dsp1. I have not tried and instead I'm looking for the 'real(tm)' solution.

Rhythmbox (which uses gstreamer) tells me /dev/dsp wouldn't exist (which is wrong) and that it cannot open the device.

Where does /dev/dsp actually come from? Is is the Bt878 (because it is the first card)? That would explain much. Then I could tell gstreamer to use /dev/dsp1..
That just came into my mind, I'll try it later.

EDIT: of course the rhythmbox thing was with osssink. When I use alsasink, I get:

Alsa device "default" does not exist.

What does it use for "default"? Maybe the Bt878. But as you might recall, I also get errors using device 1 explicitly.

If you've read so far, please give me a hint. :-)



#2 2005-04-26 18:05:42

From: Cologne, Germany
Registered: 2004-07-29
Posts: 7

Re: alsa/gstreamer problems (again) [probably solved]

Okay, for anyone with similar problems.. I told gstreamer to use device 1:

# gstreamer-properties

default sink:
alsasink device=hw:1,0

It then works, so I think, this is solved.


p.s.: if you know any better solution, please tell me..


Board footer

Powered by FluxBB