You are not logged in.

#301 2010-10-19 14:11:04

sindikat
Member
Registered: 2010-02-10
Posts: 10

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Unfortunately psb-driver didn't work. While i've installed "xorg-server 1.8" and then "xorg-x11-drv-psb", when i enter "startx", it throws something like:

failed to load kernel module "psb"
drmOpen failed.
DRScreenInit failed. Disabling DRI
Could not uninstall irq handler.
This driver currently needs DRM to operate.

Offline

#302 2010-10-19 15:47:12

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Please post your xorg.conf and Xorg.0.log. Has the following command the same output as mine?

ls -l /dev/dri/
total 0
crw-rw----+ 1 root video 226, 0 Oct 19 09:28 card0

Also do you have the latest kernel26-headers installed?

Offline

#303 2010-10-19 19:50:34

sindikat
Member
Registered: 2010-02-10
Posts: 10

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Xorg.0.log: http://pastebin.com/1cbAV2Fm
xorg.conf: http://pastebin.com/UrGEMLTu
your command shows "total 0"
kernel26-headers are installed
sad

Offline

#304 2010-10-19 20:06:23

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

My xorg.conf is that simple

Section "Device"
    Option      "ShadowFB"                "true"
    Option        "MigrationHeuristic"     "greedy"
    Identifier  "Card0"
    Driver      "psb"
    VendorName  "Intel Corporation"
    BoardName   "System Controller Hub (SCH Poulsbo) Graphics Controller"
    BusID       "PCI:0:2:0"
EndSection

From what I get, your error lies here

[   209.050] drmOpenDevice: node name is /dev/dri/card0
[   209.055] drmOpenDevice: open result is -1, (No such device or address)
[   209.059] drmOpenDevice: open result is -1, (No such device or address)
[   209.060] drmOpenDevice: Open failed
[   209.060] drmOpenDevice: node name is /dev/dri/card0
[   209.064] drmOpenDevice: open result is -1, (No such device or address)
[   209.069] drmOpenDevice: open result is -1, (No such device or address)
[   209.069] drmOpenDevice: Open failed

Mine for instance is

[   191.717] drmOpenDevice: node name is /dev/dri/card0
[   191.718] drmOpenDevice: open result is 12, (OK)
[   191.718] drmOpenByBusid: Searching for BusID PCI:0:2:0
[   191.718] drmOpenDevice: node name is /dev/dri/card0
[   191.718] drmOpenDevice: open result is 12, (OK)
[   191.718] drmOpenByBusid: drmOpenMinor returns 12
[   191.718] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0

For starters try to change your xorg.conf. Is your user in the video group btw? What's the output of groups?

Last edited by maevius (2010-10-19 20:35:39)

Offline

#305 2010-10-19 20:27:23

sindikat
Member
Registered: 2010-02-10
Posts: 10

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

user actually is in "video" group
the problem is /dev/dri is empty and i don't have any idea why and how to amend that
when i installed xorg i did "X -configure", that's why my xorg.conf is so big, is that a problem?

Offline

#306 2010-10-19 21:48:35

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Yeah, change the xorg.conf according to what I posted above and startx. If nothing happens again, post your Xorg.0.log.

Offline

#307 2010-10-20 18:10:46

sindikat
Member
Registered: 2010-02-10
Posts: 10

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Sorry for the delay. I've cut everything from xorg.conf. This is my Xorg.0.log: http://pastebin.com/UT7iWD8K
Again, i have an empty /dev/dri folder.

Offline

#308 2010-10-20 21:26:33

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Do you have dri2proto and mesa installed?

Last edited by maevius (2010-10-20 21:27:06)

Offline

#309 2010-10-21 17:25:59

sindikat
Member
Registered: 2010-02-10
Posts: 10

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

dri2proto is installed
when i enter "pacman -S mesa" it says "libdrm and libdrm-poulsbo are in conflict. Remove libdrm-poulsbo?"

Offline

#310 2010-10-22 07:28:29

cswetenham
Member
Registered: 2010-10-22
Posts: 7

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Hi, I have been following this thread and I have the same problem, on an Asus 1201HA, same error in Xorg.log.0. dri2proto is installed and mesa is installed. Sindikat, I think you can try pacman -Sd mesa to ignore the conflict, in my case mesa was already installed before I removed libdrm and installed libdrm-poulsbo. I don't have downgraded versions of libgl or mesa, I don't have A BusID line in the Device section of my Xorg.conf, I will try those and see what happens...

Offline

#311 2010-10-23 09:47:09

sindikat
Member
Registered: 2010-02-10
Posts: 10

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

So, i've lost patience and deleted xorg.conf (making a backup). Now X works quite fine (i think it uses some default options), at least faster, than vesa. I still have no accelerated scrollings and other stuff, but I can at least use X without pain. maevius, thank you for all the help and wasted time on me (=.

Last edited by sindikat (2010-10-23 09:50:54)

Offline

#312 2010-10-23 23:42:32

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Nothing to thank me for. I wish I knew more to help you with your problem...
So what driver are you using now?

Offline

#313 2010-10-25 07:28:24

partizan
Member
From: Ukraine
Registered: 2010-09-23
Posts: 28

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Hi all smile
I got working compiz with latest xorg.
Just added patches from fedora devel brach to existent pkgbuilds psb-kmod and xorg-x11-video-psb.
http://dl.dropbox.com/u/2162921/pkgbuil … src.tar.gz
http://dl.dropbox.com/u/2162921/pkgbuil … src.tar.gz

(also, if you got error about xf86mm.h when building xorg-x11-drv-psb, check if package libdrm-poulsbo installed)

Offline

#314 2010-10-25 07:43:34

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

That's great news! I'm building right now!
@Sindicat, it just got me today while compiling a package. It was probably my fault that you could not startx. I have been building all packages with kernel26-fbcondecor, so if you use the normal kernel, modules won't be able to load on your machine... I just started building again from scratch, I'll keep you posted smile
A big thanks to partizan!

Last edited by maevius (2010-10-25 07:44:08)

Offline

#315 2010-10-26 02:51:20

Jonhoo
Member
Registered: 2009-05-23
Posts: 113

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Any chance of getting the new patches added to the AUR as well?
Great work partizan!

Offline

#316 2010-10-26 05:56:44

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Unfortunately, I can't get xorg-x11-drv-psb to compile... It kicks with errors. Anyone else with this problem? As for AUR, someone should contact the maintainer in order to add the patches and new PKGBUILD.

Offline

#317 2010-10-26 10:05:01

partizan
Member
From: Ukraine
Registered: 2010-09-23
Posts: 28

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

maevius wrote:

Unfortunately, I can't get xorg-x11-drv-psb to compile... It kicks with errors. Anyone else with this problem? As for AUR, someone should contact the maintainer in order to add the patches and new PKGBUILD.

previous maintainer dropped packages for me, i just updated xorg-x11-drv-psb and psb-kmod.
are you sure you building drv-psb after psb-kmod? post here your error, i'll try to help smile

Offline

#318 2010-10-26 10:45:46

maevius
Member
From: Greece
Registered: 2009-09-10
Posts: 134
Website

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

partizan wrote:
maevius wrote:

Unfortunately, I can't get xorg-x11-drv-psb to compile... It kicks with errors. Anyone else with this problem? As for AUR, someone should contact the maintainer in order to add the patches and new PKGBUILD.

previous maintainer dropped packages for me, i just updated xorg-x11-drv-psb and psb-kmod.
are you sure you building drv-psb after psb-kmod? post here your error, i'll try to help smile

Yeap, I built/installed psb-kmod 4.41.1-3 without problem. I rebooted and played fine. I'm still on xorg 1.8 btw.
Here's the code when I try to build xorg-x11-drv-psb 0.32.0-2.

http://pastebin.com/gbV1V2V6

Offline

#319 2010-10-26 11:01:41

partizan
Member
From: Ukraine
Registered: 2010-09-23
Posts: 28

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

are you building this package with xorg-1.9?
you can try my binary package http://dl.dropbox.com/u/2162921/package … pkg.tar.gz

Offline

#320 2010-10-27 02:33:32

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

The psb-kmond PKBUILD works ok but I cannot complie xorg-x11-drv-psb successfully, it says

...(above is ok)...
Making all in src
make[2]: Entering directory `/home/steven/xorg-x11-drv-psb/src/xserver-xorg-video-psb-0.32.0/src'
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..    -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1   -I/usr/include/psb -I/usr/include/psb/drm -I/usr/include/X11/dri   -Wall -I.. -fvisibility=default -MT psb_accel.lo -MD -MP -MF .deps/psb_accel.Tpo -c -o psb_accel.lo psb_accel.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1 -I/usr/include/psb -I/usr/include/psb/drm -I/usr/include/X11/dri -Wall -I.. -fvisibility=default -MT psb_accel.lo -MD -MP -MF .deps/psb_accel.Tpo -c psb_accel.c  -fPIC -DPIC -o .libs/psb_accel.o
psb_accel.c: In function 'psbTexOffsetStart':
psb_accel.c:1396:17: warning: unused variable 'pScrn'
psb_accel.c: At top level:
i830_bios.h:232:26: warning: array 'g_SupportedCeShortVideoModes' assumed to have one element
mv -f .deps/psb_accel.Tpo .deps/psb_accel.Plo
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..    -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1   -I/usr/include/psb -I/usr/include/psb/drm -I/usr/include/X11/dri   -Wall -I.. -fvisibility=default -MT psb_buffers.lo -MD -MP -MF .deps/psb_buffers.Tpo -c -o psb_buffers.lo psb_buffers.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1 -I/usr/include/psb -I/usr/include/psb/drm -I/usr/include/X11/dri -Wall -I.. -fvisibility=default -MT psb_buffers.lo -MD -MP -MF .deps/psb_buffers.Tpo -c psb_buffers.c  -fPIC -DPIC -o .libs/psb_buffers.o
i830_bios.h:232:26: warning: array 'g_SupportedCeShortVideoModes' assumed to have one element
mv -f .deps/psb_buffers.Tpo .deps/psb_buffers.Plo
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..    -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1   -I/usr/include/psb -I/usr/include/psb/drm -I/usr/include/X11/dri   -Wall -I.. -fvisibility=default -MT psb_driver.lo -MD -MP -MF .deps/psb_driver.Tpo -c -o psb_driver.lo psb_driver.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1 -I/usr/include/psb -I/usr/include/psb/drm -I/usr/include/X11/dri -Wall -I.. -fvisibility=default -MT psb_driver.lo -MD -MP -MF .deps/psb_driver.Tpo -c psb_driver.c  -fPIC -DPIC -o .libs/psb_driver.o
In file included from psb_driver.c:41:0:
i810_reg.h:2288:0: warning: "BITS_PER_BYTE" redefined
/usr/include/xorg/edid.h:23:0: note: this is the location of the previous definition
psb_driver.c: In function 'psbSetup':
psb_driver.c:319:18: error: 'RegionEmptyBox' undeclared (first use in this function)
psb_driver.c:319:18: note: each undeclared identifier is reported only once for each function it appears in
psb_driver.c:320:19: error: 'RegionEmptyData' undeclared (first use in this function)
psb_driver.c:321:20: error: 'RegionBrokenData' undeclared (first use in this function)
psb_driver.c: In function 'psbDeviceInit':
psb_driver.c:1076:13: warning: passing argument 2 of 'pci_device_cfg_read_u32' from incompatible pointer type
/usr/include/pciaccess.h:153:5: note: expected 'uint32_t *' but argument is of type 'CARD32 *'
psb_driver.c:1116:5: warning: format '%08x' expects type 'unsigned int', but argument 4 has type 'long unsigned int'
psb_driver.c:1152:5: warning: format '%08x' expects type 'unsigned int', but argument 5 has type 'long unsigned int'
psb_driver.c:1152:5: warning: format '%08x' expects type 'unsigned int', but argument 6 has type 'long unsigned int'
psb_driver.c:1230:9: warning: passing argument 2 of 'pci_device_cfg_read_u32' from incompatible pointer type
/usr/include/pciaccess.h:153:5: note: expected 'uint32_t *' but argument is of type 'CARD32 *'
psb_driver.c: At top level:
psb_driver.c:168:20: warning: 'vbeSymbols' defined but not used
psb_driver.c:174:20: warning: 'fbSymbols' defined but not used
psb_driver.c:180:20: warning: 'shadowSymbols' defined but not used
psb_driver.c:186:20: warning: 'exaSymbols' defined but not used
psb_driver.c:198:20: warning: 'psbvgahwSymbols' defined but not used
psb_driver.c:217:20: warning: 'psbDRISymbols' defined but not used
psb_driver.c:233:20: warning: 'psbDRMSymbols' defined but not used
psb_driver.c:268:20: warning: 'psbXpsbSymbols' defined but not used
psb_driver.c:282:20: warning: 'ddcSymbols' defined but not used
psb_driver.c:2191:1: warning: 'psbPointerMoved' defined but not used
i830_bios.h:232:26: warning: array 'g_SupportedCeShortVideoModes' assumed to have one element
make[2]: *** [psb_driver.lo]     ERROR 1
make[2]: Leaving directory `/home/steven/xorg-x11-drv-psb/src/xserver-xorg-video-psb-0.32.0/src'
make[1]: *** [all-recursive]  ERROR 1
make[1]: Leaving directory `/home/steven/xorg-x11-drv-psb/src/xserver-xorg-video-psb-0.32.0'
make: *** [all]  ERROR 2

Offline

#321 2010-10-27 03:08:27

seeking
Member
Registered: 2009-08-25
Posts: 22

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

When I "pacman -U" the binary package of partizan, X fails to start...

I work with xorg-server 1.8 and the latest upgraded system. But I don't know the relationship of xorg 7.x and xorg-server 1.8/1.9

Is it the problem of xorg 7.5/7.6?

Offline

#322 2010-10-27 06:16:59

partizan
Member
From: Ukraine
Registered: 2010-09-23
Posts: 28

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

seeking wrote:

When I "pacman -U" the binary package of partizan, X fails to start...

I work with xorg-server 1.8 and the latest upgraded system. But I don't know the relationship of xorg 7.x and xorg-server 1.8/1.9

Is it the problem of xorg 7.5/7.6?

i think,
xorg-7.5 == xorg-server-1.9
Seems like this driver works only with xorg-server-1.9 (tested by me), anybody can confirm this?

also, in your previous post you building driver with xorg-server-1.8, becouse of it, it fails.

Last edited by partizan (2010-10-27 06:19:12)

Offline

#323 2010-10-27 09:36:38

Jonhoo
Member
Registered: 2009-05-23
Posts: 113

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

The xorg-x11-drv-psb package from AUR does not compile for me either..
Fails after "checking if /usr/bin/cpp requires -traditional... yes" with:

./configure: line 11995: syntax error near unexpected token 'XINERAMA,'
./configure: line 11995: 'XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)'

Any ideas?

Offline

#324 2010-10-27 10:16:09

partizan
Member
From: Ukraine
Registered: 2010-09-23
Posts: 28

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Jonhoo wrote:

The xorg-x11-drv-psb package from AUR does not compile for me either..
Fails after "checking if /usr/bin/cpp requires -traditional... yes" with:

./configure: line 11995: syntax error near unexpected token 'XINERAMA,'
./configure: line 11995: 'XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)'

Any ideas?

idea #1: pacman -S xorg-server-devel
or just update pkgbuild from aur, i included it in makedepends

Offline

#325 2010-10-27 10:49:15

Jonhoo
Member
Registered: 2009-05-23
Posts: 113

Re: Poulsbo aka Intel GMA500 drivers PKGBUILD

Worked like a charm!
Thanks smile

Offline

Board footer

Powered by FluxBB