You are not logged in.

#1 2010-10-22 20:57:54

elifarley
Member
From: Rio de Janeiro
Registered: 2008-03-07
Posts: 37
Website

[SOLVED]Error starting KDE: org.kde.kded not provided by .service file

After a 'pacman -Syu', I'm unable to use KDE anymore. Here's the error message:


----
startkde: Starting up...
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kded(5019): Communication problem with  "kded" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.ServiceUnknown" : " "The name org.kde.kded was not provided by any .service files" "

startkde: Shutting down...
klauncher: Exiting on signal 1
----

uname -a
Linux vostro 2.6.35-ARCH #1 SMP PREEMPT Wed Sep 29 08:45:18 CEST 2010 x86_64 Intel(R) Core(TM)2 Duo CPU T8100 @ 2.10GHz GenuineIntel GNU/Linux

kdelibs: 4.5.2-1

Last edited by elifarley (2010-11-07 14:06:13)

Offline

#2 2010-10-28 18:09:24

thesalus
Member
Registered: 2010-10-28
Posts: 1

Re: [SOLVED]Error starting KDE: org.kde.kded not provided by .service file

A few days ago after the upgrade to xorg-apps and xorg-server-utils to 7.6-1 (merely a correlation at this point), I logged out and received the same errors as you when I tried to log back in. However, a completely new user account with the same .kde4 and .kdemod4 folders worked just fine.

After a day of fruitless research and a brief foray into fluxbox, I encountered this post by spacepenguin whose instructions seemed to fix my problems:
1. Copy ~/.Xauthority and ~/.ICEauthority from a new user account to the dysfunctional one.
2. Remove the /var/tmp/kdecache-<username> folder

(p.s. the key step here seems to be the removal of that cache, but I cannot confirm it)
--
uname -a
Linux thesalus 2.6.35-ARCH #1 SMP PREEMPT Wed Sep 29 07:17:20 UTC 2010 i686 Intel(R) Core(TM)2 CPU T5300 @ 1.73GHz GenuineIntel GNU/Linux

kdemod-core kdemod-kdelibs 4.5.2-2 [installed]

Offline

#3 2010-11-06 18:44:47

Götz
Member
Registered: 2009-02-16
Posts: 25

Re: [SOLVED]Error starting KDE: org.kde.kded not provided by .service file

Thank you very much thesalus for the info.

I was moving some plasma widgets from the panel to the desktop, and back, then plasma-desktop crashed, after some seconds kwin also crashed. After that I typed ALT+SysRq+K to restart the xserver, but it didn't worked. So I restarted the pc and I encountered the problem.

I first moved the .kde folder, but it didn't help. Then I removed the .Xauthority and the .ICEauthority files, it didn't work either.
But only removing the /var/tmp/kdecache-$USER  folder made KDE work again.

I can not understand how this can happen, I had no idea that there was in /var/tmp a folder with some more files. I thought that in the root directory, there was only a temp folder in /tmp.


What I hear, I forget. What I say, I remember. What I do, I understand.  –Tao Te Ching/Laozi

Offline

#4 2010-11-07 14:04:51

elifarley
Member
From: Rio de Janeiro
Registered: 2008-03-07
Posts: 37
Website

Re: [SOLVED]Error starting KDE: org.kde.kded not provided by .service file

I removed /var/tmp/kdecache-$USER and /var/tmp/kdecache-kdm, and it solved the problem. I think removing kdecache-kdm wasn't necessary.

Thanks thesalus and spacepenguin!

Offline

#5 2011-01-08 16:09:20

pafnow
Member
Registered: 2011-01-08
Posts: 1

Re: [SOLVED]Error starting KDE: org.kde.kded not provided by .service file

Hello everybody !

I just encounter this problem also under kubuntu tonight and your post helped me a lot!
Thanks to all of you.

And for more precision, just remove the folder /var/tmp/kdecache-<username> is enough!

Thanks again

Offline

Board footer

Powered by FluxBB