You are not logged in.

#1 2010-10-16 21:24:32

zac
Member
Registered: 2010-10-16
Posts: 2

Trouble with Sound Volume on Acer Aspire 7730

Hi Forum,

since I updated to a newer kernel (2.6.32->2.6.35; first I used Ubuntu 10.04, then 10.10 which uses a new kernel, then I decided to change to arch), I am experiencing a kindof strange sound problem (before updating, it all worked out quite well):

The sound works, but the volume is very low. I have added options snd-hda-intel model=acer-aspire-7730g (this is how it is listed on kernel.org) to my /etc/modprobe.d/sound.conf and all channels in alsamixer are up at 100% and unmuted. Seems, all my sound modules are loaded into the kernel while booting. There seem to be no errors related to sound on dmesg.

Also, jacksensing does not seem to work (I can't use the internal speaker; only my headset works) - which also had worked before updating.
I can't really find anything up-to-date on the Net about reappearing sound problems on this platform, so I would be grateful for any advice you could possibly give.

The output of some commands that might (or not) be useful:

aplay -l:
Karte 0: Intel [HDA Intel], Gerät 0: ALC888 Analog [ALC888 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: Intel [HDA Intel], Gerät 1: ALC888 Digital [ALC888 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: Intel [HDA Intel], Gerät 3: NVIDIA HDMI [NVIDIA HDMI]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

/etc/modprobe.d/sound.conf:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=acer-aspire-7730g

/proc/asound/cards:
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf0500000 irq 47

Offline

#2 2010-10-17 10:44:59

owain
Member
Registered: 2009-08-24
Posts: 233

Re: Trouble with Sound Volume on Acer Aspire 7730

I've got the same problem, with the same laptop - here's the bug report.

Offline

#3 2010-10-23 08:37:24

zac
Member
Registered: 2010-10-16
Posts: 2

Re: Trouble with Sound Volume on Acer Aspire 7730

I rolled back to kernel26-lts; everything works just fine with that kernel version.

Offline

Board footer

Powered by FluxBB