You are not logged in.

#51 2010-11-01 21:01:18

nishantjr
Member
From: Tokyo
Registered: 2009-02-17
Posts: 4
Website

Re: Ayatana Project on Archlinux - official thread

Hi, Ive got bamf compiling, by using the ubuntu glib2 patch.
Here is the package build, you need to download the install script and glib2.sh, glib2.csh manually or do
yaourt -Sb glib2 and edit PKGBUILD

pkgname=glib2-ubuntu
pkgver=2.26.0
pkgrel=2
pkgdesc="Common C routines used by GTK+ 2.4 and other libs"
url="http://www.gtk.org/"
arch=(i686 x86_64)
license=('LGPL')
depends=('pcre>=8.02')
provides=('glib2=2.26.0')
conflicts=('glib2=2.26.0')
replaces=('glib2=2.26.0')
makedepends=('pkgconfig' 'python2')
options=('!libtool' '!docs')
source=(http://archive.ubuntu.com/ubuntu/pool/main/g/glib2.0/glib2.0_2.26.0.orig.tar.gz
    http://archive.ubuntu.com/ubuntu/pool/main/g/glib2.0/glib2.0_2.26.0-0ubuntu1.diff.gz
        glib2.sh
        glib2.csh)
md5sums=(9496ef773f323c3fceadfdcebcaf43c7
         edc0982e209c8f2b4203cb44a451253e
     803017b365bd35dc20b092ce43b8c8c5
     90c7b830bef4baf225c2eb8b7ead0cab)


build() {
  patch -Np1 -i "${srcdir}/glib2.0_2.26.0-0ubuntu1.diff"
  cd "${srcdir}/glib-${pkgver}"
  patch -Np1 -i "${srcdir}/debian/patches/71_gio_launch_handler.patch"
  ./configure --prefix=/usr \
      --sysconfdir=/etc \
      --with-pcre=system \
      --disable-fam
  make
  make DESTDIR="${pkgdir}" install

  install -d "${pkgdir}/etc/profile.d"
  install -m755 "${srcdir}/glib2.sh" "${pkgdir}/etc/profile.d/"
  install -m755 "${srcdir}/glib2.csh" "${pkgdir}/etc/profile.d/"
}

Last edited by nishantjr (2010-11-01 21:01:49)

Offline

#52 2010-11-01 21:29:09

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: Ayatana Project on Archlinux - official thread

Upload it on AUR and then tell the bamf contributor to point the dependency on this particular package.

Offline

#53 2010-11-04 01:57:50

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

any updates????

i uploaded the next packages


libindicate http://aur.archlinux.org/packages.php?ID=32049
ido http://aur.archlinux.org/packages.php?ID=34437
indicator-sound http://aur.archlinux.org/packages.php?ID=42614
evolution-indicator: http://aur.archlinux.org/packages.php?ID=42647
gtkhtml-editor: http://aur.archlinux.org/packages.php?ID=42648 (library needed by evolution-indicator)
indicator-popper: http://aur.archlinux.org/packages.php?ID=42667 this is a email notificator for indicator-messages

next in the todo list
python-appindicator (for support to indicators in python)
rhythmbox-indicator-plugin (integrate rhythmbox in the sound indicator): semi-done
pastie
indicator-workspace
and others crappy indicators wink

i've create a metapackage for all ayatana stuff
what is the best name?
ayatana? or what?



ohh, one more thing (jobs style wink )

y create a package for rhythmbox-indicator-plugin from ubuntu deb, and: now have indicator integration of rhythmbox, look
Pantallazo.png

see a few post down

Last edited by madek (2010-11-08 23:53:25)

Offline

#54 2010-11-05 19:09:00

fresh24
Member
From: Austria / Vienna
Registered: 2009-11-27
Posts: 28

Re: Ayatana Project on Archlinux - official thread

great work!

maybe you could name it to ayatana-ubuntu or something else.


"Arch Linux - One update away from learning chroot" - Griemak

Offline

#55 2010-11-05 21:53:29

arriagga
Member
From: Dominican Republic
Registered: 2010-04-01
Posts: 27

Re: Ayatana Project on Archlinux - official thread

madek, you're doing a very good job.  thanks

Offline

#56 2010-11-06 00:04:01

b0f00narch
Member
Registered: 2010-11-03
Posts: 13

Re: Ayatana Project on Archlinux - official thread

Is Ayatana a desktop environment ?  I have been reading the wiki, to me it seems by looking at the pictures that I am looking at a new DE. Like ubuntu(gnome) wants to chalenge KDE4 with this.

Last edited by b0f00narch (2010-11-06 00:04:24)

Offline

#57 2010-11-06 01:15:23

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

no, ayatana is a usability proyect, is focused in desktop simplicity, an is based on gnome, of course, with the way of unity, you can think that is a new DE, but at this moment only is a lot of applicatios centred to user, of course that, in the future, any thing is possible

Offline

#58 2010-11-06 11:43:21

blackdot
Member
Registered: 2010-11-06
Posts: 2

Re: Ayatana Project on Archlinux - official thread

How can I integrade pidgin to indicator-messages applet?
I add to directory /usr/share/indicators/messages/applications/ file pidgin, which contains:
/usr/share/applications/pidgin.desktop
So now I am able to see Pidgin in indicator-message applet. When I click on it, it starts pidgin, but that's all. No new notification to messages and no indication of running application in applet.
Thank you for any advice.

Offline

#59 2010-11-06 17:19:57

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

i work now in the pidgin-libnotify patched to indicators
i have a working version locally, maybe in the afternoon i upload, after a bit of clean the package

edit: new pkgbuils
rhythmbox-indicator-plugin http://aur.archlinux.org/packages.php?ID=43262 (works fine with indicator-sound)
pidgin-libnotify-ubuntu http://aur.archlinux.org/packages.php?ID=43264 (support for notify-osd and indicator)
indicator-appmenu http://aur.archlinux.org/packages.php?ID=43266 (I don't know your function exactly)

if you have a better way to install pidgin-libnotify-ubuntu from source packages instead from a .deb please share

this is a proposed pkgbuild for a metapackage

# Contributor: Madek <gonzaloseguel@gmail.com>

pkgname=ayatana-ubuntu
pkgver=1.0
pkgrel=1
pkgdesc="Metapackage for ayatana usability project, based in ubuntu packages"
arch=('any')
url="https://bbs.archlinux.org/viewtopic.php?pid=848833"
license=('GPL')
depends=('indicator-applet' 'indicator-me' 'indicator-session' 'indicator-application' 'indicator-messages')
optdepends=('indicator-sound' 'indicator-datetime' 'indicator-appmenu' 'evolution-indicator' 'rhythmbox-indicator-plugin' 'pidgin-libnotify-ubuntu' 'indicator-popper')
source=()
md5sums=()

build() {
  return 0
}

Last edited by madek (2010-11-09 00:17:42)

Offline

#60 2010-11-09 09:05:18

mirandir
Member
Registered: 2010-11-09
Posts: 55
Website

Re: Ayatana Project on Archlinux - official thread

Hi,

I have edited the pidgin-libnotify PKGBUILD, it works with notify-osd and indicator :

# Contributor: mirandir <mirandir[AT]orange[DOT]fr>

pkgname=pidgin-libnotify-ubuntu
realname=pidgin-libnotify
pkgver=0.14
pkgrel=4ubuntu1
arch=('i686' 'x86_64')
pkgdesc="Patched pidgin-libnotify version for notify-osd and indicators"
url="http://gaim-libnotify.sourceforge.net/"
license=('GPL')
depends=('pidgin' 'libnotify' 'perlxml' 'gettext' 'libindicate')
makedepends=('libtool' 'intltool')
replaces=('gaim-libnotify')
conflicts=('pidgin-libnotify')
provides=('pidgin-libnotify')
source=(http://downloads.sourceforge.net/sourceforge/gaim-libnotify/$realname-$pkgver.tar.gz
http://archive.ubuntu.com/ubuntu/pool/main/p/pidgin-libnotify/pidgin-libnotify_0.14-4ubuntu1.debian.tar.gz updatefrpo.patch)
md5sums=('bfb5368b69c02d429b2b17c00a6673c0'
         '613b91f80a8d09a0dc324cdc1ea52c11' 'aaea6a9a16f08648a876a5d4b939fa3b')

build() {
  cd $srcdir/
  patch -p0 < debian/patches/de_po.diff || return 1
  patch -p0 < debian/patches/indicate.patch || return 1
  patch -p0 < debian/patches/indicate-autotools.patch || return 1
  patch -p0 < debian/patches/force-load.patch || return 1
  patch -p0 < debian/patches/it_po.diff || return 1
  patch -p0 < ../updatefrpo.patch || return 1
  cd $realname-$pkgver
  ./configure --prefix=/usr --disable-deprecated
  make || return 1
  make DESTDIR=$startdir/pkg install
}

I also updated the French translation (the updatefrpo.patch file) :

--- pidgin-libnotify-0.14/po/fr.po.orig    2007-06-30 20:53:22.000000000 +0200
+++ pidgin-libnotify-0.14/po/fr.po 2010-11-05 18:49:22.000000000 +0100
@@ -26,51 +26,44 @@

 #: src/pidgin-libnotify.c:67
 msgid "Ignore events from blocked users"
-msgstr "Ignorer les evenements des utilsateurs bloqués"
+msgstr "Ignorer les événements des utilisateurs bloqués"

 #: src/pidgin-libnotify.c:72
 msgid "Buddy signs on"
 msgstr "L'utilisateur se connecte"

 #: src/pidgin-libnotify.c:77
-#, fuzzy
 msgid "Buddy signs off"
-msgstr "L'utilisateur se connecte"
+msgstr "L'utilisateur se déconnecte"

-#: src/pidgin-libnotify.c:315
+#: src/pidgin-libnotify.c:505
 msgid "Show"
 msgstr "Montrer"

-#: src/pidgin-libnotify.c:347
+#: src/pidgin-libnotify.c:538
 #, c-format
-msgid "%s signed on"
-msgstr "%s s'est connecté"
-
-#: src/pidgin-libnotify.c:379
-#, fuzzy, c-format
-msgid "%s signed off"
-msgstr "%s s'est connecté"
+msgid "is online"
+msgstr "est connecté"

-#: src/pidgin-libnotify.c:406
+#: src/pidgin-libnotify.c:567
 #, c-format
-msgid "%s says:"
-msgstr "%s dit :"
+msgid "is offline"
+msgstr "est déconnecté"

-#: src/pidgin-libnotify.c:572
+#: src/pidgin-libnotify.c:1360
 msgid "Libnotify Popups"
 msgstr "Popups Libnotify"

-#: src/pidgin-libnotify.c:573
+#: src/pidgin-libnotify.c:1361
 msgid "Displays popups via libnotify."
 msgstr "Affiche des popups via libnotify."

-#: src/pidgin-libnotify.c:574
-#, fuzzy
+#: src/pidgin-libnotify.c:1362
 msgid ""
 "Pidgin-libnotify:\n"
 "Displays popups via libnotify."
 msgstr ""
-"Gaim-libnotify:\n"
+"Pidgin-libnotify:\n"
 "Affiche des messages via libnotify."

 #~ msgid "Libnotify Interface"

Offline

#61 2010-11-09 16:27:29

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

today work
python-appindicator: python bindings for indicators http://aur.archlinux.org/packages.php?ID=43372 (ugly pkgbuild but works fine)
indicator-pastie: clipboard manager http://aur.archlinux.org/packages.php?ID=43373
indicator-workspaces: http://aur.archlinux.org/packages.php?ID=43375
indicator-datetime: http://aur.archlinux.org/packages.php?ID=43436 (i build it some days ago, but i forget it upload)
I uptaded pkgbuild of pidgin-libnotify-ubuntu with the mirandir info adn patch, thanks

for me. the works is done: only litle things is pendings

if you want another indicator for specific aplication, you can search ideas here
http://www.omgubuntu.co.uk/tag/indicatorapplets/
or you can put directly in this thread

Last edited by madek (2010-11-12 13:43:54)

Offline

#62 2010-11-10 23:29:29

fresh24
Member
From: Austria / Vienna
Registered: 2009-11-27
Posts: 28

Re: Ayatana Project on Archlinux - official thread

still nice work smile

indicator-workspaces needs deb2targz as dependency


"Arch Linux - One update away from learning chroot" - Griemak

Offline

#63 2010-11-12 13:27:22

Janhouse
Member
Registered: 2010-10-02
Posts: 28

Re: Ayatana Project on Archlinux - official thread

Can someone please update first post to make some sense?
There are now packages libindicate and libindicate-bzr etc.
And there are 3 maintainers!

Looks like mess and I am not sure what packages to install for them to work.

Should I use packages by Madek, Gianfrix or Dinth?

Offline

#64 2010-11-12 13:55:30

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

you can use the bzr branch of all packages, dinth pkgbuilds
or you can use the stable branch, bassed in the ubuntu sources, with the pkgbuilds of gianfrix and me (both works togheter)
i recommend the stable branch, is more up to date and works better

you can use a metapackage for all stuff: ayatana-ubuntu http://aur.archlinux.org/packages.php?ID=43437
only have i litle thing, the packages indicator-session and indicator-me was outdated, but i post a message in the aur page with the updated pkgbuild
please update pkgbuild locally when go to install this packages

pd: some mod please, update the first post with the new info, specially with the metapackage for stable branch

see ya!!!

Offline

#65 2010-11-12 14:17:53

Janhouse
Member
Registered: 2010-10-02
Posts: 28

Re: Ayatana Project on Archlinux - official thread

Thx for fast reply Madek!

Don't know if you still need it but I updated utouch-geis and utouch-grail in the AUR.
Tell me if I had to add some patches or something.


Can you please add xchat indicator? (not xchat-gnome).
Never mind... I created xchat-indicator http://aur.archlinux.org/packages.php?ID=43442 for xchat
But it doesn't hide tray icon automatically. Any ideas how to do that?
I can hide tray icon but then it will close instead of minimizing to that applet.

And how can we remove that "Setup broadcast account" button from indicator applet?

Last edited by Janhouse (2010-11-12 17:28:31)

Offline

#66 2010-11-12 17:53:13

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

ok, added xchat-indicator and indicator-usb http://aur.archlinux.org/packages.php?ID=43444 to the metapackage

i have no idea how hide tray icon automatically and how actiave plugin automatically at start

Offline

#67 2010-11-12 18:55:29

lucain
Member
From: Mexico
Registered: 2009-10-25
Posts: 19
Website

Re: Ayatana Project on Archlinux - official thread

I' had some trouble to install libindicate  and libdbusmenu, it needed to edit both PKGBUILDs

With libdbusmenu a comment by arriagga says that editing the ./configure --prefix=/usr with ./configure --prefix=/usr --disable-static --enable-introspection=no it will compile

With libindicate is the same workaround: Just edit the PKGBUILD in this line:

./configure --prefix=/usr --disable-static --disable-instrospection || return 1

replace --disable-instrospection with --enable-introspection=no it will look like

./configure --prefix=/usr --disable-static --enable-introspection=no || return 1

Please update the PKGBUILDs

Offline

#68 2010-11-14 11:34:09

Szelek
Member
From: Warsaw
Registered: 2008-09-03
Posts: 86

Re: Ayatana Project on Archlinux - official thread

I have a problem installing indicator-applet.

After compiling, when package is being installed, following error is thrown:
"indicator-applet: /usr/lib/bonobo/servers/GNOME_FastUserSwitchApplet.server exists in file system"

Offline

#69 2010-11-14 12:48:21

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

install with -f option

Offline

#70 2010-11-16 16:15:23

gregmits
Member
From: Xanthi, Greece
Registered: 2010-11-01
Posts: 17

Re: Ayatana Project on Archlinux - official thread

lucain wrote:

I' had some trouble to install libindicate  and libdbusmenu, it needed to edit both PKGBUILDs

With libdbusmenu a comment by arriagga says that editing the ./configure --prefix=/usr with ./configure --prefix=/usr --disable-static --enable-introspection=no it will compile

With libindicate is the same workaround: Just edit the PKGBUILD in this line:

./configure --prefix=/usr --disable-static --disable-instrospection || return 1

replace --disable-instrospection with --enable-introspection=no it will look like

./configure --prefix=/usr --disable-static --enable-introspection=no || return 1

Please update the PKGBUILDs

I managed to install libdbusmenu but even after editing the PKGBUILD of libindicate i get the error :

./IndicatorMonoExample.cs(28,75): error CS0234: The type or namespace name `ServerDisplayArgs' does not exist in the namespace `Indicate'. Are you missing an assembly reference?

Any ideas?

Offline

#71 2010-11-16 19:44:35

Anaki
Member
Registered: 2008-05-14
Posts: 8

Re: Ayatana Project on Archlinux - official thread

For months i couldn't compile some of these packages (like libdbusmenu, libindicate), but last week i suceeded in compiling, by using a clean chroot: https://wiki.archlinux.org/index.php/De … ean_Chroot

Offline

#72 2010-11-20 16:12:31

Ptiwee
Member
Registered: 2010-11-20
Posts: 8

Re: Ayatana Project on Archlinux - official thread

Is there any way to translate the indicators ? I'm french, all my desktop is in french except indicators :s
Thanks

Offline

#73 2010-11-22 16:11:22

biniou
Member
From: France
Registered: 2009-07-07
Posts: 33

Re: Ayatana Project on Archlinux - official thread

Good question, I'm french too tongue
Unfortunately, I have troubles to compile some packages. I have been forced to install some -bzr packages because the "normal" ones didn't work. I say that but I realize the huge work for maintaining all these packages and I thank you !

PS: sorry for my very bad english. Again, I'm french so...lol

Offline

#74 2010-11-22 17:30:35

canuckkat
Member
Registered: 2009-08-28
Posts: 44

Re: Ayatana Project on Archlinux - official thread

So I finally got indicator-me installed. I left little notes on all the packages that I had problems on (mainly pkgbuild errors and missing dependencies).

The one real issue is that I got this when installing indicator-session

I/O warning : failed to load external entity "/usr/share/gconf/schemas/indicator-session.schemas"
Failed to open `/usr/share/gconf/schemas/indicator-session.schemas': No such file or directory

Offline

#75 2010-11-29 16:00:14

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 40
Website

Re: Ayatana Project on Archlinux - official thread

I'm back after lots of time big_smile
I have a package for those who want language packs for their indicators... as soon as I boot my Linux box I'll upload it. Also I'd want to give some love to LXDE too tongue

@Madek: If you want I can orphan my indicators packages flagged out of date if you want to update them.


~ Gianfrix
There's no place like 127.0.0.1

Offline

Board footer

Powered by FluxBB