You are not logged in.

#1 2005-04-30 22:58:34

demonus
Member
Registered: 2005-01-31
Posts: 62

alsa, kernels 2.6.x

did anyone notice that something weird is happening in new kernels? say in 2.6.8 I could play mp3s with mpg321 or anything else even when some other app was using the disk heavily, but now on 2.6.11.7 (own build) it's impossible, xmms stops (freezes rather during playback and I can only play the track again), the same goes for mpg321;
heh and not only when the disk is read by other app heavily but also when let's say you pop up a firefox window (high cpu usage) xmms stops
any clues?

Offline

#2 2005-05-01 00:45:53

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: alsa, kernels 2.6.x

This is your own kernel build? Did you enable DMA on the hard disk?

Offline

#3 2005-05-01 06:42:45

leeghoofd
Member
From: the Netherlands
Registered: 2005-04-28
Posts: 61

Re: alsa, kernels 2.6.x

Try

hdparm -d device

to see if DMA is enabled

edit: should be -d, install hdparm with pacman -S hdparm if you don't have it

regards,
david

Offline

#4 2005-05-01 07:25:40

demonus
Member
Registered: 2005-01-31
Posts: 62

Re: alsa, kernels 2.6.x

dma is enabled and supported by kernel

update:
I get "Alsa: underrun..." messages randomly when playing sound with mpg321

Offline

#5 2005-05-01 10:57:15

eric
Member
From: under heaven
Registered: 2004-02-11
Posts: 110

Re: alsa, kernels 2.6.x

You can try to increase the buffer size in your sound engine configfile (mine is /etc/asound.conf).

Offline

#6 2005-05-01 12:33:10

Michel
Member
From: Belgium
Registered: 2004-07-31
Posts: 286

Re: alsa, kernels 2.6.x

Heya,

maybe changing i/o-scheduler can also help.

there are 3 disk schedulers: anticipatory (the default one), deadline and cfq. Cfq is recommended for desktop usage.

You can find more info about them on the following link:
http://awlinux1.alphaworks.ibm.com/deve … uler.shtml

It seems there is another disk scheduler: Noop

On the folling link you can find which parameter to give to the kernel to change your i/o-scheduler:
http://awlinux1.alphaworks.ibm.com/deve … html#begin
the parameter is:
elevator:<name of i/o-scheduler>

I just found the above links. It seems a nice site ...

Hopes this helps,

Michel

Offline

Board footer

Powered by FluxBB