You are not logged in.

#1 2010-11-11 10:58:23

Darkwind
Member
Registered: 2007-05-06
Posts: 58

[SOLVED]Atheros AR5001 connection issues

Hello

My girlfriend has a laptop with an Atheros AR500w wireless card in it.

lspci
07:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)

I had some initial problems setting it up but it worked fine until yesterday when it simply stopped. It was using the madwifi drivers as I could not get ath5k to work (even wireless-compat failed).

It currently refuses to pick up any networks - I know it is within range as it is closer to the router then I am while I write this.

iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wifi0     Interface doesn't support scanning.

ath0      No scan results

I've tried using ath5k and the wireless-compat ath5k but no luck.

sudo iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

Does anybody have any ideas? If you want more data, let me know what you want and I'll post it up here.
Many thanks
C

Last edited by Darkwind (2010-11-11 19:17:58)

Offline

#2 2010-11-11 12:04:52

Gusar
Member
Registered: 2009-08-25
Posts: 3,581

Re: [SOLVED]Atheros AR5001 connection issues

Is it an Acer laptop? See here then, regarding the hardware switch: https://bbs.archlinux.org/viewtopic.php?id=107314

Offline

#3 2010-11-11 19:17:30

Darkwind
Member
Registered: 2007-05-06
Posts: 58

Re: [SOLVED]Atheros AR5001 connection issues

No, it's not a Acer - It's a HP. However, unlocking it with rfkill fixed the problem - thought it still seems not to be able to scan.

many thanks

C

Offline

Board footer

Powered by FluxBB