You are not logged in.

#1 2010-09-30 23:03:34

xdemo
Member
From: Bristol, UK
Registered: 2010-06-10
Posts: 42

[SOLVED] Firefox/xulrunner crashing since update

------------------------------------------------------------
EDIT
Adobe flash, causing yet another problem -.-
------------------------------------------------------------

Since the xulrunner update the other day (xulrunner 1.9.2.10-2)...
My firefox keeps locking up randomly, certain sites seem to cause it last.fm and mediafire.com being the worst causing an instant freeze where i have to kill firefox. Yet i can browse bbc news / firefox personas websites for ages without any problems.

I first tried enabling flashblock in case of adobe's malware magnet causing the crashes, but no effect. I then get warnings about adblock plus / noscript causing an unresponsive script error. So i disabled all add-ons... this time the browser just locks up without a warning.

What is going on?
I'm guessing the sites that crash firefox, have something in common...
I have tried reinstalling firefox / xulrunner and anything related, i'm not sure how to go about fixing this. Any suggestions?


I'll also add about the script errors:
screenshot0930201011541.th.png

That seems related to ad block plus, but if i remove the add-on altogether, and try to load the same page, the browser crashes/locks up, without an error. I'm beginning to think the xulrunner update has broken something. o.o

If i run firefox from a terminal and visit http://last.fm/ i get spammed with this (browser also locks up)

/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
*** NSPlugin Wrapper *** WARNING:(/build/src/nspluginwrapper-1.3.0/src/npw-wrapper.c:3160):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))
NOTE: child process received `Goodbye', closing down
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
*** NSPlugin Wrapper *** WARNING:(/build/src/nspluginwrapper-1.3.0/src/npw-wrapper.c:3160):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))
NOTE: child process received `Goodbye', closing down
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libxcb-render-util.so.0: cannot open shared object file: No such file or directory
*** NSPlugin Wrapper *** ERROR: failed to initialize plugin-side RPC client connection
*** NSPlugin Wrapper *** WARNING:(/build/src/nspluginwrapper-1.3.0/src/npw-wrapper.c:3160):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))
NOTE: child process received `Goodbye', closing down
^C

Yet:

$ pacman -Ss libxcb
extra/libxcb 1.7-1 [installed]
    X11 client-side library
multilib/lib32-libxcb 1.7-2 [installed]
    X11 client-side library (32-bit)

Thats adobe flash player right?
I usually have flashblock/noscript to stop flash adverts loading... but since the xulrunner update nothing can "block" them it seems.

Last edited by xdemo (2010-10-01 00:16:19)


Linux 2.6.38-ck x86_64 / xfce

Offline

#2 2010-10-01 00:15:19

xdemo
Member
From: Bristol, UK
Registered: 2010-06-10
Posts: 42

Re: [SOLVED] Firefox/xulrunner crashing since update

Well it seems 32bit flash (on x86_64) doesn't work since updating xulrunner... i simply remove the flashplugin from the multilib repo, and installed this one: http://aur.archlinux.org/packages.php?ID=32072

Seems to be working ok for now (and flashblock / noscript are working again).
smile


Linux 2.6.38-ck x86_64 / xfce

Offline

#3 2010-10-02 21:09:36

sekenre
Member
Registered: 2009-04-14
Posts: 16

Re: [SOLVED] Firefox/xulrunner crashing since update

Hi,

I had the same problem and it was caused by a missing dependency of lib32-xcb-util. Install that, and your multilib flash player should work fine.

Cheers,
Sek

Offline

#4 2010-10-02 21:24:12

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] Firefox/xulrunner crashing since update

fixed once for all that xcb-utils issue. after updating lib32-gtk2 and lib32-pango reinstall flashplugin


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2010-11-17 16:53:18

Tetsumaki
Member
Registered: 2010-11-17
Posts: 6

Re: [SOLVED] Firefox/xulrunner crashing since update

Hello i have the same problem and it's solved with this :

pacman -Rsn flashplugin
pacman -S flashplugin-prerelease

And on Firefox :

about:config
dom.ipc.plugins.enabled = true

It is a good solution until a new version of "flashplugin".

Offline

Board footer

Powered by FluxBB