You are not logged in.

#26 2010-11-25 22:44:43

rowp
Member
Registered: 2010-04-12
Posts: 12

Re: [kde-unstable] KDE 4.6

Enabled [TESTING] and installed just the packages in question - this fixed all my issues (well the Major ones)

Only small things with plasma workspaces that i can see so far, but everything so far is very stable.

Wow this is an awesome release - Just completed my 'Kmail migration' which completed without a problem ; )

Offline

#27 2010-11-25 23:25:26

jxy
Member
Registered: 2008-12-03
Posts: 133

Re: [kde-unstable] KDE 4.6

bash wrote:
Zom wrote:

Is suspend disabled or unimplemented right now? I have udev, udisks and upower installed. HAL is not running.

this is up to consolekit now, and in fact this works:

dbus-send --system --print-reply --dest="org.freedesktop.UPower" /org/freedesktop/UPower org.freedesktop.UPower.Suspend

but I see no sleep option in KDE, maybe is not implemented yet.

Do you also happen to know a way to lock the screen using command line?  I want to put them in a script so I can run that script instead of shutdown.

Offline

#28 2010-11-25 23:34:51

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

jxy wrote:

Do you also happen to know a way to lock the screen using command line?  I want to put them in a script so I can run that script instead of shutdown.

put that string in ~/something.sh and made the script executable, then go to System Settings -> Shortcuts and Gestures -> Custom Shortcuts -> Edit -> New -> Global Shortcut -> Command/Url
and add ~/something.sh to Action
Also you can set a "D-bus Command" shortcut that does not require a script, but I don't know how to setup it.

Offline

#29 2010-11-26 00:35:50

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: [kde-unstable] KDE 4.6

Upgraded and all seems to work fine.


Excuse my poor English.

Offline

#30 2010-11-26 08:04:49

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.6

@bash:
That worked brilliantly. Thanks!

Offline

#31 2010-11-26 08:25:01

Emericn6k
Member
From: Toulouse
Registered: 2010-06-22
Posts: 13

Re: [kde-unstable] KDE 4.6

I've made the update yesterday evening too and was absolutely impressed by the changes (kde feels quicker now, visual effects seem better etc.) and by the fact that the update worked flawlessly.

I've only got a few problems with nepomuk/strigi not running due to some error, but I have had no time to investigate further yet.

Last edited by Emericn6k (2010-11-26 08:25:36)


"In a world without fences and walls, who needs Gates and Windows"

Offline

#32 2010-11-26 11:26:28

chromatic
Member
From: France
Registered: 2008-02-21
Posts: 26

Re: [kde-unstable] KDE 4.6

Hi, I found some bugs :

1) In kontact, when I click on korganizer or the todo list,  there's an error message about missing libeventviews.so.4. I think this library is part of kdepimlibs, but i'm not sure.
2) polkit-kde from extra should be replaced with polkit-kde-agent-1 from git.kde.org.

I can confirm that my soundcard isn't detected by phonon without hal, I found this on the KDE devel hardware mailing list about libsolid :

> And I don't know if I have to implement the next:
>
> - AudioInterface
> - Video

Would be nice, but we hopefully can live without them. The Phonon people might
hate us for releasing without support for those though.

So, a fully HALess KDE seems to be for 4.7 ^^

Thanks for the 4.6 packages smile

Offline

#33 2010-11-26 11:35:52

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

@chromatic
about 1), kdepim-libkdepim-4.5.80-2 should be already on the mirrors, it provides that library.

about 2) thanks, we already use polkit-kde-1 in [extra], but I am updating it to a snapshot from git in [kde-unstable]

about HAL, I can use my soundcard only with phonon-gstreamer backend. I really hope they implement Audio support without HAL with every phonon backend

Offline

#34 2010-11-26 12:30:16

chromatic
Member
From: France
Registered: 2008-02-21
Posts: 26

Re: [kde-unstable] KDE 4.6

bash wrote:

about 1), kdepim-libkdepim-4.5.80-2 should be already on the mirrors, it provides that library.

Ok, thanks for the fix.

bash wrote:

about HAL, I can use my soundcard only with phonon-gstreamer backend. I really hope they implement Audio support without HAL with every phonon backend

I've tried all the backends, xine and gstreamer from testing, vlc from git and everytime I Iaunch a phonon app without HAL there's a popup window telling me this (approximatly translated from french):
The HDA Intel (Connexant Analog) audio device isn't working. Falling back to default.

No HAL = no sound for me sad

Offline

#35 2010-11-26 12:32:21

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

try installing gstreamer, then remove ~/.kde4/share/config/phonondevicesrc ~/.config/kde.org/libphonon.conf ~/.config/kde.org/Phonon*, logout

Offline

#36 2010-11-26 12:54:54

chromatic
Member
From: France
Registered: 2008-02-21
Posts: 26

Re: [kde-unstable] KDE 4.6

bash wrote:

try installing gstreamer, then remove ~/.kde4/share/config/phonondevicesrc ~/.config/kde.org/libphonon.conf ~/.config/kde.org/Phonon*, logout

gstreamer and all the plugins are installed and I already tried to remove those files yesterday ^^
The funny thing is that phonon doesn't detect the HDA intel chipset on my laptop but it detect the HDA HDMI ATI audio output.

I'll fill a report on bugs.kde.org when i'll have more time...

Anyway, thanks for your help smile

Offline

#37 2010-11-26 14:15:56

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: [kde-unstable] KDE 4.6

I don't have problems with my soundcard... i have phonon-mplayer-git installed.

K3b and K3b-svn can't detect my dvd drive without hal. At this moment this is the only issue i 've found with kde 4.6. Another little bug is i can't expand youtube windows player with konqueror, but this bug is present on 4.5.3 also.

To be honest, i can't see many differences between 4.5 and 4.6.


Excuse my poor English.

Offline

#38 2010-11-26 14:34:48

madgnu
Member
From: Saint-Petersburg
Registered: 2009-12-27
Posts: 10

Re: [kde-unstable] KDE 4.6

@bash:

Hi. There are a small version issue with polkit-kde-1:

warning: polkit-kde: local (0.95.1-2) is newer than kde-unstable (git20101126-1)

UPD: Hmmm... It works after manual installation of this package. Pacman is strange thing smile

Also, would be great if there are will be a snapshot of KDevelop in [kde-unstable], because stable version don't work with 4.6 sad

Last edited by madgnu (2010-11-26 14:39:05)

Offline

#39 2010-11-26 15:17:28

madgnu
Member
From: Saint-Petersburg
Registered: 2009-12-27
Posts: 10

Re: [kde-unstable] KDE 4.6

Sleep and hibernate still not work without hal (even with polkit-kde-git20101126-1).

Dolphin and removable devices tray applet are incredible slooooow.

Offline

#40 2010-11-26 16:12:07

venky80
Member
Registered: 2007-05-13
Posts: 996

Re: [kde-unstable] KDE 4.6

what is the best backend for phonon which plays everything...with minimal deps..?


DELL XPS 1640 with ATI Mobility Radeon  HD 3670. Arch Linux KDE Minimal Install

Offline

#41 2010-11-26 16:27:50

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 406

Re: [kde-unstable] KDE 4.6

Xine or mplayer I'd guess, but there really isn't a "best" backend.

Offline

#42 2010-11-26 16:57:45

stavallo
Member
Registered: 2010-05-28
Posts: 34

Re: [kde-unstable] KDE 4.6

madgnu wrote:

Also, would be great if there are will be a snapshot of KDevelop in [kde-unstable], because stable version don't work with 4.6 sad

There are kdevplatform-git and kdevelop-git in AUR. I built those myself and now I can run KDevelop again.

Offline

#43 2010-11-26 18:02:19

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: [kde-unstable] KDE 4.6

venky80 wrote:

what is the best backend for phonon which plays everything...with minimal deps..?

phonon-vlc-git works nicely here

Offline

#44 2010-11-26 18:16:21

SanskritFritz
Member
From: Budapest, Hungary
Registered: 2009-01-08
Posts: 1,615
Website

Re: [kde-unstable] KDE 4.6

adee wrote:
venky80 wrote:

what is the best backend for phonon which plays everything...with minimal deps..?

phonon-vlc-git works nicely here

Thank you for this advice!


zʇıɹɟʇıɹʞsuɐs AUR || Cycling in Budapest with a helmet camera || Revised log levels proposal: "FYI" "WTF" and "OMG" (John Barnette)

Offline

#45 2010-11-26 19:24:17

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

@madgnu
Sorry, I won't package anything else then KDE (I am using kdevelop-git from AUR too, but if I had kdevelop I should add a lot of K<applications...so nothing!)

I'll fix polkit-kde adding 'force' option, also kdebase-workspace does not depend on polkit-kde and this should be fixed.

Offline

#46 2010-11-26 21:43:24

pano
Member
From: Stuttgart, Germany
Registered: 2008-09-08
Posts: 118

Re: [kde-unstable] KDE 4.6

updated and so far everything looks smooth :-)
thanks for these packages!

only problem I had is that the Migration of KMail did not import *all* of my mails.
I did solve this though (thanks to me copying .kde4 to another folder, before updating to kde-unstable):

1. installed KDEPIM and akonadi from [extra] again
2. entered .kde4 and removing the kmail files and folder(s)
3. copied my kmail folders/files from my .kde4 backup into .kde4
4. Started KMail (the one from [extra]) and exported all my Folders (with the feature in KMail itself (Archive Folders)
5. Installed KDEPIM, etc. from kde-unstable
6. Imported the importfile created in step 4

might be worth mentioning somewhere…

Offline

#47 2010-11-26 22:16:16

ToxinPowe
Member
Registered: 2010-11-26
Posts: 20

Re: [kde-unstable] KDE 4.6

I am absolutely impressed too. All is working faster and smoother than ever.

Thank you so much for the packages Bash!

Last edited by ToxinPowe (2010-11-26 22:16:46)

Offline

#48 2010-11-26 22:21:41

tuxador
Member
From: algeria
Registered: 2010-07-08
Posts: 45

Re: [kde-unstable] KDE 4.6

this update just broke akonadi and strigi and all related-stuff (kmail kopete etc)
it's said that a dependance is missing, libboost 1.45 
enabling testing didn't resolve this (only phono issuses wink )
how could i fix it ? (sorry for my poor english)


laptop LENOVO Ideapad Z570 i7 / 6GO RAM/GeForce 540
ARCHLINUX+KDE frameworks 5.3 (working great !)

Offline

#49 2010-11-26 22:48:14

xheyther
Member
Registered: 2009-10-18
Posts: 40

Re: [kde-unstable] KDE 4.6

I fixed the sound problem using phonon-vlc-git as advised previously in this topic (thanks btw !).

I also discovered that I can't shutdown or reboot my computer from the KDE. I have to swtich to some VT and switch to init 0 or init 6. I don't know where I can check some log to investigate that.

Offline

#50 2010-11-27 00:44:59

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.6

@tuxador
you need boost-libs 1.45.0 (which is in [testing])

@xheyther
check if polkit-kde and consolekit are installed

Offline

Board footer

Powered by FluxBB