You are not logged in.

#76 2010-11-29 17:41:34

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

ok gianfrix, disown it

pd: have you the gnome-panel-ubuntu and gnome-session-ubuntu?
if you have, can you upload please to the aur

Offline

#77 2010-12-03 11:51:03

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: Ayatana Project on Archlinux - official thread

IMHO this package must be uploaded as set for all dep as meta package or something like that. If not sometimes it can break your gnome panel like mine. gtk2-appmenu for example just break my panel 2 days ago


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#78 2010-12-03 12:46:01

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

please read the previous page
metapackage ayatana-ubuntu be in aur

Offline

#79 2010-12-03 17:00:51

lafka
Member
Registered: 2010-08-24
Posts: 9

Re: Ayatana Project on Archlinux - official thread

I started a Wiki page for this, i will try to finish it off over the next week.
Anyone managed to get all the parts working without any hacking?

Also this looks interesting: http://aur.archlinux.org/packages.php?ID=43437 anyone tried it?

Offline

#80 2010-12-03 17:11:39

hellnest
Member
From: $ dmesg | grep ATA
Registered: 2010-11-11
Posts: 194
Website

Re: Ayatana Project on Archlinux - official thread

just now will try the meta-package.


roll Snapping my own life roll
hmmgithubhmm
coolMyBlogcool

Offline

#81 2010-12-03 22:46:45

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

now indicator-applet can be port to libpanel-applet-3, so no need gnome-panel-bonobo. see: https://aur.archlinux.org/packages.php?ID=38319

Offline

#82 2010-12-04 02:49:06

lafka
Member
Registered: 2010-08-24
Posts: 9

Re: Ayatana Project on Archlinux - official thread

--2010-12-03 19:34:18--  http://launchpad.net/gwibber/trunk/2.32 … 2.2.tar.gz
Resolving launchpad.net... 91.189.89.223, 91.189.89.222
Connecting to launchpad.net|91.189.89.223|:80... connected.
HTTP forespřrsel sendt, mottar topptekster... 404 Not Found
2010-12-03 19:34:19 FEIL 404: Not Found.


The fetch needs to be replaced to following URL:

http://launchpad.net/gwibber/2.32/2.32. … 2.2.tar.gz

Don't have the time to look it up now, i will check it out when i wake up!


EDIT: Heres an updated PKGBUILD: http://aur.pastebin.com/G6PdBjps

Also posted to AUR so hopefully an update ASAP

Last edited by lafka (2010-12-04 02:57:01)

Offline

#83 2010-12-04 04:44:31

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

now there is networkmanager-applet with indicator support. and there is patch:
http://bazaar.launchpad.net/~mathieu-tl … n/patches/

but i have problem using it. by default, apply this patch need run autoreconf first, but ./configure still connot recognize --enable-appindicator, so have to remove detective part.

AC_ARG_ENABLE([indicator],
[  --enable-appindicator  Enables using libappindicator to draw the applet
                          on the screen, instead of the standard status icons.],
[
    PKG_CHECK_MODULES(APPINDICATOR, appindicator-0.1)
    AC_DEFINE([ENABLE_INDICATOR], 1, [Enable using libappindicator])
])

to

PKG_CHECK_MODULES(APPINDICATOR, appindicator-0.1)
AC_DEFINE([ENABLE_INDICATOR], 1, [Enable using libappindicator])

then the appindicator did show up, but it breaks my network connection. please test, if anyone have the same problem, i will report this to developer,

Last edited by jarryson (2010-12-04 04:44:53)

Offline

#84 2010-12-04 04:48:26

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

and i made a patch for indicator-me to compile with out gwibber and telephany-glib, please see AUR:

http://aur.archlinux.org/packages.php?ID=38322

and to the maintainer of -bzr package, please change _bzrbranch to _bzrtrunk, so that pacman can detect the latest bzr version automaticly

Offline

#85 2010-12-04 16:23:57

lafka
Member
Registered: 2010-08-24
Posts: 9

Re: Ayatana Project on Archlinux - official thread

Any tips on getting nux-bzr package to build?

I have buildt glewmx BUT i get the following error:

configure: error: Package requirements (glib-2.0 >= 2.25.14
                  gdk-pixbuf-2.0
                  glew
                  glewmx
                  ) were not met:

No package 'glewmx' found

Anyone got past that?

Last edited by lafka (2010-12-04 16:24:40)

Offline

#86 2010-12-04 17:49:38

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 38
Website

Re: Ayatana Project on Archlinux - official thread

See this screen tongue
lxdeindicators.png

Indicator applet working on LXDE! Just install this package: http://aur.archlinux.org/packages.php?ID=44156
Also, as you can see, my indicators are localized. Get this package from AUR, modify it to get your preferred language, update MD5s and install! You may need to overwrite some files using -f option in pacman.

Last edited by Gianfrix (2010-12-04 17:56:55)


~ Gianfrix
There's no place like 127.0.0.1

Offline

#87 2010-12-05 01:18:14

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

great work gianfrix

Offline

#88 2010-12-05 05:41:21

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

nautilus did not show desktop background, i can only change colors.

transmission svn with indicator support did not work propperly here. the transmission main window won't show at all, click the "show transmission" menu not working.

any one else have the same problems?

Last edited by jarryson (2010-12-05 05:47:18)

Offline

#89 2010-12-05 13:19:49

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

nautilus: no, i do'nt have any of theese issues ¿what version of nautilus use you?

transmission:sorry, i'm use deluge

Offline

#90 2010-12-05 16:37:28

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: Ayatana Project on Archlinux - official thread

never mind the nautilus problem, it's really wierd, i don't even know if it related to indicator.

but transmission and nm-applet really have problem with indicator.

simple way to test nm-appet with indicator( if you have already install network-manager-applet from arch repo ): http://ppa.launchpad.net/mathieu-tl/nm- … er-applet/

download and extract, no need install them, just enter usr/bin, and run ./nm-applet

PS: i tested the nm-applet from ppa and the one compiled myself, all have the same problem. but if i delete indicator-applet from gnome-panel, nm-applet will show in system tray, and this time it works normally.

PS2: i am using all -bzr version

Offline

#91 2010-12-05 22:02:14

biniou
Member
From: France
Registered: 2009-07-07
Posts: 33

Re: Ayatana Project on Archlinux - official thread

Hello everybody !
Thanks for all your work ! I have installed ayatana-ubuntu without any problem and it seems to be functionnal !

However, I have a problem with indicator-datetime which I can install but not launch. When I start "Indicator Applet Complete" (which worked before I try indicator-datetime), it is telling me that there was a problem while loading "OAFIID:Gnome_IndicatorAppletComplet". Do you know how I can fix this please?

Edit: It needed gnome-system-tools, my bad ! Everything works, the last thing I need is indicator-network. You're really doing a great work, I can't thank you enough ! big_smile

Last edited by biniou (2010-12-05 22:13:41)

Offline

#92 2010-12-06 15:44:20

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 38
Website

Re: Ayatana Project on Archlinux - official thread

madek wrote:

great work gianfrix

Thanks, but there's some extra work to do before getting them to work properly. I tried them in Lubuntu Live and logout didn't work OOTB as I thought it should. I tried doing that in Xubuntu and logout didn't work too. I'll create the indicator package for XFCE too, I want to get it working.

Also I'd want to propose something to you all. As the indicator infrastucture is desktop independent, in my opinion it would be better if there is a metapackage only for the base indicator packages (libdbusmenu, libindicator and so) and another package for people who want all the indicators like they are shown in GNOME by default. It could make the life easier for people who want not to use GNOME but wants indicators. Also consider that it would be better for indicators that are not working in other DEs (e.g. indicator-session, for now).
EDIT: Also think that ayatana project does not cover indicators only, but also notify-osd and unity.

Example:
Metapackage ayatana-indicators-baselibs installs: libdbusmenu, libindicator, libindicate and ido
After installing the base you can install ayatana-indicators-gnome that installs indicator-applet (which is gnome-only), indicator-session, indicator-me, indicator-messages, indicator-sound, etc., or ayatana-indicators-xfce for XFCE that excludes indicator-session (if it won't work).

What do you think about it?

lafka wrote:

I started a Wiki page for this, i will try to finish it off over the next week.

Do you need any help for that?

Last edited by Gianfrix (2010-12-06 15:45:29)


~ Gianfrix
There's no place like 127.0.0.1

Offline

#93 2010-12-06 16:42:47

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

i think this is a good idea, a base metapackage for libs, and separatelly metapackages for DE's
with the inclusion of notify-osd, I agree with you
but unity actually is broken in arch, i prefer to wait to gnome 3.0
eg: indicators-libs for base libs
indicators-gnome for gnome stuff, included notify-osd
indicators-lxde for this DE
and indicators-xxxxxx for another DE


pd: i made litle mods in ayatana wiki page

Offline

#94 2010-12-06 17:01:38

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 38
Website

Re: Ayatana Project on Archlinux - official thread

madek wrote:

i think this is a good idea, a base metapackage for libs, and separatelly metapackages for DE's
with the inclusion of notify-osd, I agree with you
eg: indicators-libs for base libs
indicators-gnome for gnome stuff, included notify-osd
indicators-lxde for this DE
and indicators-xxxxxx for another DE

OK, if you want I can take care of those metapackages.

but unity actually is broken in arch, i prefer to wait to gnome 3.0

Unity is broken even on Ubuntu as it's alpha-quality software xD
I'd prefer to package it as soon as Natty is released, with the stable packages released.


~ Gianfrix
There's no place like 127.0.0.1

Offline

#95 2010-12-06 18:57:50

biniou
Member
From: France
Registered: 2009-07-07
Posts: 33

Re: Ayatana Project on Archlinux - official thread

Good ideas, could be useful for a lot of people !

Beside that, do you know if there is a way to use networkmanager-applet with indicators ? I tried to use ConnMan but I didn't succeed to make it work (the indicator is in place, connman's daemon is running but the indicator doesn't shows any connection).

Another question for you because you rock ! I have indicator-session installed but I can't reboot or shutdown my computer. Maybe it is a permission problem. Do you know how to fix that ?

We, users, really appreciate what you're doing for us !

Last edited by biniou (2010-12-06 18:58:55)

Offline

#96 2010-12-06 20:21:18

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 38
Website

Re: Ayatana Project on Archlinux - official thread

biniou wrote:

Another question for you because you rock ! I have indicator-session installed but I can't reboot or shutdown my computer. Maybe it is a permission problem. Do you know how to fix that ?

I remember I got it working in GNOME a long time ago, but I don't remember how... I have to see between my old packages...

EDIT: BINGO! Two pages ago I posted a packages list... one of these was this:

Gianfrix wrote:

gnome-session-ubuntu 2.32.0-1 (Fixes slow startup, fixes shutdown with indicator-session and lets compiz-fusion start easily without icon using gconf)

I just have to find it in my archive and then makepkg --source it big_smile
EDIT: http://aur.archlinux.org/packages.php?ID=44214 <-- Here it is! big_smile
I didn't test it because I switched to XFCE, but it should work. I updated the package to 2.32.1, even if Ubuntu has 2.32.0, but the patched applied successfully.

Last edited by Gianfrix (2010-12-06 20:38:24)


~ Gianfrix
There's no place like 127.0.0.1

Offline

#97 2010-12-06 21:17:26

biniou
Member
From: France
Registered: 2009-07-07
Posts: 33

Re: Ayatana Project on Archlinux - official thread

Whoah, that was fast ! Thank you very much, I'll try it as soon as I can, maybe tonight ! big_smile
And sorry not have seen yours notes about gnome-session-ubuntu.

Offline

#98 2010-12-06 21:38:30

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

Gianfrix wrote:
madek wrote:

i think this is a good idea, a base metapackage for libs, and separatelly metapackages for DE's
with the inclusion of notify-osd, I agree with you
eg: indicators-libs for base libs
indicators-gnome for gnome stuff, included notify-osd
indicators-lxde for this DE
and indicators-xxxxxx for another DE

OK, if you want I can take care of those metapackages.

but unity actually is broken in arch, i prefer to wait to gnome 3.0

Unity is broken even on Ubuntu as it's alpha-quality software xD
I'd prefer to package it as soon as Natty is released, with the stable packages released.

don't problem

pd: can you upload gnome-panel-ubuntu and gnome-panel-bonobo-ubuntu

Last edited by madek (2010-12-06 21:43:44)

Offline

#99 2010-12-06 22:47:10

Gianfrix
Member
From: Locorotondo (BA) - Italy
Registered: 2009-10-21
Posts: 38
Website

Re: Ayatana Project on Archlinux - official thread

madek wrote:
Gianfrix wrote:
madek wrote:

i think this is a good idea, a base metapackage for libs, and separatelly metapackages for DE's
with the inclusion of notify-osd, I agree with you
eg: indicators-libs for base libs
indicators-gnome for gnome stuff, included notify-osd
indicators-lxde for this DE
and indicators-xxxxxx for another DE

OK, if you want I can take care of those metapackages.

but unity actually is broken in arch, i prefer to wait to gnome 3.0

Unity is broken even on Ubuntu as it's alpha-quality software xD
I'd prefer to package it as soon as Natty is released, with the stable packages released.

don't problem

pd: can you upload gnome-panel-ubuntu and gnome-panel-bonobo-ubuntu

I have gnome-panel-ubuntu, but not gnome-panel-bonobo-ubuntu. I'll release them when I can, but I'll have to create something like a chroot or a VM to test them as I'm not using GNOME anymore.

Second, I got indicators showing in my XFCE panel, but I'll need more time to make them work fully, maybe patching xfce by myself if I can tongue
In the end, ayatana-indicators-baselibs metapackage is ready and will be uploaded soon... now I'm going to bed tongue


~ Gianfrix
There's no place like 127.0.0.1

Offline

#100 2010-12-06 22:57:22

madek
Member
From: Santiago, Chile
Registered: 2009-09-08
Posts: 98
Website

Re: Ayatana Project on Archlinux - official thread

ok
pd: you can upload gnome-panel-ubuntu and i make gnome-panel-bonobo-ubuntu

Offline

Board footer

Powered by FluxBB